Using roo to avoid need for Excel to be installed


D

David Schulberg

I have installed rubyzip and roo gems to bypass the need to have excel
installed when reading excel workbooks.

When I do in irb
require 'zip/zipfilesystem'
require 'roo'

I get error

C:/Ruby/lib/ruby/gems/1.8/gems/nokogiri-1.4.0-x86-mswin32/lib/nokogiri/xml/build
er.rb:272: warning: parenthesize argument(s) for future version
LoadError: no such file to load -- spreadsheet
from
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `ge
m_original_require'
from
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `re
quire'
from C:/Ruby/lib/ruby/gems/1.8/gems/roo-1.9.2/lib/roo/excel.rb:2
from
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `ge
m_original_require'
from
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `re
quire'
from C:/Ruby/lib/ruby/gems/1.8/gems/roo-1.9.2/lib/roo.rb:69
from
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `ge
m_original_require'
from
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `re
quire'
from (irb):2

There is something about this topic on the German version of this forum
http://forum.ruby-portal.de/viewtopic.php?f=1&t=10616 but it says
everything should be fine after I have specified the two requires.

David
 
Ad

Advertisements

T

Thomas Preymesser

[Note: parts of this message were removed to make it a legal post.]

2009/12/14 David Schulberg said:
I have installed rubyzip and roo gems to bypass the need to have excel
installed when reading excel workbooks.

When I do in irb
require 'zip/zipfilesystem'
require 'roo'

I get error


C:/Ruby/lib/ruby/gems/1.8/gems/nokogiri-1.4.0-x86-mswin32/lib/nokogiri/xml/build
er.rb:272: warning: parenthesize argument(s) for future version
LoadError: no such file to load -- spreadsheet
sorry, the dependencies from other gems were not defined in this release.

You need to install these gems:

'spreadsheet', '> 0.6.4'
'nokogiri', '>= 0.0.1'
'builder', '>= 2.1.2'
'gimite-google-spreadsheet-ruby','>= 0.0.5'
'febeling-rubyzip','>= 0.9.2'

-Thomas
 
Ad

Advertisements

J

Jocelyn Ireson-Paine

Thomas Preymesser wrote in post #873257:
sorry, the dependencies from other gems were not defined in this
release.

You need to install these gems:

'spreadsheet', '> 0.6.4'
'nokogiri', '>= 0.0.1'
'builder', '>= 2.1.2'
'gimite-google-spreadsheet-ruby','>= 0.0.5'
'febeling-rubyzip','>= 0.9.2'

-Thomas

I was able to install the first three, but "gem install" couldn't find
gimite-google-spreadsheet-ruby or febeling-rubyzip. I eventually managed
to satisfy dependencies by installing rubyzip (not rubyzip2 as mentioned
in hamlet's post) and google-spreadsheet-ruby.

Jocelyn Ireson-Paine
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top