Access denied due to security settings for intranet

Discussion in 'ASP .Net' started by K Viltersten, Oct 4, 2008.

  1. K Viltersten

    K Viltersten Guest

    I have created a virtual directory. When I type in
    http://localhost/myProject/test.html I get access denied with the
    explanaition that intranet settings are turned off as standard. I´ve been
    browsning around in the settings but I couldn´t find any suitable setting to
    change. The exact error message is:
    "http 401.3 access denied to ACL for the resource"

    All the settings I followed were standard wizard settings.

    Any pointers? What more information should I provide?

    --

    --
    Regards
    Konrad Viltersten
    --------------------------------
    sleep - a substitute for coffee for the poor
    ambition - lack of sense to be lazy
    K Viltersten, Oct 4, 2008
    #1
    1. Advertising

  2. K Viltersten

    George Guest

    The IIS accounts and ASP.NET accounts must have read access to those
    folders.
    If you had created your folder in Inetpub/wwwRoot then those permissions are
    inherited from the parent.
    If somewhere else (even if you moved it to Inetpub/wwwRoot) permissions are
    not set correctly.
    The easies way just to replicate permissions that any folder in
    Inetpub/wwwRoot has.

    George.

    "K Viltersten" <> wrote in message
    news:...
    >I have created a virtual directory. When I type in
    >http://localhost/myProject/test.html I get access denied with the
    >explanaition that intranet settings are turned off as standard. I´ve been
    >browsning around in the settings but I couldn´t find any suitable setting
    >to change. The exact error message is:
    > "http 401.3 access denied to ACL for the resource"
    >
    > All the settings I followed were standard wizard settings.
    >
    > Any pointers? What more information should I provide?
    >
    > --
    >
    > --
    > Regards
    > Konrad Viltersten
    > --------------------------------
    > sleep - a substitute for coffee for the poor
    > ambition - lack of sense to be lazy
    >
    George, Oct 4, 2008
    #2
    1. Advertising

  3. K Viltersten

    K Viltersten Guest

    > The IIS accounts and ASP.NET accounts must have read access to those
    > folders. If you had created your folder in Inetpub/wwwRoot then those
    > permissions are inherited from the parent. If somewhere else (even if you
    > moved it to Inetpub/wwwRoot) permissions are not set correctly. The easies
    > way just to replicate permissions that any folder in Inetpub/wwwRoot has.


    Ah, found it. I needed to add two users and
    assign permissions to them. The users were
    IUSR_computername and ASPNET. After i've
    added them to the the directory (with the
    default settings), it worked.

    Thanks!

    --
    Regards
    Konrad Viltersten
    ----------------------------------------
    May all spammers die an agonizing death;
    have no burial places; their souls be
    chased by demons in Gehenna from one room
    to another for all eternity and beyond.
    K Viltersten, Oct 6, 2008
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    2
    Views:
    505
  2. Fresh
    Replies:
    2
    Views:
    633
    Bo Persson
    Apr 22, 2008
  3. donet programmer
    Replies:
    3
    Views:
    1,535
    Gregory A. Beamer
    Nov 20, 2009
  4. NEtsdpace news
    Replies:
    2
    Views:
    146
    NEtsdpace news
    Sep 29, 2004
  5. gg23
    Replies:
    0
    Views:
    361
Loading...

Share This Page