Another Opera 7.54 Bug ?

Discussion in 'HTML' started by Dylan Parry, Nov 14, 2004.

  1. Dylan Parry

    Dylan Parry Guest

    [Opera forums/groups]
    > I don't know of any... care to give me an addy?


    The forums are on the Opera Website <url:http://my.opera.com/forums/>.
    I'll leave it to you to decide which is the most suitable one for your
    message.

    The newsgroups depend on whatever your NNTP server carries, or you can
    use the server provided by Opera. See
    <url:http://www.opera.com/newsgroups/> for more information.

    --
    Dylan Parry
    http://webpageworkshop.co.uk -- FREE Web tutorials and references
     
    Dylan Parry, Nov 14, 2004
    #1
    1. Advertising

  2. On this page (for example): http://davmagic.com/paint/PAGES2.html all
    the other popular Browsers get it right but Opera 7.54 does not render a
    list item marker (an Image of a "blue right-pointing triangle") for the
    first item (in the content section), or for the third item either (and
    more down the list)... both of which I have placed an Image within the
    <li>... tag.... like this:

    <ul style="list-style-image: url(path/here)">
    <li><img src="URL" align="right" alt="text" width="xx" height="yy">text
    here
    </ul>

    Curiously, if I place the text first before the Image tag, Opera then
    shows the marker... but this is not what I want because the Image aligns
    with the next list item and this does not look right...

    Any comments.... ?

    Web Design, Magic, Painting, Junking, More
    http://www.davmagic.com/
    Paint A House
    http://www.paintahouse.com/
    NOTE: This emailbox is CLOSED do NOT reply!!!
     
    Davmagic .Com, Nov 14, 2004
    #2
    1. Advertising

  3. Dylan Parry

    Dylan Parry Guest

    Davmagic .Com wrote:

    > Any comments.... ?


    Have you posted about this to any of the opera.* groups or to one of
    their forums?

    --
    Dylan Parry
    http://webpageworkshop.co.uk -- FREE Web tutorials and references
     
    Dylan Parry, Nov 14, 2004
    #3

  4. >From:
    >(Dylan Parry)
    >Have you posted about this to any of the
    >opera.* groups or to one of their forums?


    I don't know of any... care to give me an addy?

    Web Design, Magic, Painting, Junking, More
    http://www.davmagic.com/
    Paint A House
    http://www.paintahouse.com/
    NOTE: This emailbox is CLOSED do NOT reply!!!
     
    Davmagic .Com, Nov 14, 2004
    #4
  5. Dylan Parry

    Toby Inkster Guest

    Davmagic .Com wrote:

    > On this page (for example): http://davmagic.com/paint/PAGES2.html all
    > the other popular Browsers get it right but Opera 7.54 does not render a
    > list item marker (an Image of a "blue right-pointing triangle") for the
    > first item (in the content section), or for the third item


    Oooh! This time you do indeed seem to have found a real bug.

    It seems to be caused by the align="right". If you remove that attibute
    and the list item reappears. Replacing it with CSS ("float:right") doesn't
    help.

    An interesting bug. You ought to create a simplified example page and
    report it in opera.page-display.

    --
    Toby A Inkster BSc (Hons) ARCS
    Contact Me ~ http://tobyinkster.co.uk/contact
     
    Toby Inkster, Nov 14, 2004
    #5

  6. >From:
    >(Toby Inkster)
    >Oooh! This time you do indeed seem to
    >have found a real bug.
    >It seems to be caused by the align="right".
    >If you remove that attibute and the list
    >item reappears. Replacing it with CSS
    >("float:right") doesn't help.
    >An interesting bug. You ought to create a
    >simplified example page and report it in
    >opera.page-display.


    Thanks... I'm tired of trying to please Opera... by screwing up my
    code.... all the others get it right... but I guess I'll mess with it
    some more...

    BTW where the hell is opera.page-display ? Is that a News Group? Or
    what?

    Web Design, Magic, Painting, Junking, More
    http://www.davmagic.com/
    Paint A House
    http://www.paintahouse.com/
    NOTE: This emailbox is CLOSED do NOT reply!!!
     
    Davmagic .Com, Nov 14, 2004
    #6
  7. Dylan Parry

    Neredbojias Guest

    Without quill or qualm, Davmagic .Com quothed:

    > Thanks... I'm tired of trying to please Opera... by screwing up my
    > code.... all the others get it right... but I guess I'll mess with it
    > some more...


    I try to "appease" Mozilla 1.73 (now), IE 6.0, and Netscape 4.xx (if I
    choose) primarily. Of course, using "vanilla" html and css supposedly
    makes all browsers work correctly...

    --
    Neredbojias
    Contrary to popular belief, it is believable.
     
    Neredbojias, Nov 14, 2004
    #7
  8. Dylan Parry

    Toby Inkster Guest

    Davmagic .Com wrote:

    > Thanks... I'm tired of trying to please Opera... by screwing up my
    > code.... all the others get it right... but I guess I'll mess with it
    > some more...


    A couple of bullet point are hardly a life-or-death problem. Just leave
    it. If the bullet points are really important to you, then a non-breaking
    space (&nbsp;) between the <li> and the <img> seems to do it.

    > BTW where the hell is opera.page-display ? Is that a News Group?


    It is indeed, though not all news servers will carry it.

    --
    Toby A Inkster BSc (Hons) ARCS
    Contact Me ~ http://tobyinkster.co.uk/contact
     
    Toby Inkster, Nov 15, 2004
    #8
  9. in alt.html, Toby Inkster wrote:
    > Davmagic .Com wrote:
    >
    > > On this page (for example): http://davmagic.com/paint/PAGES2.html all
    > > the other popular Browsers get it right but Opera 7.54 does not render a
    > > list item marker (an Image of a "blue right-pointing triangle") for the
    > > first item (in the content section), or for the third item

    >
    > Oooh! This time you do indeed seem to have found a real bug.
    >
    > It seems to be caused by the align="right". If you remove that attibute
    > and the list item reappears. Replacing it with CSS ("float:right") doesn't
    > help.
    >
    > An interesting bug. You ought to create a simplified example page and


    I made that
    http://www.student.oulu.fi/~laurirai/_bugs/floatinlist.html

    > report it in opera.page-display.

    That too

    --
    Lauri Raittila <http://www.iki.fi/lr> <http://www.iki.fi/zwak/fonts>
     
    Lauri Raittila, Nov 18, 2004
    #9
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. altamir

    Opera's box model bug?

    altamir, Dec 10, 2003, in forum: HTML
    Replies:
    5
    Views:
    765
    altamir
    Dec 10, 2003
  2. Replies:
    6
    Views:
    464
  3. Robert Ludewig

    CSS bug in opera 7 ?

    Robert Ludewig, Aug 28, 2004, in forum: HTML
    Replies:
    13
    Views:
    740
    Robert Ludewig
    Aug 30, 2004
  4. Spartanicus

    Re: Opera table display problem/bug

    Spartanicus, Sep 5, 2004, in forum: HTML
    Replies:
    0
    Views:
    651
    Spartanicus
    Sep 5, 2004
  5. Bob
    Replies:
    24
    Views:
    1,580
Loading...

Share This Page