Apache Tomcat returns HTTP 502 response error

Discussion in 'Java' started by i.am.testing.it@gmail.com, Jul 31, 2006.

  1. Guest

    Hi Guys,

    I am having some difficulties on the Tomcat (or the Servlet), can
    anyone please help?

    Here is how I deploy my application:
    Apache <---> Tomcat <---> Servlet

    The phenomenon is like this:
    1. startup both Apache and Tomcat
    2. can access Tomcat via Apache
    3. after 2 hours, the Tomcat is not accessable
    3.1. can access Apache, and it returns 200 OK response
    3.2. can't access Tomcat via Apache, and it returns 502 Bad Gateway
    error from the log
    3.3. can't access Tomcat via browser, and it returns page not found
    error message

    Some facts:
    1. traffic isn't high at all, I have another controller environment
    with the similar setup, but there is no problem at all.
    2. both environments are having the same setup/configuration
    3. garbarge collection is doing less than 1 second each time
    4. no sign of out-of-memory issue

    Does anyone encounter this issuse before? I am running out of ideas
    though.

    Best regards,

    tikcireviva.
     
    , Jul 31, 2006
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    1
    Views:
    8,599
    Juan T. Llibre
    Feb 6, 2006
  2. (Pete Cresswell)
    Replies:
    9
    Views:
    477
    Blinky the Shark
    Apr 1, 2005
  3. jasp
    Replies:
    0
    Views:
    411
  4. in5n8
    Replies:
    0
    Views:
    1,352
    in5n8
    Aug 23, 2011
  5. James E Keenan
    Replies:
    1
    Views:
    195
    Matt Garrish
    Sep 18, 2005
Loading...

Share This Page