ASP.NET Deadlocks

Discussion in 'ASP .Net' started by Martin Blackstone [MVP - Exchange], Aug 23, 2003.

  1. We are seeing a lot of errors like the one below which when occur
    essentially lock up the ability to run the applications.
    I have browsed the support articles and they all seem to apply to the 1.0
    framework and advise a hotfix to correct the issue. But we are running the
    1.1 Framework.

    The articles suggest changing the timing of the responseDeadlockInterval
    setting, but don't say whether to increase it or decrease it.
    So which is it?

    Any help would be greatly appreciated.


    Event Type: Error
    Event Source: ASP.NET 1.1.4322.0
    Event Category: None
    Event ID: 1003
    Date: 8/22/2003
    Time: 2:53:32 PM
    User: N/A
    Computer: WEBSERVER
    Description:
    aspnet_wp.exe (PID: 3208) was recycled because it was suspected to be in a
    deadlocked state. It did not send any responses for pending requests in the
    last 300 seconds. This timeout may be adjusted using the <processModel
    responseDeadlockInterval> setting in machine.config.

    --
    Martin Blackstone
    MVP - Exchange

    http://www.swinc.com/resource/exchange.htm


    http://www.swinc.com/resource/e2kfaq_appxc.htm
     
    Martin Blackstone [MVP - Exchange], Aug 23, 2003
    #1
    1. Advertising

  2. responseDeadlockInterval:

    Specifies the time interval, in standard process model format (hr:min:sec),
    after which the process will be restarted if the following conditions are
    met:
    a.. There are queued requests.
    b.. There has not been a response during this interval.
    The default is 3 minutes.



    "Martin Blackstone [MVP - Exchange]" <> wrote in
    message news:...
    > We are seeing a lot of errors like the one below which when occur
    > essentially lock up the ability to run the applications.
    > I have browsed the support articles and they all seem to apply to the 1.0
    > framework and advise a hotfix to correct the issue. But we are running

    the
    > 1.1 Framework.
    >
    > The articles suggest changing the timing of the responseDeadlockInterval
    > setting, but don't say whether to increase it or decrease it.
    > So which is it?
    >
    > Any help would be greatly appreciated.
    >
    >
    > Event Type: Error
    > Event Source: ASP.NET 1.1.4322.0
    > Event Category: None
    > Event ID: 1003
    > Date: 8/22/2003
    > Time: 2:53:32 PM
    > User: N/A
    > Computer: WEBSERVER
    > Description:
    > aspnet_wp.exe (PID: 3208) was recycled because it was suspected to be in

    a
    > deadlocked state. It did not send any responses for pending requests in

    the
    > last 300 seconds. This timeout may be adjusted using the <processModel
    > responseDeadlockInterval> setting in machine.config.
    >
    > --
    > Martin Blackstone
    > MVP - Exchange
    >
    > http://www.swinc.com/resource/exchange.htm
    >
    >
    > http://www.swinc.com/resource/e2kfaq_appxc.htm
    >
    >
     
    MS News \(MS ILM\), Aug 23, 2003
    #2
    1. Advertising

  3. ISAPI and Worker Process Isolation Mode.
    This might help, I meant to send with first reply.

    http://msdn.microsoft.com/library/d...ef/htm/ISAPIAndWorkerProcessIsolationMode.asp





    "MS News (MS ILM)" <> wrote in message
    news:...
    > responseDeadlockInterval:
    >
    > Specifies the time interval, in standard process model format

    (hr:min:sec),
    > after which the process will be restarted if the following conditions are
    > met:
    > a.. There are queued requests.
    > b.. There has not been a response during this interval.
    > The default is 3 minutes.
    >
    >
    >
    > "Martin Blackstone [MVP - Exchange]" <> wrote in
    > message news:...
    > > We are seeing a lot of errors like the one below which when occur
    > > essentially lock up the ability to run the applications.
    > > I have browsed the support articles and they all seem to apply to the

    1.0
    > > framework and advise a hotfix to correct the issue. But we are running

    > the
    > > 1.1 Framework.
    > >
    > > The articles suggest changing the timing of the

    responseDeadlockInterval
    > > setting, but don't say whether to increase it or decrease it.
    > > So which is it?
    > >
    > > Any help would be greatly appreciated.
    > >
    > >
    > > Event Type: Error
    > > Event Source: ASP.NET 1.1.4322.0
    > > Event Category: None
    > > Event ID: 1003
    > > Date: 8/22/2003
    > > Time: 2:53:32 PM
    > > User: N/A
    > > Computer: WEBSERVER
    > > Description:
    > > aspnet_wp.exe (PID: 3208) was recycled because it was suspected to be

    in
    > a
    > > deadlocked state. It did not send any responses for pending requests in

    > the
    > > last 300 seconds. This timeout may be adjusted using the <processModel
    > > responseDeadlockInterval> setting in machine.config.
    > >
    > > --
    > > Martin Blackstone
    > > MVP - Exchange
    > >
    > > http://www.swinc.com/resource/exchange.htm
    > >
    > >
    > > http://www.swinc.com/resource/e2kfaq_appxc.htm
    > >
    > >

    >
    >
     
    MS News \(MS ILM\), Aug 23, 2003
    #3
  4. OK, so call me dense, but does that mean I should increase the time? We have
    it cranked up to 5 minutes now.
    The problem is that once we get that error, the ASPNET service is hung and I
    have to issue an IISReset to get it going again.

    Also, is this a development issue (bad code), or a Windows issue?

    --
    Martin Blackstone
    MVP - Exchange

    http://www.swinc.com/resource/exchange.htm


    http://www.swinc.com/resource/e2kfaq_appxc.htm
    "MS News (MS ILM)" <> wrote in message
    news:...
    > responseDeadlockInterval:
    >
    > Specifies the time interval, in standard process model format

    (hr:min:sec),
    > after which the process will be restarted if the following conditions are
    > met:
    > a.. There are queued requests.
    > b.. There has not been a response during this interval.
    > The default is 3 minutes.
    >
    >
    >
    > "Martin Blackstone [MVP - Exchange]" <> wrote in
    > message news:...
    > > We are seeing a lot of errors like the one below which when occur
    > > essentially lock up the ability to run the applications.
    > > I have browsed the support articles and they all seem to apply to the

    1.0
    > > framework and advise a hotfix to correct the issue. But we are running

    > the
    > > 1.1 Framework.
    > >
    > > The articles suggest changing the timing of the

    responseDeadlockInterval
    > > setting, but don't say whether to increase it or decrease it.
    > > So which is it?
    > >
    > > Any help would be greatly appreciated.
    > >
    > >
    > > Event Type: Error
    > > Event Source: ASP.NET 1.1.4322.0
    > > Event Category: None
    > > Event ID: 1003
    > > Date: 8/22/2003
    > > Time: 2:53:32 PM
    > > User: N/A
    > > Computer: WEBSERVER
    > > Description:
    > > aspnet_wp.exe (PID: 3208) was recycled because it was suspected to be

    in
    > a
    > > deadlocked state. It did not send any responses for pending requests in

    > the
    > > last 300 seconds. This timeout may be adjusted using the <processModel
    > > responseDeadlockInterval> setting in machine.config.
    > >
    > > --
    > > Martin Blackstone
    > > MVP - Exchange
    > >
    > > http://www.swinc.com/resource/exchange.htm
    > >
    > >
    > > http://www.swinc.com/resource/e2kfaq_appxc.htm
    > >
    > >

    >
    >
     
    Martin Blackstone [MVP - Exchange], Aug 24, 2003
    #4
  5. This is W2K Server, IIS5. Does this article apply?

    --
    Martin Blackstone
    MVP - Exchange

    http://www.swinc.com/resource/exchange.htm


    http://www.swinc.com/resource/e2kfaq_appxc.htm
    "MS News (MS ILM)" <> wrote in message
    news:...
    > ISAPI and Worker Process Isolation Mode.
    > This might help, I meant to send with first reply.
    >
    >

    http://msdn.microsoft.com/library/d...ef/htm/ISAPIAndWorkerProcessIsolationMode.asp
    >
    >
    >
    >
    >
    > "MS News (MS ILM)" <> wrote in message
    > news:...
    > > responseDeadlockInterval:
    > >
    > > Specifies the time interval, in standard process model format

    > (hr:min:sec),
    > > after which the process will be restarted if the following conditions

    are
    > > met:
    > > a.. There are queued requests.
    > > b.. There has not been a response during this interval.
    > > The default is 3 minutes.
    > >
    > >
    > >
    > > "Martin Blackstone [MVP - Exchange]" <> wrote in
    > > message news:...
    > > > We are seeing a lot of errors like the one below which when occur
    > > > essentially lock up the ability to run the applications.
    > > > I have browsed the support articles and they all seem to apply to the

    > 1.0
    > > > framework and advise a hotfix to correct the issue. But we are

    running
    > > the
    > > > 1.1 Framework.
    > > >
    > > > The articles suggest changing the timing of the

    > responseDeadlockInterval
    > > > setting, but don't say whether to increase it or decrease it.
    > > > So which is it?
    > > >
    > > > Any help would be greatly appreciated.
    > > >
    > > >
    > > > Event Type: Error
    > > > Event Source: ASP.NET 1.1.4322.0
    > > > Event Category: None
    > > > Event ID: 1003
    > > > Date: 8/22/2003
    > > > Time: 2:53:32 PM
    > > > User: N/A
    > > > Computer: WEBSERVER
    > > > Description:
    > > > aspnet_wp.exe (PID: 3208) was recycled because it was suspected to be

    > in
    > > a
    > > > deadlocked state. It did not send any responses for pending requests

    in
    > > the
    > > > last 300 seconds. This timeout may be adjusted using the <processModel
    > > > responseDeadlockInterval> setting in machine.config.
    > > >
    > > > --
    > > > Martin Blackstone
    > > > MVP - Exchange
    > > >
    > > > http://www.swinc.com/resource/exchange.htm
    > > >
    > > >
    > > > http://www.swinc.com/resource/e2kfaq_appxc.htm
    > > >
    > > >

    > >
    > >

    >
    >
     
    Martin Blackstone [MVP - Exchange], Aug 24, 2003
    #5
  6. Decrease it, may be you are going the wrong way.

    "Martin Blackstone [MVP - Exchange]" <> wrote in
    message news:...
    > OK, so call me dense, but does that mean I should increase the time? We

    have
    > it cranked up to 5 minutes now.
    > The problem is that once we get that error, the ASPNET service is hung and

    I
    > have to issue an IISReset to get it going again.
    >
    > Also, is this a development issue (bad code), or a Windows issue?
    >
    > --
    > Martin Blackstone
    > MVP - Exchange
    >
    > http://www.swinc.com/resource/exchange.htm
    >
    >
    > http://www.swinc.com/resource/e2kfaq_appxc.htm
    > "MS News (MS ILM)" <> wrote in message
    > news:...
    > > responseDeadlockInterval:
    > >
    > > Specifies the time interval, in standard process model format

    > (hr:min:sec),
    > > after which the process will be restarted if the following conditions

    are
    > > met:
    > > a.. There are queued requests.
    > > b.. There has not been a response during this interval.
    > > The default is 3 minutes.
    > >
    > >
    > >
    > > "Martin Blackstone [MVP - Exchange]" <> wrote in
    > > message news:...
    > > > We are seeing a lot of errors like the one below which when occur
    > > > essentially lock up the ability to run the applications.
    > > > I have browsed the support articles and they all seem to apply to the

    > 1.0
    > > > framework and advise a hotfix to correct the issue. But we are

    running
    > > the
    > > > 1.1 Framework.
    > > >
    > > > The articles suggest changing the timing of the

    > responseDeadlockInterval
    > > > setting, but don't say whether to increase it or decrease it.
    > > > So which is it?
    > > >
    > > > Any help would be greatly appreciated.
    > > >
    > > >
    > > > Event Type: Error
    > > > Event Source: ASP.NET 1.1.4322.0
    > > > Event Category: None
    > > > Event ID: 1003
    > > > Date: 8/22/2003
    > > > Time: 2:53:32 PM
    > > > User: N/A
    > > > Computer: WEBSERVER
    > > > Description:
    > > > aspnet_wp.exe (PID: 3208) was recycled because it was suspected to be

    > in
    > > a
    > > > deadlocked state. It did not send any responses for pending requests

    in
    > > the
    > > > last 300 seconds. This timeout may be adjusted using the <processModel
    > > > responseDeadlockInterval> setting in machine.config.
    > > >
    > > > --
    > > > Martin Blackstone
    > > > MVP - Exchange
    > > >
    > > > http://www.swinc.com/resource/exchange.htm
    > > >
    > > >
    > > > http://www.swinc.com/resource/e2kfaq_appxc.htm
    > > >
    > > >

    > >
    > >

    >
    >
     
    MS News \(MS ILM\), Aug 24, 2003
    #6
  7. Are you doing something inside ASP.NET code that you expect to be taking a
    long time? If this is the case, increasing the responseDeadlockInterval
    will be the most direct solution, though changing the requests processing
    architecture so that a client isn't left waiting for > 3 minutes for a
    response is probably a better option.

    If you aren't doing anything that should be taking a long time, you probably
    have a real thread deadlock, and you need to identify it and fix it. The
    PAP group has produced a great document on ASP.NET debugging [1] to solve
    problems like this. For deadlocks, you can add a DWORD value called
    UnderDebugger to the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ASP.NET key, and
    when this is set to 1, recycling will be disabled, which allows an Attach to
    Process on aspnet_wp.exe to occur.

    [1]
    http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dnbda/html/DBGrm.asp


    Nick Wienholt, MVP
    Maximizing .NET Performance
    http://www.apress.com/book/bookDisplay.html?bID=217
    Sydney Deep .NET User Group www.sdnug.org


    "Martin Blackstone [MVP - Exchange]" <> wrote in
    message news:...
    > We are seeing a lot of errors like the one below which when occur
    > essentially lock up the ability to run the applications.
    > I have browsed the support articles and they all seem to apply to the 1.0
    > framework and advise a hotfix to correct the issue. But we are running

    the
    > 1.1 Framework.
    >
    > The articles suggest changing the timing of the responseDeadlockInterval
    > setting, but don't say whether to increase it or decrease it.
    > So which is it?
    >
    > Any help would be greatly appreciated.
    >
    >
    > Event Type: Error
    > Event Source: ASP.NET 1.1.4322.0
    > Event Category: None
    > Event ID: 1003
    > Date: 8/22/2003
    > Time: 2:53:32 PM
    > User: N/A
    > Computer: WEBSERVER
    > Description:
    > aspnet_wp.exe (PID: 3208) was recycled because it was suspected to be in

    a
    > deadlocked state. It did not send any responses for pending requests in

    the
    > last 300 seconds. This timeout may be adjusted using the <processModel
    > responseDeadlockInterval> setting in machine.config.
    >
    > --
    > Martin Blackstone
    > MVP - Exchange
    >
    > http://www.swinc.com/resource/exchange.htm
    >
    >
    > http://www.swinc.com/resource/e2kfaq_appxc.htm
    >
    >
     
    Nick Wienholt, Aug 24, 2003
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Mike Carr

    Deadlocks

    Mike Carr, Jul 16, 2004, in forum: ASP .Net
    Replies:
    9
    Views:
    657
    Mike Carr
    Jul 23, 2004
  2. Rogan Dawes

    Automatically detecting deadlocks?

    Rogan Dawes, May 5, 2004, in forum: Java
    Replies:
    2
    Views:
    443
    Rogan Dawes
    May 6, 2004
  3. deadlocks

    , Dec 8, 2005, in forum: Java
    Replies:
    31
    Views:
    1,535
    Steve Horsley
    Dec 22, 2005
  4. commie
    Replies:
    16
    Views:
    1,069
  5. Eloff
    Replies:
    14
    Views:
    499
    Tim Peters
    Jun 23, 2005
Loading...

Share This Page