Can't Build Ruby 1.8.1 on HP-UX 11.00

Discussion in 'Ruby' started by Kevin Hinners, Nov 16, 2004.

  1. I've downloaded the stable 1.8.1 release of Ruby. When I attempt to run make
    on HP-UX 11.00, I receive the following error:

    compiling curses
    /ext/extmk.rb:103: warning: Insecure world writable dir /opt/netscape, mode
    040777
    gcc -fPIC -g -O2 -I. -I/temp/ruby/ruby-1.8.1 -I/temp/ruby/ruby-1.8.
    1 -I/temp/ruby/ruby-1.8.1/ext/curses -DHAVE_CURSES_COLR_CURSES_H -DHAVE_BEEP
    -DHAVE_BKGD -DHAVE_BKGDSET -DHAVE_CURS_SET -DHAVE_DELETELN -DHAVE_DOUPDATE
    -DHAVE_FLASH -DHAVE_GETBKGD -DHAVE_GETNSTR -DHAVE_INIT -DHAVE_ISENDWIN -DHAV
    E_KEYNAME -DHAVE_KEYPAD -DHAVE_RESIZETERM -DHAVE_SCRL -DHAVE_SET -DHAVE_SETS
    CRREG -DHAVE_UNGETCH -DHAVE_WATTROFF -DHAVE_WATTRON -DHAVE_WATTRSET -DHAVE_W
    BKGD -DHAVE_WBKGDSET -DHAVE_WDELETELN -DHAVE_WGETNSTR -DHAVE_WRESIZE -DHAVE_
    WSCRL -DHAVE_WSETSCRREG -DHAVE_DEF_PROG_MODE -DHAVE_RESET_PROG_MODE -DHAVE_T
    IMEOUT -DHAVE_WTIMEOUT -DHAVE_NODELAY -DHAVE_INIT_COLOR -c curses.c
    ld -b -E -L"/temp/ruby/ruby-1.8.1" -L"/usr/local/lib" -o curses.sl
    curses.o -lcur_colr -ltinfo -ldld -lcrypt -lm -lc
    ld: Can't find library: "tinfo"
    *** Error exit code 1

    Stop.
    *** Error exit code 1



    Kevin Hinners
    Senior Technical Analyst

    FedEx Services
    350 Spectrum Loop
    Colorado Springs, CO 80921
    719-484-2303
     
    Kevin Hinners, Nov 16, 2004
    #1
    1. Advertising

  2. Hi,

    In message "Re: Can't Build Ruby 1.8.1 on HP-UX 11.00"
    on Wed, 17 Nov 2004 05:58:11 +0900, Kevin Hinners <> writes:

    |curses.o -lcur_colr -ltinfo -ldld -lcrypt -lm -lc
    |ld: Can't find library: "tinfo"
    |*** Error exit code 1

    Strange. extmk.rb adds -ltinfo only when it finds tinfo. Can you show
    us your mkmk.log?

    matz.
     
    Yukihiro Matsumoto, Nov 16, 2004
    #2
    1. Advertising

  3. FastCGI ... missing link

    There have missing links in http://raa.ruby-lang.org/project/fastcgi/
    for homepage and download.

    Is there any alternate location to download?

    I also tried with 'gem',
    [root@localhost root]# gem install fastcgi --remote
    Attempting remote installation of 'fastcgi'
    ERROR: While executing gem ... (Gem::GemNotFoundException)
    Could not find fastcgi (> 0) in the repository



    Thanks,
    MOhammad


    --

    [mkhan@localhost local]$ make love
    make: *** No rule to make target `love'. Stop.
     
    Mohammad Khan, Nov 16, 2004
    #3
  4. Top segment of mkmk.log:

    have_library: checking for tgetent() in -ltinfo... -------------------- yes

    "gcc -o conftest -I/temp/ruby/ruby-1.8.1 -I/temp/ruby/ruby-1.8.1 -g -O2
    conftest.c -L"/temp/ruby/ruby-1.8.1" -L"/usr/local/lib" -E -lruby-sta
    tic -ltinfo -ldld -lcrypt -lm -lc"
    gcc: -lruby-static: linker input file unused because linking not done
    gcc: -ltinfo: linker input file unused because linking not done
    gcc: -ldld: linker input file unused because linking not done
    gcc: -lcrypt: linker input file unused because linking not done
    gcc: -lm: linker input file unused because linking not done
    gcc: -lc: linker input file unused because linking not done
    checked program was:
    /* begin */

    /*top*/
    int main() { return 0; }
    int t() { tgetent(); return 0; }
    /* end */

    --------------------

    have_header: checking for ncurses.h... -------------------- no

    "gcc -E -I/temp/ruby/ruby-1.8.1 -I/temp/ruby/ruby-1.8.1 -g -O2
    conftest.c -o conftest.i"
    /temp/ruby/ruby-1.8.1/lib/mkmf.rb:169: warning: Insecure world writable dir
    /opt/netscape, mode 040777
    conftest.c:1:21: ncurses.h: No such file or directory
    checked program was:
    /* begin */
    #include <ncurses.h>
    /* end */

    --------------------

    have_header: checking for ncurses/curses.h... -------------------- no

    "gcc -E -I/temp/ruby/ruby-1.8.1 -I/temp/ruby/ruby-1.8.1 -g -O2
    conftest.c -o conftest.i"
    /temp/ruby/ruby-1.8.1/lib/mkmf.rb:169: warning: Insecure world writable dir
    /opt/netscape, mode 040777
    conftest.c:1:28: ncurses/curses.h: No such file or directory
    checked program was:
    /* begin */
    #include <ncurses/curses.h>
    /* end */

    --------------------

    have_header: checking for curses_colr/curses.h... -------------------- yes

    "gcc -E -I/temp/ruby/ruby-1.8.1 -I/temp/ruby/ruby-1.8.1 -g -O2
    conftest.c -o conftest.i"
    /temp/ruby/ruby-1.8.1/lib/mkmf.rb:169: warning: Insecure world writable dir
    /opt/netscape, mode 040777
    checked program was:
    /* begin */
    #include <curses_colr/curses.h>
    /* end */

    --------------------

    have_library: checking for initscr() in -lcur_colr... --------------------
    yes

    "gcc -o conftest -I/temp/ruby/ruby-1.8.1 -I/temp/ruby/ruby-1.8.1 -g -O2
    conftest.c -L"/temp/ruby/ruby-1.8.1" -L"/usr/local/lib" -E -ltinfo -l
    ruby-static -lcur_colr -ltinfo -ldld -lcrypt -lm -lc"
    gcc: -ltinfo: linker input file unused because linking not done
    gcc: -lruby-static: linker input file unused because linking not done
    gcc: -lcur_colr: linker input file unused because linking not done
    gcc: -ltinfo: linker input file unused because linking not done
    gcc: -ldld: linker input file unused because linking not done
    gcc: -lcrypt: linker input file unused because linking not done
    gcc: -lm: linker input file unused because linking not done
    gcc: -lc: linker input file unused because linking not done
    checked program was:
    /* begin */

    /*top*/
    int main() { return 0; }
    int t() { initscr(); return 0; }
    /* end */




    Kevin Hinners
    Senior Technical Analyst

    FedEx Services
    350 Spectrum Loop
    Colorado Springs, CO 80921
    719-484-2303


    -----Original Message-----
    From: Yukihiro Matsumoto [mailto:]
    Sent: Tuesday, November 16, 2004 2:08 PM
    To: ruby-talk ML
    Subject: Re: Can't Build Ruby 1.8.1 on HP-UX 11.00


    Hi,

    In message "Re: Can't Build Ruby 1.8.1 on HP-UX 11.00"
    on Wed, 17 Nov 2004 05:58:11 +0900, Kevin Hinners
    <> writes:

    |curses.o -lcur_colr -ltinfo -ldld -lcrypt -lm -lc
    |ld: Can't find library: "tinfo"
    |*** Error exit code 1

    Strange. extmk.rb adds -ltinfo only when it finds tinfo. Can you show
    us your mkmk.log?

    matz.
     
    Kevin Hinners, Nov 16, 2004
    #4
  5. Hi,

    In message "Re: Can't Build Ruby 1.8.1 on HP-UX 11.00"
    on Wed, 17 Nov 2004 06:25:09 +0900, Kevin Hinners <> writes:

    |have_library: checking for tgetent() in -ltinfo... -------------------- yes
    |
    |"gcc -o conftest -I/temp/ruby/ruby-1.8.1 -I/temp/ruby/ruby-1.8.1 -g -O2
    |conftest.c -L"/temp/ruby/ruby-1.8.1" -L"/usr/local/lib" -E -lruby-sta
    |tic -ltinfo -ldld -lcrypt -lm -lc"

    "-E" is the reason. But I have no idea how it sneaks in linking
    arguments. Show us rbconfig.rb then.

    matz.
     
    Yukihiro Matsumoto, Nov 16, 2004
    #5
  6. Here is rbconfig.rb:

    # This file was created by mkconfig.rb when ruby was built. Any
    # changes made to this file will be lost the next time ruby is built.

    module Config
    RUBY_VERSION == "1.8.1" or
    raise "ruby lib version (1.8.1) doesn't match executable version
    (#{RUBY_VERSION})"

    TOPDIR =
    File.dirname(__FILE__).sub!(%r'/lib/ruby/1\.8/hppa2\.0w\-hpux11\.00\Z', '')
    DESTDIR = '' unless defined? DESTDIR
    CONFIG = {}
    CONFIG["DESTDIR"] = DESTDIR
    CONFIG["srcdir"] = "/temp/ruby/ruby-1.8.1"
    CONFIG["prefix"] = (TOPDIR || DESTDIR + "/usr/local")
    CONFIG["ruby_install_name"] = "ruby"
    CONFIG["EXEEXT"] = ""
    CONFIG["SHELL"] = "/bin/sh"
    CONFIG["PATH_SEPARATOR"] = ":"
    CONFIG["PACKAGE_NAME"] = ""
    CONFIG["PACKAGE_TARNAME"] = ""
    CONFIG["PACKAGE_VERSION"] = ""
    CONFIG["PACKAGE_STRING"] = ""
    CONFIG["PACKAGE_BUGREPORT"] = ""
    CONFIG["exec_prefix"] = "$(prefix)"
    CONFIG["bindir"] = "$(exec_prefix)/bin"
    CONFIG["sbindir"] = "$(exec_prefix)/sbin"
    CONFIG["libexecdir"] = "$(exec_prefix)/libexec"
    CONFIG["datadir"] = "$(prefix)/share"
    CONFIG["sysconfdir"] = "$(prefix)/etc"
    CONFIG["sharedstatedir"] = "$(prefix)/com"
    CONFIG["localstatedir"] = "$(prefix)/var"
    CONFIG["libdir"] = "$(exec_prefix)/lib"
    CONFIG["includedir"] = "$(prefix)/include"
    CONFIG["oldincludedir"] = "/usr/include"
    CONFIG["infodir"] = "$(prefix)/info"
    CONFIG["mandir"] = "$(prefix)/man"
    CONFIG["build_alias"] = ""
    CONFIG["host_alias"] = ""
    CONFIG["target_alias"] = ""
    CONFIG["ECHO_C"] = "\\c"
    CONFIG["ECHO_N"] = ""
    CONFIG["ECHO_T"] = ""
    CONFIG["LIBS"] = "-ldld -lcrypt -lm "
    CONFIG["MAJOR"] = "1"
    CONFIG["MINOR"] = "8"
    CONFIG["TEENY"] = "1"
    CONFIG["build"] = "hppa2.0w-hp-hpux11.00"
    CONFIG["build_cpu"] = "hppa2.0w"
    CONFIG["build_vendor"] = "hp"
    CONFIG["build_os"] = "hpux11.00"
    CONFIG["host"] = "hppa2.0w-hp-hpux11.00"
    CONFIG["host_cpu"] = "hppa2.0w"
    CONFIG["host_vendor"] = "hp"
    CONFIG["host_os"] = "hpux11.00"
    CONFIG["target"] = "hppa2.0w-hp-hpux11.00"
    CONFIG["target_cpu"] = "hppa2.0w"
    CONFIG["target_vendor"] = "hp"
    CONFIG["target_os"] = "hpux11.00"
    CONFIG["CC"] = "gcc"
    CONFIG["ac_ct_CC"] = "gcc"
    CONFIG["CFLAGS"] = "-g -O2"
    CONFIG["LDFLAGS"] = ""
    CONFIG["CPPFLAGS"] = ""
    CONFIG["OBJEXT"] = "o"
    CONFIG["CPP"] = "gcc -E"
    CONFIG["EGREP"] = "grep -E"
    CONFIG["GNU_LD"] = "no"
    CONFIG["CPPOUTFILE"] = "-o conftest.i"
    CONFIG["OUTFLAG"] = "-o "
    CONFIG["YACC"] = "bison -y"
    CONFIG["RANLIB"] = "ranlib"
    CONFIG["ac_ct_RANLIB"] = "ranlib"
    CONFIG["AR"] = "ar"
    CONFIG["ac_ct_AR"] = "ar"
    CONFIG["NM"] = ""
    CONFIG["ac_ct_NM"] = ""
    CONFIG["WINDRES"] = ""
    CONFIG["ac_ct_WINDRES"] = ""
    CONFIG["DLLWRAP"] = ""
    CONFIG["ac_ct_DLLWRAP"] = ""
    CONFIG["LN_S"] = "ln -s"
    CONFIG["SET_MAKE"] = ""
    CONFIG["LIBOBJS"] = " flock$(U).o finite$(U).o isinf$(U).o"
    CONFIG["ALLOCA"] = ""
    CONFIG["DLDFLAGS"] = " -E"
    CONFIG["ARCH_FLAG"] = ""
    CONFIG["STATIC"] = ""
    CONFIG["CCDLFLAGS"] = " -fPIC"
    CONFIG["LDSHARED"] = "ld -b"
    CONFIG["DLEXT"] = "sl"
    CONFIG["DLEXT2"] = ""
    CONFIG["LIBEXT"] = "a"
    CONFIG["LINK_SO"] = ""
    CONFIG["LIBPATHFLAG"] = " -L%s"
    CONFIG["RPATHFLAG"] = ""
    CONFIG["STRIP"] = "strip"
    CONFIG["EXTSTATIC"] = ""
    CONFIG["setup"] = "Setup"
    CONFIG["MINIRUBY"] = "./miniruby$(EXEEXT)"
    CONFIG["PREP"] = ""
    CONFIG["ARCHFILE"] = ""
    CONFIG["XCFLAGS"] = ""
    CONFIG["XLDFLAGS"] = " -Wl,-E -L."
    CONFIG["LIBRUBY_LDSHARED"] = "ld -b"
    CONFIG["LIBRUBY_DLDFLAGS"] = " -E"
    CONFIG["RUBY_INSTALL_NAME"] = "ruby"
    CONFIG["rubyw_install_name"] = ""
    CONFIG["RUBYW_INSTALL_NAME"] = ""
    CONFIG["RUBY_SO_NAME"] = "$(RUBY_INSTALL_NAME)"
    CONFIG["LIBRUBY_A"] = "lib$(RUBY_SO_NAME)-static.a"
    CONFIG["LIBRUBY_SO"] = "lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR).$(TEENY)"
    CONFIG["LIBRUBY_ALIASES"] = "lib$(RUBY_SO_NAME).so"
    CONFIG["LIBRUBY"] = "$(LIBRUBY_A)"
    CONFIG["LIBRUBYARG"] = "$(LIBRUBYARG_STATIC)"
    CONFIG["LIBRUBYARG_STATIC"] = "-l$(RUBY_SO_NAME)-static"
    CONFIG["LIBRUBYARG_SHARED"] = ""
    CONFIG["SOLIBS"] = ""
    CONFIG["DLDLIBS"] = " -lc"
    CONFIG["ENABLE_SHARED"] = "no"
    CONFIG["MAINLIBS"] = ""
    CONFIG["COMMON_LIBS"] = ""
    CONFIG["COMMON_MACROS"] = ""
    CONFIG["COMMON_HEADERS"] = ""
    CONFIG["EXPORT_PREFIX"] = ""
    CONFIG["MAKEFILES"] = "Makefile"
    CONFIG["arch"] = "hppa2.0w-hpux11.00"
    CONFIG["sitearch"] = "hppa2.0w-hpux11.00"
    CONFIG["sitedir"] = "$(prefix)/lib/ruby/site_ruby"
    CONFIG["configure_args"] = ""
    CONFIG["NROFF"] = "/usr/bin/nroff"
    CONFIG["MANTYPE"] = "man"
    CONFIG["LTLIBOBJS"] = " flock$(U).lo finite$(U).lo isinf$(U).lo"
    CONFIG["abs_srcdir"] = "$(ac_abs_srcdir)"
    CONFIG["abs_top_srcdir"] = "$(ac_abs_top_srcdir)"
    CONFIG["builddir"] = "$(ac_builddir)"
    CONFIG["abs_builddir"] = "$(ac_abs_builddir)"
    CONFIG["top_builddir"] = "$(ac_top_builddir)"
    CONFIG["abs_top_builddir"] = "$(ac_abs_top_builddir)"
    CONFIG["ruby_version"] = "$(MAJOR).$(MINOR)"
    CONFIG["rubylibdir"] = "$(libdir)/ruby/$(ruby_version)"
    CONFIG["archdir"] = "$(rubylibdir)/$(arch)"
    CONFIG["sitelibdir"] = "$(sitedir)/$(ruby_version)"
    CONFIG["sitearchdir"] = "$(sitelibdir)/$(sitearch)"
    CONFIG["compile_dir"] = "/temp/ruby/ruby-1.8.1"
    MAKEFILE_CONFIG = {}
    CONFIG.each{|k,v| MAKEFILE_CONFIG[k] = v.dup}
    def Config::expand(val, config = CONFIG)
    val.gsub!(/\$\$|\$\(([^()]+)\)|\$\{([^{}]+)\}/) do |var|
    if !(v = $1 || $2)
    '$'
    elsif key = config[v]
    config[v] = false
    Config::expand(key, config)
    config[v] = key
    else
    var
    end
    end
    val
    end
    CONFIG.each_value do |val|
    Config::expand(val)
    end
    end
    CROSS_COMPILING = nil unless defined? CROSS_COMPILING



    Kevin Hinners
    Senior Technical Analyst

    FedEx Services
    350 Spectrum Loop
    Colorado Springs, CO 80921
    719-484-2303


    -----Original Message-----
    From: Yukihiro Matsumoto [mailto:]
    Sent: Tuesday, November 16, 2004 2:54 PM
    To: ruby-talk ML
    Subject: Re: Can't Build Ruby 1.8.1 on HP-UX 11.00


    Hi,

    In message "Re: Can't Build Ruby 1.8.1 on HP-UX 11.00"
    on Wed, 17 Nov 2004 06:25:09 +0900, Kevin Hinners
    <> writes:

    |have_library: checking for tgetent() in -ltinfo... -------------------- yes
    |
    |"gcc -o conftest -I/temp/ruby/ruby-1.8.1 -I/temp/ruby/ruby-1.8.1 -g -O2
    |conftest.c -L"/temp/ruby/ruby-1.8.1" -L"/usr/local/lib" -E -lruby-st
    a
    |tic -ltinfo -ldld -lcrypt -lm -lc"

    "-E" is the reason. But I have no idea how it sneaks in linking
    arguments. Show us rbconfig.rb then.

    matz.
     
    Kevin Hinners, Nov 16, 2004
    #6
  7. -----Original Message-----
    From: Kevin Hinners [mailto:]
    Sent: Tuesday, November 16, 2004 3:35 PM
    To: ruby-talk ML
    Subject: Re: Can't Build Ruby 1.8.1 on HP-UX 11.00


    Here is rbconfig.rb:

    # This file was created by mkconfig.rb when ruby was built. Any
    # changes made to this file will be lost the next time ruby is built.

    module Config
    RUBY_VERSION == "1.8.1" or
    raise "ruby lib version (1.8.1) doesn't match executable version
    (#{RUBY_VERSION})"

    TOPDIR =
    File.dirname(__FILE__).sub!(%r'/lib/ruby/1\.8/hppa2\.0w\-hpux11\.00\Z', '')
    DESTDIR = '' unless defined? DESTDIR
    CONFIG = {}
    CONFIG["DESTDIR"] = DESTDIR
    CONFIG["srcdir"] = "/temp/ruby/ruby-1.8.1"
    CONFIG["prefix"] = (TOPDIR || DESTDIR + "/usr/local")
    CONFIG["ruby_install_name"] = "ruby"
    CONFIG["EXEEXT"] = ""
    CONFIG["SHELL"] = "/bin/sh"
    CONFIG["PATH_SEPARATOR"] = ":"
    CONFIG["PACKAGE_NAME"] = ""
    CONFIG["PACKAGE_TARNAME"] = ""
    CONFIG["PACKAGE_VERSION"] = ""
    CONFIG["PACKAGE_STRING"] = ""
    CONFIG["PACKAGE_BUGREPORT"] = ""
    CONFIG["exec_prefix"] = "$(prefix)"
    CONFIG["bindir"] = "$(exec_prefix)/bin"
    CONFIG["sbindir"] = "$(exec_prefix)/sbin"
    CONFIG["libexecdir"] = "$(exec_prefix)/libexec"
    CONFIG["datadir"] = "$(prefix)/share"
    CONFIG["sysconfdir"] = "$(prefix)/etc"
    CONFIG["sharedstatedir"] = "$(prefix)/com"
    CONFIG["localstatedir"] = "$(prefix)/var"
    CONFIG["libdir"] = "$(exec_prefix)/lib"
    CONFIG["includedir"] = "$(prefix)/include"
    CONFIG["oldincludedir"] = "/usr/include"
    CONFIG["infodir"] = "$(prefix)/info"
    CONFIG["mandir"] = "$(prefix)/man"
    CONFIG["build_alias"] = ""
    CONFIG["host_alias"] = ""
    CONFIG["target_alias"] = ""
    CONFIG["ECHO_C"] = "\\c"
    CONFIG["ECHO_N"] = ""
    CONFIG["ECHO_T"] = ""
    CONFIG["LIBS"] = "-ldld -lcrypt -lm "
    CONFIG["MAJOR"] = "1"
    CONFIG["MINOR"] = "8"
    CONFIG["TEENY"] = "1"
    CONFIG["build"] = "hppa2.0w-hp-hpux11.00"
    CONFIG["build_cpu"] = "hppa2.0w"
    CONFIG["build_vendor"] = "hp"
    CONFIG["build_os"] = "hpux11.00"
    CONFIG["host"] = "hppa2.0w-hp-hpux11.00"
    CONFIG["host_cpu"] = "hppa2.0w"
    CONFIG["host_vendor"] = "hp"
    CONFIG["host_os"] = "hpux11.00"
    CONFIG["target"] = "hppa2.0w-hp-hpux11.00"
    CONFIG["target_cpu"] = "hppa2.0w"
    CONFIG["target_vendor"] = "hp"
    CONFIG["target_os"] = "hpux11.00"
    CONFIG["CC"] = "gcc"
    CONFIG["ac_ct_CC"] = "gcc"
    CONFIG["CFLAGS"] = "-g -O2"
    CONFIG["LDFLAGS"] = ""
    CONFIG["CPPFLAGS"] = ""
    CONFIG["OBJEXT"] = "o"
    CONFIG["CPP"] = "gcc -E"
    CONFIG["EGREP"] = "grep -E"
    CONFIG["GNU_LD"] = "no"
    CONFIG["CPPOUTFILE"] = "-o conftest.i"
    CONFIG["OUTFLAG"] = "-o "
    CONFIG["YACC"] = "bison -y"
    CONFIG["RANLIB"] = "ranlib"
    CONFIG["ac_ct_RANLIB"] = "ranlib"
    CONFIG["AR"] = "ar"
    CONFIG["ac_ct_AR"] = "ar"
    CONFIG["NM"] = ""
    CONFIG["ac_ct_NM"] = ""
    CONFIG["WINDRES"] = ""
    CONFIG["ac_ct_WINDRES"] = ""
    CONFIG["DLLWRAP"] = ""
    CONFIG["ac_ct_DLLWRAP"] = ""
    CONFIG["LN_S"] = "ln -s"
    CONFIG["SET_MAKE"] = ""
    CONFIG["LIBOBJS"] = " flock$(U).o finite$(U).o isinf$(U).o"
    CONFIG["ALLOCA"] = ""
    CONFIG["DLDFLAGS"] = " -E"
    CONFIG["ARCH_FLAG"] = ""
    CONFIG["STATIC"] = ""
    CONFIG["CCDLFLAGS"] = " -fPIC"
    CONFIG["LDSHARED"] = "ld -b"
    CONFIG["DLEXT"] = "sl"
    CONFIG["DLEXT2"] = ""
    CONFIG["LIBEXT"] = "a"
    CONFIG["LINK_SO"] = ""
    CONFIG["LIBPATHFLAG"] = " -L%s"
    CONFIG["RPATHFLAG"] = ""
    CONFIG["STRIP"] = "strip"
    CONFIG["EXTSTATIC"] = ""
    CONFIG["setup"] = "Setup"
    CONFIG["MINIRUBY"] = "./miniruby$(EXEEXT)"
    CONFIG["PREP"] = ""
    CONFIG["ARCHFILE"] = ""
    CONFIG["XCFLAGS"] = ""
    CONFIG["XLDFLAGS"] = " -Wl,-E -L."
    CONFIG["LIBRUBY_LDSHARED"] = "ld -b"
    CONFIG["LIBRUBY_DLDFLAGS"] = " -E"
    CONFIG["RUBY_INSTALL_NAME"] = "ruby"
    CONFIG["rubyw_install_name"] = ""
    CONFIG["RUBYW_INSTALL_NAME"] = ""
    CONFIG["RUBY_SO_NAME"] = "$(RUBY_INSTALL_NAME)"
    CONFIG["LIBRUBY_A"] = "lib$(RUBY_SO_NAME)-static.a"
    CONFIG["LIBRUBY_SO"] = "lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR).$(TEENY)"
    CONFIG["LIBRUBY_ALIASES"] = "lib$(RUBY_SO_NAME).so"
    CONFIG["LIBRUBY"] = "$(LIBRUBY_A)"
    CONFIG["LIBRUBYARG"] = "$(LIBRUBYARG_STATIC)"
    CONFIG["LIBRUBYARG_STATIC"] = "-l$(RUBY_SO_NAME)-static"
    CONFIG["LIBRUBYARG_SHARED"] = ""
    CONFIG["SOLIBS"] = ""
    CONFIG["DLDLIBS"] = " -lc"
    CONFIG["ENABLE_SHARED"] = "no"
    CONFIG["MAINLIBS"] = ""
    CONFIG["COMMON_LIBS"] = ""
    CONFIG["COMMON_MACROS"] = ""
    CONFIG["COMMON_HEADERS"] = ""
    CONFIG["EXPORT_PREFIX"] = ""
    CONFIG["MAKEFILES"] = "Makefile"
    CONFIG["arch"] = "hppa2.0w-hpux11.00"
    CONFIG["sitearch"] = "hppa2.0w-hpux11.00"
    CONFIG["sitedir"] = "$(prefix)/lib/ruby/site_ruby"
    CONFIG["configure_args"] = ""
    CONFIG["NROFF"] = "/usr/bin/nroff"
    CONFIG["MANTYPE"] = "man"
    CONFIG["LTLIBOBJS"] = " flock$(U).lo finite$(U).lo isinf$(U).lo"
    CONFIG["abs_srcdir"] = "$(ac_abs_srcdir)"
    CONFIG["abs_top_srcdir"] = "$(ac_abs_top_srcdir)"
    CONFIG["builddir"] = "$(ac_builddir)"
    CONFIG["abs_builddir"] = "$(ac_abs_builddir)"
    CONFIG["top_builddir"] = "$(ac_top_builddir)"
    CONFIG["abs_top_builddir"] = "$(ac_abs_top_builddir)"
    CONFIG["ruby_version"] = "$(MAJOR).$(MINOR)"
    CONFIG["rubylibdir"] = "$(libdir)/ruby/$(ruby_version)"
    CONFIG["archdir"] = "$(rubylibdir)/$(arch)"
    CONFIG["sitelibdir"] = "$(sitedir)/$(ruby_version)"
    CONFIG["sitearchdir"] = "$(sitelibdir)/$(sitearch)"
    CONFIG["compile_dir"] = "/temp/ruby/ruby-1.8.1"
    MAKEFILE_CONFIG = {}
    CONFIG.each{|k,v| MAKEFILE_CONFIG[k] = v.dup}
    def Config::expand(val, config = CONFIG)
    val.gsub!(/\$\$|\$\(([^()]+)\)|\$\{([^{}]+)\}/) do |var|
    if !(v = $1 || $2)
    '$'
    elsif key = config[v]
    config[v] = false
    Config::expand(key, config)
    config[v] = key
    else
    var
    end
    end
    val
    end
    CONFIG.each_value do |val|
    Config::expand(val)
    end
    end
    CROSS_COMPILING = nil unless defined? CROSS_COMPILING



    Kevin Hinners
    Senior Technical Analyst

    FedEx Services
    350 Spectrum Loop
    Colorado Springs, CO 80921
    719-484-2303


    -----Original Message-----
    From: Yukihiro Matsumoto [mailto:]
    Sent: Tuesday, November 16, 2004 2:54 PM
    To: ruby-talk ML
    Subject: Re: Can't Build Ruby 1.8.1 on HP-UX 11.00


    Hi,

    In message "Re: Can't Build Ruby 1.8.1 on HP-UX 11.00"
    on Wed, 17 Nov 2004 06:25:09 +0900, Kevin Hinners
    <> writes:

    |have_library: checking for tgetent() in -ltinfo... -------------------- yes
    |
    |"gcc -o conftest -I/temp/ruby/ruby-1.8.1 -I/temp/ruby/ruby-1.8.1 -g -O2
    |conftest.c -L"/temp/ruby/ruby-1.8.1" -L"/usr/local/lib" -E -lruby-st
    a
    |tic -ltinfo -ldld -lcrypt -lm -lc"

    "-E" is the reason. But I have no idea how it sneaks in linking
    arguments. Show us rbconfig.rb then.

    matz.
     
    Kevin Hinners, Nov 18, 2004
    #7
  8. Kevin Hinners

    Guest

    Hi,

    At Wed, 17 Nov 2004 06:54:17 +0900,
    Yukihiro Matsumoto wrote in [ruby-talk:120582]:
    > |have_library: checking for tgetent() in -ltinfo... -------------------- yes
    > |
    > |"gcc -o conftest -I/temp/ruby/ruby-1.8.1 -I/temp/ruby/ruby-1.8.1 -g -O2
    > |conftest.c -L"/temp/ruby/ruby-1.8.1" -L"/usr/local/lib" -E -lruby-sta
    > |tic -ltinfo -ldld -lcrypt -lm -lc"
    >
    > "-E" is the reason. But I have no idea how it sneaks in linking
    > arguments. Show us rbconfig.rb then.


    -E came from DLDFLAGS, and it has been removed from TRY_LINK in
    lib/mkmf.rb. Recent stable snapshots shouldn't have the problem.

    --
    Nobu Nakada
     
    , Nov 18, 2004
    #8
  9. Re: FastCGI ... missing link

    try gem install fcgi

    gem list -r to see whats available


    On Wed, 17 Nov 2004 06:21:26 +0900, Mohammad Khan <> wrote:
    >
    > There have missing links in http://raa.ruby-lang.org/project/fastcgi/
    > for homepage and download.
    >
    > Is there any alternate location to download?
    >
    > I also tried with 'gem',
    > [root@localhost root]# gem install fastcgi --remote
    > Attempting remote installation of 'fastcgi'
    > ERROR: While executing gem ... (Gem::GemNotFoundException)
    > Could not find fastcgi (> 0) in the repository
    >
    > Thanks,
    > MOhammad
    >
    > --
    >
    > [mkhan@localhost local]$ make love
    > make: *** No rule to make target `love'. Stop.
    >
    >



    --
    Tobi
    http://blog.leetsoft.com
     
    Tobias Luetke, Nov 18, 2004
    #9
  10. Re: FastCGI ... missing link

    On Wed, 2004-11-17 at 21:06, Tobias Luetke wrote:
    > try gem install fcgi
    >
    > gem list -r to see whats available
    >
    >



    fcgi and fastcgi is not same.
    fcgi written by MoonWolf and current status is 'usable'.
    On the other hand fastcgi written by Eli Green and current status is
    'stable'. Moreover, fastcgi is reffered by the homepage of FastCGI
    (http://www.fastcgi.com)

    So, I prefer to use fastcgi.


    Thanks,
    Mohammad


    > On Wed, 17 Nov 2004 06:21:26 +0900, Mohammad Khan <> wrote:
    > >
    > > There have missing links in http://raa.ruby-lang.org/project/fastcgi/
    > > for homepage and download.
    > >
    > > Is there any alternate location to download?
    > >
    > > I also tried with 'gem',
    > > [root@localhost root]# gem install fastcgi --remote
    > > Attempting remote installation of 'fastcgi'
    > > ERROR: While executing gem ... (Gem::GemNotFoundException)
    > > Could not find fastcgi (> 0) in the repository
    > >
    > > Thanks,
    > > MOhammad
    > >
    > > --
    > >
    > > [mkhan@localhost local]$ make love
    > > make: *** No rule to make target `love'. Stop.
    > >
    > >
     
    Mohammad Khan, Nov 18, 2004
    #10
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Vagif Abilov
    Replies:
    2
    Views:
    570
    Vagif Abilov
    Jul 7, 2004
  2. Pedro Mir
    Replies:
    2
    Views:
    442
    Winista
    Jun 20, 2006
  3. Nicolas Lehuen
    Replies:
    3
    Views:
    719
    Nicolas Lehuen
    Jan 28, 2004
  4. Toon Knapen
    Replies:
    2
    Views:
    363
    Toon Knapen
    May 17, 2006
  5. Brian Candler
    Replies:
    1
    Views:
    219
    Brian Candler
    Oct 21, 2004
Loading...

Share This Page