Eclipse error: Specified VM install not found: type Standard VM, name j2re1.4.2_08

Discussion in 'Java' started by HeatherB, Jul 25, 2005.

  1. HeatherB

    HeatherB Guest

    Windows XP + Eclipse 3.0.2 + ant 1.6.5 + tomcat 5.x

    After attempting to upgrade a global project to its most recent code
    base in CVS, we now are suffering from the following compile failure
    (using ant compile within eclipse):

    Specified VM install not found: type Standard VM, name j2re1.4.2_08

    We are using j2sdk1.4.2_08 installed under
    c:\program files\java\j2sdk1.4.2_08

    When the SDK was installed it also installed j2re under
    c:\program files\java\j2re1.4.2_08
    but we don't have any env variables or path pointing here (JAVA_HOME
    points to SDK, PATH point to SDK\bin).

    I've tried replacing all references to j2re with j2sdk (using a binary
    replace utility) underneath our eclipse workspace directory and
    underneath the eclipse installation directory but this error keeps
    coming back.

    Also followed suggestions to blow away all .launch configurations and
    recreate (which I did even though they didn't have any reference to
    j2re).

    I also tried to run with command line arg -clean (suggested for same
    problem under Eclipse 3.1.0 but I don't think 3.0.2 seems to understand
    this argument).

    Is there else something taken from the window registry (that I also
    need to clean out specifically)? Any other locations to check for
    cached parameters? Any other suggestions?
     
    HeatherB, Jul 25, 2005
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. MovnOn
    Replies:
    0
    Views:
    404
    MovnOn
    Oct 14, 2003
  2. Replies:
    0
    Views:
    791
  3. Replies:
    1
    Views:
    3,227
    lordy
    Jun 29, 2006
  4. ben
    Replies:
    0
    Views:
    110
  5. Big Moxy
    Replies:
    1
    Views:
    117
    Big Moxy
    Nov 26, 2007
Loading...

Share This Page