fastthread installation fails - debian - w or w/o gem

Discussion in 'Ruby' started by paukul@googlemail.com, Feb 26, 2007.

  1. Guest

    Hi,

    iam trying to install fastthread, but it fails with the message:
    ---------
    Building native extensions. This could take a while...
    extconf.rb:1:in `require': no such file to load -- mkmf (LoadError)
    from extconf.rb:1

    ERROR: While executing gem ... (RuntimeError)
    ERROR: Failed to build gem native extension.
    Gem files will remain installed in /var/lib/gems/1.8/gems/
    fastthread-0.6.4.1 for inspection.


    Results logged to /var/lib/gems/1.8/gems/fastthread-0.6.4.1/ext/
    fastthread/gem_make.out
    --------

    i tried it both with gem install fastthread and by downloading it from
    the project
    website und install it with ruby setup.rb => Same result

    Iam realy new with ruby so i don't know what to do. google didnt help
    me anyway... I'd be happy if someone could give me a hint..

    Pascal Friederich
    , Feb 26, 2007
    #1
    1. Advertising

  2. On Mon, Feb 26, 2007 at 06:40:05PM +0900, wrote:
    > Hi,
    >
    > iam trying to install fastthread, but it fails with the message:
    > ---------
    > Building native extensions. This could take a while...
    > extconf.rb:1:in `require': no such file to load -- mkmf (LoadError)
    > from extconf.rb:1


    For Debian/Ubuntu, you need to install the ruby1.8-dev package to get mkmf
    (which is a standard part of Ruby, it's just that Debian broke up the core
    Ruby into shrapnel packages)

    HTH,

    Brian.
    Brian Candler, Feb 26, 2007
    #2
    1. Advertising

  3. Guest

    On 26 Feb., 10:44, Brian Candler <> wrote:

    > For Debian/Ubuntu, you need to install the ruby1.8-dev package to get mkmf
    > (which is a standard part of Ruby, it's just that Debian broke up the core
    > Ruby into shrapnel packages)


    works. thanks so much!
    , Feb 26, 2007
    #3
  4. MenTaLguY Guest

    On Mon, 26 Feb 2007 18:40:05 +0900, "" <> wrote:
    > Hi,
    >
    > iam trying to install fastthread, but it fails with the message:
    > ---------
    > Building native extensions. This could take a while...
    > extconf.rb:1:in `require': no such file to load -- mkmf (LoadError)
    > from extconf.rb:1


    You will need to install the ruby1.8-dev Debian package in order to be able to install gems with C extensions (like fastthread).

    -mental
    MenTaLguY, Feb 26, 2007
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Luke Kenneth Casson Leighton
    Replies:
    0
    Views:
    453
    Luke Kenneth Casson Leighton
    Dec 31, 2008
  2. Michael Glaesemann

    gem query finds gem, yet require fails

    Michael Glaesemann, Nov 12, 2006, in forum: Ruby
    Replies:
    5
    Views:
    141
    Michael Glaesemann
    Nov 26, 2006
  3. Austin 7873
    Replies:
    5
    Views:
    175
    Eric Hodel
    Jan 27, 2007
  4. Vassilis Rizopoulos

    Rubygems 0.9.5 and fastthread mswin32 gem

    Vassilis Rizopoulos, Dec 5, 2007, in forum: Ruby
    Replies:
    5
    Views:
    117
    Luis Lavena
    Dec 11, 2007
  5. Olivier Lolveley
    Replies:
    3
    Views:
    184
    Olivier Lolveley
    Apr 29, 2009
Loading...

Share This Page