I can't explain why my scripts run different (even with differentstyle rendering) on two machines

Discussion in 'HTML' started by Gotch@, Dec 11, 2008.

  1. Gotch@

    Gotch@ Guest

    Hello,
    I hit a veyr nasty error that I can't explain and it's giving me huge
    headaches. Here's the situation: I developing a PHP + Javascript (Dojo
    and plain javascript) application. The development environment on
    local is wamp. Now the problem: after installing wamp on another
    machine ( I forgot to tell you that the machines are windows ones,
    mine is Vista, the other XP) and putting on all the files happen the
    following things:

    - Sometimes CSS affects the document in different ways (of course
    using the same machine, the same browser (ie or firefox, no matter,
    still the same result), e.g. looking at the same page will display
    scrollbars on the server and won't on my machine. Or tables are
    rendered differently.

    - I got nasty errors from dojo when the app is on the server machine
    (of course using the same browser).

    I tried everything: clearing caches, cookies and whatever. I can't get
    an explanation. I even copied on the server the very same php.ini
    configuration file. - No Effect -

    What can cause this unexplicable behaviour???? Any ideas...?? i'm
    getting crazy because of this...
     
    Gotch@, Dec 11, 2008
    #1
    1. Advertising

  2. Re: I can't explain why my scripts run different (even with different style rendering) on two machines

    Gazing into my crystal ball I observed "Gotch@" <>
    writing in news:acac9d8e-44a3-4b80-963d-98ff4a971430@
    40g2000prx.googlegroups.com:

    > Hello,
    > I hit a veyr nasty error that I can't explain and it's giving me huge
    > headaches. Here's the situation: I developing a PHP + Javascript (Dojo
    > and plain javascript) application. The development environment on
    > local is wamp. Now the problem: after installing wamp on another
    > machine ( I forgot to tell you that the machines are windows ones,
    > mine is Vista, the other XP) and putting on all the files happen the
    > following things:
    >
    > - Sometimes CSS affects the document in different ways (of course
    > using the same machine, the same browser (ie or firefox, no matter,
    > still the same result), e.g. looking at the same page will display
    > scrollbars on the server and won't on my machine. Or tables are
    > rendered differently.
    >
    > - I got nasty errors from dojo when the app is on the server machine
    > (of course using the same browser).
    >
    > I tried everything: clearing caches, cookies and whatever. I can't get
    > an explanation. I even copied on the server the very same php.ini
    > configuration file. - No Effect -
    >
    > What can cause this unexplicable behaviour???? Any ideas...?? i'm
    > getting crazy because of this...
    >


    The first thing I do when I have rendering issues is validate the markup
    and the CSS. Then I clean up any errors and test again. You might want
    to test with Firefox Firebug on both machines as well.


    --
    Adrienne Boswell at Home
    Arbpen Web Site Design Services
    http://www.cavalcade-of-coding.info
    Please respond to the group so others can share
     
    Adrienne Boswell, Dec 12, 2008
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Johnny Ruin
    Replies:
    5
    Views:
    507
  2. Replies:
    1
    Views:
    360
    Juan T. Llibre
    Jul 20, 2006
  3. Mr. SweatyFinger
    Replies:
    2
    Views:
    2,077
    Smokey Grindel
    Dec 2, 2006
  4. Christopher Brewster
    Replies:
    5
    Views:
    357
    John Machin
    Nov 14, 2008
  5. Replies:
    0
    Views:
    163
Loading...

Share This Page