IIS stopped recognizing AD groups

Discussion in 'ASP .Net Security' started by Thomas G, Mar 27, 2006.

  1. Thomas G

    Thomas G Guest

    Hi,

    We recently reformatted a web server. After redeploying, both the IsInRole
    method and the web.config authorization section stopped working. (.NET 1.1)
    This app had been working fine before the reformat with the same settings.

    Windows impersonation was enabled and anonymous access was off.
    User.Identity.Name returned the proper credentials.

    For several days and multiple restarts this continued, but after a weekend
    of no changes it started working properly.

    Anyone know why that would happen?
    Thomas G, Mar 27, 2006
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Petra Hübner
    Replies:
    0
    Views:
    428
    Petra Hübner
    Feb 16, 2004
  2. anonymous
    Replies:
    1
    Views:
    4,534
    Francisco Padron
    May 8, 2005
  3. Replies:
    3
    Views:
    350
    Peter Hansen
    Jun 10, 2005
  4. John Gonsalves
    Replies:
    15
    Views:
    708
    Alexey Smirnov
    Apr 9, 2007
  5. TygerKrash

    role/group authorization not recognizing user groups.

    TygerKrash, Nov 6, 2007, in forum: ASP .Net Security
    Replies:
    4
    Views:
    233
    TygerKrash
    Nov 14, 2007
Loading...

Share This Page