jEdit: compiles JDK 1.5.0 ok, but runs JDK 1.4.1 (why?)

Discussion in 'Java' started by Thomas G. Marshall, Aug 4, 2004.

  1. Hi, I have jEdit (ver 4.2pre15) configured to use

    C:\jdk1.5.0\bin\javac

    for compiling, but I see no place where I can tell it to execute with

    C:\jdk1.5.0\bin\java

    unless I hand type it all out in the console plugin. It seems to default to
    my /prior/ 1.4.1 jre installation's java.exe (not my prior jedit
    installation, since I've never installed it before):

    C:\Programs\jdk1.4.1_02\bin\java

    When I ask the console plugin for what the current path is, I get this
    prepended to the path:

    C:\Programs\jdk1.4.1_02\bin;

    (...) And this is not showing up in my user path verified both through a
    "dos window" and from the control panel->System->Advanced->environment
    variables. I'm on windows XP pro.

    What's going on? How do I /execute/ on jdk1.5.0 by default?

    --
    It'salwaysbeenmygoalinlifetocreateasignaturethatendedwiththeword"blarphoogy"
    ..
    Thomas G. Marshall, Aug 4, 2004
    #1
    1. Advertising

  2. Thomas G. Marshall

    Jim Sculley Guest

    Thomas G. Marshall wrote:
    > Hi, I have jEdit (ver 4.2pre15) configured to use
    >
    > C:\jdk1.5.0\bin\javac
    >
    > for compiling, but I see no place where I can tell it to execute with
    >
    > C:\jdk1.5.0\bin\java
    >
    > unless I hand type it all out in the console plugin. It seems to default to
    > my /prior/ 1.4.1 jre installation's java.exe (not my prior jedit
    > installation, since I've never installed it before):
    >
    > C:\Programs\jdk1.4.1_02\bin\java
    >
    > When I ask the console plugin for what the current path is, I get this
    > prepended to the path:
    >
    > C:\Programs\jdk1.4.1_02\bin;
    >
    > (...) And this is not showing up in my user path verified both through a
    > "dos window" and from the control panel->System->Advanced->environment
    > variables. I'm on windows XP pro.
    >
    > What's going on? How do I /execute/ on jdk1.5.0 by default?


    I think 'Start...Programs...jEdit...Set jEdit Parameters' will take you
    to the place to change the Java runtime being used.

    Jim S.

    --
    Remove my extraneous mandibular appendages to reply via email.
    Jim Sculley, Aug 5, 2004
    #2
    1. Advertising

  3. Thomas G. Marshall

    Ike Guest

    Can you step through code in JEdit? Set breakpoints? -Ike

    "Jim Sculley" <> wrote in message
    news:...
    > Thomas G. Marshall wrote:
    > > Hi, I have jEdit (ver 4.2pre15) configured to use
    > >
    > > C:\jdk1.5.0\bin\javac
    > >
    > > for compiling, but I see no place where I can tell it to execute with
    > >
    > > C:\jdk1.5.0\bin\java
    > >
    > > unless I hand type it all out in the console plugin. It seems to default

    to
    > > my /prior/ 1.4.1 jre installation's java.exe (not my prior jedit
    > > installation, since I've never installed it before):
    > >
    > > C:\Programs\jdk1.4.1_02\bin\java
    > >
    > > When I ask the console plugin for what the current path is, I get this
    > > prepended to the path:
    > >
    > > C:\Programs\jdk1.4.1_02\bin;
    > >
    > > (...) And this is not showing up in my user path verified both through a
    > > "dos window" and from the control panel->System->Advanced->environment
    > > variables. I'm on windows XP pro.
    > >
    > > What's going on? How do I /execute/ on jdk1.5.0 by default?

    >
    > I think 'Start...Programs...jEdit...Set jEdit Parameters' will take you
    > to the place to change the Java runtime being used.
    >
    > Jim S.
    >
    > --
    > Remove my extraneous mandibular appendages to reply via email.
    Ike, Aug 5, 2004
    #3
  4. Ike <> coughed up the following:
    > Can you step through code in JEdit? Set breakpoints? -Ike
    >
    > "Jim Sculley" <> wrote in message
    > news:...
    >> Thomas G. Marshall wrote:
    >>> Hi, I have jEdit (ver 4.2pre15) configured to use
    >>>
    >>> C:\jdk1.5.0\bin\javac
    >>>
    >>> for compiling, but I see no place where I can tell it to execute
    >>> with
    >>>
    >>> C:\jdk1.5.0\bin\java
    >>>
    >>> unless I hand type it all out in the console plugin. It seems to
    >>> default to my /prior/ 1.4.1 jre installation's java.exe (not my
    >>> prior jedit installation, since I've never installed it before):
    >>>
    >>> C:\Programs\jdk1.4.1_02\bin\java
    >>>
    >>> When I ask the console plugin for what the current path is, I get
    >>> this prepended to the path:
    >>>
    >>> C:\Programs\jdk1.4.1_02\bin;
    >>>
    >>> (...) And this is not showing up in my user path verified both
    >>> through a "dos window" and from the control
    >>> panel->System->Advanced->environment variables. I'm on windows XP
    >>> pro.
    >>>
    >>> What's going on? How do I /execute/ on jdk1.5.0 by default?

    >>
    >> I think 'Start...Programs...jEdit...Set jEdit Parameters' will take
    >> you to the place to change the Java runtime being used.



    There is no such option in Start->Programs->jEdit. The only two programs
    there are

    jEdit
    and
    Uninstall jEdit

    And I can find no similar option anywhere within jEdit itself. Are you
    using jEdit 4.2pre15? Is this a less-reliable pre-release or something?

    Thanks!


    --
    "So I just, uh... I just cut them up like regular chickens?"
    "Sure, just cut them up like regular chickens."
    Thomas G. Marshall, Aug 5, 2004
    #4
  5. In article <YDgQc.2710$XV5.64@trndny06>,
    Thomas G. Marshall <> wrote:
    >Ike <> coughed up the following:
    >> Can you step through code in JEdit? Set breakpoints? -Ike
    >>
    >> "Jim Sculley" <> wrote in message
    >> news:...
    >>> Thomas G. Marshall wrote:
    >>>> Hi, I have jEdit (ver 4.2pre15) configured to use
    >>>>
    >>>> C:\jdk1.5.0\bin\javac
    >>>>
    >>>> for compiling, but I see no place where I can tell it to execute
    >>>> with
    >>>>
    >>>> C:\jdk1.5.0\bin\java
    >>>>
    >>>> unless I hand type it all out in the console plugin. It seems to
    >>>> default to my /prior/ 1.4.1 jre installation's java.exe (not my
    >>>> prior jedit installation, since I've never installed it before):
    >>>>
    >>>> C:\Programs\jdk1.4.1_02\bin\java
    >>>>
    >>>> When I ask the console plugin for what the current path is, I get
    >>>> this prepended to the path:
    >>>>
    >>>> C:\Programs\jdk1.4.1_02\bin;
    >>>>
    >>>> (...) And this is not showing up in my user path verified both
    >>>> through a "dos window" and from the control
    >>>> panel->System->Advanced->environment variables. I'm on windows XP
    >>>> pro.
    >>>>
    >>>> What's going on? How do I /execute/ on jdk1.5.0 by default?
    >>>
    >>> I think 'Start...Programs...jEdit...Set jEdit Parameters' will take
    >>> you to the place to change the Java runtime being used.

    >
    >
    >There is no such option in Start->Programs->jEdit. The only two programs
    >there are
    >
    > jEdit
    >and
    > Uninstall jEdit
    >
    >And I can find no similar option anywhere within jEdit itself. Are you
    >using jEdit 4.2pre15? Is this a less-reliable pre-release or something?
    >


    Can't speak for Jim Scully, but 'Set JEdit Parameters' is present in
    my JEdit folder. I'm using 4.1final. Either 4.2pre15 is doing it
    differently (maybe an option in JEdit itself?) or maybe ... did you
    perform a custom install? Maybe you skipped a feature that you
    thought was unimportant? Just wildly guessing at this point.

    --
    -john

    February 28 1997: Last day libraries could order catalogue cards
    from the Library of Congress.
    John M. Gamble, Aug 6, 2004
    #5
  6. John M. Gamble <> coughed up the following:
    > In article <YDgQc.2710$XV5.64@trndny06>,
    > Thomas G. Marshall
    > <> wrote:


    ---[rip]---

    >> There is no such option in Start->Programs->jEdit. The only two
    >> programs there are
    >>
    >> jEdit
    >> and
    >> Uninstall jEdit
    >>
    >> And I can find no similar option anywhere within jEdit itself. Are
    >> you
    >> using jEdit 4.2pre15? Is this a less-reliable pre-release or
    >> something?
    >>

    >
    > Can't speak for Jim Scully, but 'Set JEdit Parameters' is present in
    > my JEdit folder. I'm using 4.1final. Either 4.2pre15 is doing it
    > differently (maybe an option in JEdit itself?) or maybe ... did you
    > perform a custom install? Maybe you skipped a feature that you
    > thought was unimportant? Just wildly guessing at this point.


    No, did a "full install". Did it again to make sure. Same thing. So I
    went back and downloaded your 4.1final. It actually /has/ the "Set jEdit
    Parameters" entry in the jEdit folder. But now it kicks out an error
    whenever I try to download the 4.1 pluggins I need.

    Go figger. It's probably just that the website is down when I tried it.
    I'll try again later.

    In any case, the Cheetah mod for Eclipse seems to be getting some good
    reactions to folks. Maybe I'll have to {sigh} try that one now too.

    Netbeans also seems like it's going to be 1.5 compliant, but just isn't yet.
    And the Sun One IDE thing is expensive. Stupidly so, since it seems that
    others do more for less.


    --
    Forgetthesong,I'dratherhavethefrontallobotomy...
    Thomas G. Marshall, Aug 6, 2004
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jason

    Building jEdit w/ JDK 1.3

    Jason, Feb 10, 2005, in forum: Java
    Replies:
    2
    Views:
    559
    Amir Michail
    Feb 11, 2005
  2. Mr. SweatyFinger
    Replies:
    2
    Views:
    1,840
    Smokey Grindel
    Dec 2, 2006
  3. Rock
    Replies:
    4
    Views:
    434
    Jim Langston
    Nov 20, 2005
  4. Replies:
    4
    Views:
    329
    Peter
    Jun 20, 2006
  5. froil
    Replies:
    4
    Views:
    120
    J├╝rgen Exner
    Mar 8, 2006
Loading...

Share This Page