Problem with WinForms User Control Hosted in IE

Discussion in 'ASP .Net' started by =?Utf-8?B?U2VnZmFobHQ=?=, Jan 9, 2006.

  1. I need a little help here please.

    I have 2 win forms user controls in 2 different projects that I'm hosting in
    2 different virtual directories. The controls have been test and operate okay
    in both projects.

    Both controls(dlls) have been signed using SN.exe and I've set up the
    appropriate .Net assembly permissions using those Strong Names
    The DLL's have been copied to the /bin directory in both web virtual
    directories.

    Here is the object tag for each of the web pages that are hosting the win
    form control
    <OBJECT class="object" id="mNewCC" style="WIDTH: 392px; HEIGHT: 356px"
    height="356" width="392"
    classid="bin/NewCC.dll#ICCDB.NewCCCtrl" VIEWASTEXT>
    </OBJECT>


    <OBJECT class="object" id="upload1"
    classid="bin/Upload.dll#Mattel.DD.RH.CopyToZeusCtrl"
    VIEWASTEXT height="300" width="300">
    <param NAME="RHServicesURL" value="http://RightHemisphere/blah/blah">
    <PARAM NAME="MaxSessionUpload" VALUE="-1">
    </OBJECT>


    My problem is that the first one doesn't work, while the 2nd one works fine.
    I've checked both file system and virtual directory permissions and they are
    identical for each.

    If I copy the DLL to the virtual directory root and alter my classid values
    to be like "classid=DLLNAME.dll#CONTROLNAME.ClassName" then they both work as
    well, so I Know the IE hosting is working fine.

    When I go into the .Net 1.1 configuration under admin tools and and set up
    the assembly permissions, I can choose the Dll with both no problem and
    assing it.

    However, when I try to "Evaluate Assembly" from Runtime Security Policy
    link, it doesn't work for the NewCC.dll when I check for it against the
    http://localhost/<virtualdirectoryname>/bin/NewCC.dll

    If I try the same thing against the
    http://localhost/<virtualdirectoryname>/bin/bin/Upload.dll

    it works fine.

    An excerpt of my weblog shows the following.
    21:17:03 127.0.0.1 GET /WFIEI/bin/NewCC.dll 403

    Which indicates permissions problems.

    Can somebody maybe point me to some tools I can use to troubleshoot the
    issue?

    thanks in advance
    =?Utf-8?B?U2VnZmFobHQ=?=, Jan 9, 2006
    #1
    1. Advertising

  2. Hi Segfahlt,

    Welcome to ASPNET newsgroup.
    As for the IE hosted winform control not work in some asp.net application
    problem, based on my experience it is likely due to the IIS virtual
    folder's permission setting....

    For IE hosted winform control, their assembly will be downloaded by the
    clientside IE browser (just like download other page or image
    resources....), so the virtual folder where we put them should have at
    least read permission (the permission in IIS directory setting rather than
    NTFS setting....). So please check the private "bin" folder(which not
    work) 's directory setting in IIS manager(inetmgr) to see whether it has
    been checked on "Read" permission.... And to check this ,we can also put
    a simple html file in bin folder and try visiting it through client IE
    browser... If the html file can be correctly displayed, assembly(.dll
    file) should also be able to be downloaded by client side....

    Hope helps. Thanks,

    Steven Cheng
    Microsoft Online Support

    Get Secure! www.microsoft.com/security
    (This posting is provided "AS IS", with no warranties, and confers no
    rights.)





    --------------------
    | Thread-Topic: Problem with WinForms User Control Hosted in IE
    | thread-index: AcYVYrsRfT14muHRRBuaFytC8yXU4g==
    | X-WBNR-Posting-Host: 64.182.114.253
    | From: "=?Utf-8?B?U2VnZmFobHQ=?=" <>
    | Subject: Problem with WinForms User Control Hosted in IE
    | Date: Mon, 9 Jan 2006 13:22:01 -0800
    | Lines: 57
    | Message-ID: <>
    | MIME-Version: 1.0
    | Content-Type: text/plain;
    | charset="Utf-8"
    | Content-Transfer-Encoding: 7bit
    | X-Newsreader: Microsoft CDO for Windows 2000
    | Content-Class: urn:content-classes:message
    | Importance: normal
    | Priority: normal
    | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    | Newsgroups: microsoft.public.dotnet.framework.aspnet
    | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
    | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA03.phx.gbl
    | Xref: TK2MSFTNGXA02.phx.gbl
    microsoft.public.dotnet.framework.aspnet:369622
    | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    |
    | I need a little help here please.
    |
    | I have 2 win forms user controls in 2 different projects that I'm hosting
    in
    | 2 different virtual directories. The controls have been test and operate
    okay
    | in both projects.
    |
    | Both controls(dlls) have been signed using SN.exe and I've set up the
    | appropriate .Net assembly permissions using those Strong Names
    | The DLL's have been copied to the /bin directory in both web virtual
    | directories.
    |
    | Here is the object tag for each of the web pages that are hosting the win
    | form control
    | <OBJECT class="object" id="mNewCC" style="WIDTH: 392px; HEIGHT: 356px"
    | height="356" width="392"
    | classid="bin/NewCC.dll#ICCDB.NewCCCtrl" VIEWASTEXT>
    | </OBJECT>
    |
    |
    | <OBJECT class="object" id="upload1"
    | classid="bin/Upload.dll#Mattel.DD.RH.CopyToZeusCtrl"
    | VIEWASTEXT height="300" width="300">
    | <param NAME="RHServicesURL" value="http://RightHemisphere/blah/blah">
    | <PARAM NAME="MaxSessionUpload" VALUE="-1">
    | </OBJECT>
    |
    |
    | My problem is that the first one doesn't work, while the 2nd one works
    fine.
    | I've checked both file system and virtual directory permissions and they
    are
    | identical for each.
    |
    | If I copy the DLL to the virtual directory root and alter my classid
    values
    | to be like "classid=DLLNAME.dll#CONTROLNAME.ClassName" then they both
    work as
    | well, so I Know the IE hosting is working fine.
    |
    | When I go into the .Net 1.1 configuration under admin tools and and set
    up
    | the assembly permissions, I can choose the Dll with both no problem and
    | assing it.
    |
    | However, when I try to "Evaluate Assembly" from Runtime Security Policy
    | link, it doesn't work for the NewCC.dll when I check for it against the
    | http://localhost/<virtualdirectoryname>/bin/NewCC.dll
    |
    | If I try the same thing against the
    | http://localhost/<virtualdirectoryname>/bin/bin/Upload.dll
    |
    | it works fine.
    |
    | An excerpt of my weblog shows the following.
    | 21:17:03 127.0.0.1 GET /WFIEI/bin/NewCC.dll 403
    |
    | Which indicates permissions problems.
    |
    | Can somebody maybe point me to some tools I can use to troubleshoot the
    | issue?
    |
    | thanks in advance
    |
    Steven Cheng[MSFT], Jan 10, 2006
    #2
    1. Advertising

  3. Hi Steven,

    Thank you for the reply.

    Yes. That is kind of what's going on. If I enter debugging mode in my VS
    ..Net project, it doesn't see the DLL in the bin directory. If I then manually
    go in and set the bin dir to read, then my web page can access the DLL.
    However, as soon as I stop debugging and start again, the bin directory has
    been reset to not-readable.

    What was happing a couple days ago, and I think it had something to do with
    the server extensions, is that it wouldn't reset the bin directory to
    not-readable each time, so, as a result, the bin directory is readable when I
    step into debug mode, and I'm able to debug my winform control. I thought
    that was pretty convenient.

    I'm still investigating. Is there a good reference on the server extensions
    and that the following files control, do you know:
    _vti_cnf
    _vti_pvt
    _vti_script
    _vti_txt

    and inside the _vti_pvt folder I see the following files which I'd like to
    get more info on.
    access
    deptodoc.btr
    doctodep.btr
    service
    service.lck
    services

    If you don't know right off the top of your head, don't worry about it, I'm
    in the process of googling it now.

    thanks,

    Seg

    "Steven Cheng[MSFT]" wrote:

    > Hi Segfahlt,
    >
    > Welcome to ASPNET newsgroup.
    > As for the IE hosted winform control not work in some asp.net application
    > problem, based on my experience it is likely due to the IIS virtual
    > folder's permission setting....
    >
    > For IE hosted winform control, their assembly will be downloaded by the
    > clientside IE browser (just like download other page or image
    > resources....), so the virtual folder where we put them should have at
    > least read permission (the permission in IIS directory setting rather than
    > NTFS setting....). So please check the private "bin" folder(which not
    > work) 's directory setting in IIS manager(inetmgr) to see whether it has
    > been checked on "Read" permission.... And to check this ,we can also put
    > a simple html file in bin folder and try visiting it through client IE
    > browser... If the html file can be correctly displayed, assembly(.dll
    > file) should also be able to be downloaded by client side....
    >
    > Hope helps. Thanks,
    >
    > Steven Cheng
    > Microsoft Online Support
    >
    > Get Secure! www.microsoft.com/security
    > (This posting is provided "AS IS", with no warranties, and confers no
    > rights.)
    >
    >
    >
    >
    >
    > --------------------
    > | Thread-Topic: Problem with WinForms User Control Hosted in IE
    > | thread-index: AcYVYrsRfT14muHRRBuaFytC8yXU4g==
    > | X-WBNR-Posting-Host: 64.182.114.253
    > | From: "=?Utf-8?B?U2VnZmFobHQ=?=" <>
    > | Subject: Problem with WinForms User Control Hosted in IE
    > | Date: Mon, 9 Jan 2006 13:22:01 -0800
    > | Lines: 57
    > | Message-ID: <>
    > | MIME-Version: 1.0
    > | Content-Type: text/plain;
    > | charset="Utf-8"
    > | Content-Transfer-Encoding: 7bit
    > | X-Newsreader: Microsoft CDO for Windows 2000
    > | Content-Class: urn:content-classes:message
    > | Importance: normal
    > | Priority: normal
    > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    > | Newsgroups: microsoft.public.dotnet.framework.aspnet
    > | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
    > | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA03.phx.gbl
    > | Xref: TK2MSFTNGXA02.phx.gbl
    > microsoft.public.dotnet.framework.aspnet:369622
    > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > |
    > | I need a little help here please.
    > |
    > | I have 2 win forms user controls in 2 different projects that I'm hosting
    > in
    > | 2 different virtual directories. The controls have been test and operate
    > okay
    > | in both projects.
    > |
    > | Both controls(dlls) have been signed using SN.exe and I've set up the
    > | appropriate .Net assembly permissions using those Strong Names
    > | The DLL's have been copied to the /bin directory in both web virtual
    > | directories.
    > |
    > | Here is the object tag for each of the web pages that are hosting the win
    > | form control
    > | <OBJECT class="object" id="mNewCC" style="WIDTH: 392px; HEIGHT: 356px"
    > | height="356" width="392"
    > | classid="bin/NewCC.dll#ICCDB.NewCCCtrl" VIEWASTEXT>
    > | </OBJECT>
    > |
    > |
    > | <OBJECT class="object" id="upload1"
    > | classid="bin/Upload.dll#Mattel.DD.RH.CopyToZeusCtrl"
    > | VIEWASTEXT height="300" width="300">
    > | <param NAME="RHServicesURL" value="http://RightHemisphere/blah/blah">
    > | <PARAM NAME="MaxSessionUpload" VALUE="-1">
    > | </OBJECT>
    > |
    > |
    > | My problem is that the first one doesn't work, while the 2nd one works
    > fine.
    > | I've checked both file system and virtual directory permissions and they
    > are
    > | identical for each.
    > |
    > | If I copy the DLL to the virtual directory root and alter my classid
    > values
    > | to be like "classid=DLLNAME.dll#CONTROLNAME.ClassName" then they both
    > work as
    > | well, so I Know the IE hosting is working fine.
    > |
    > | When I go into the .Net 1.1 configuration under admin tools and and set
    > up
    > | the assembly permissions, I can choose the Dll with both no problem and
    > | assing it.
    > |
    > | However, when I try to "Evaluate Assembly" from Runtime Security Policy
    > | link, it doesn't work for the NewCC.dll when I check for it against the
    > | http://localhost/<virtualdirectoryname>/bin/NewCC.dll
    > |
    > | If I try the same thing against the
    > | http://localhost/<virtualdirectoryname>/bin/bin/Upload.dll
    > |
    > | it works fine.
    > |
    > | An excerpt of my weblog shows the following.
    > | 21:17:03 127.0.0.1 GET /WFIEI/bin/NewCC.dll 403
    > |
    > | Which indicates permissions problems.
    > |
    > | Can somebody maybe point me to some tools I can use to troubleshoot the
    > | issue?
    > |
    > | thanks in advance
    > |
    >
    >
    =?Utf-8?B?U2VnZmFobHQ=?=, Jan 10, 2006
    #3
  4. Thanks for your response Seg,

    Yes, the bin dir is a particular directory which is used by asp.net
    application to store application assemblies, so by default it should not be
    public to internet(so no read permission is granted), I'm not sure whether
    the IDE or extension will automatically reset it to non-read... However, we
    recommend that you put IE hosted control's assemblies in another sub
    virtual directory in the application directory since they're not part of
    the asp.net application's assemblies (just used by the IE hosted controls
    which is running at clientside....)

    Thanks,

    Steven Cheng
    Microsoft Online Support

    Get Secure! www.microsoft.com/security
    (This posting is provided "AS IS", with no warranties, and confers no
    rights.)




    --------------------
    | Thread-Topic: Problem with WinForms User Control Hosted in IE
    | thread-index: AcYWO4w4PqVle02jRPugh9ihP89OQw==
    | X-WBNR-Posting-Host: 64.182.114.253
    | From: "=?Utf-8?B?U2VnZmFobHQ=?=" <>
    | References: <>
    <>
    | Subject: RE: Problem with WinForms User Control Hosted in IE
    | Date: Tue, 10 Jan 2006 15:14:03 -0800
    | Lines: 164
    | Message-ID: <>
    | MIME-Version: 1.0
    | Content-Type: text/plain;
    | charset="Utf-8"
    | Content-Transfer-Encoding: 7bit
    | X-Newsreader: Microsoft CDO for Windows 2000
    | Content-Class: urn:content-classes:message
    | Importance: normal
    | Priority: normal
    | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    | Newsgroups: microsoft.public.dotnet.framework.aspnet
    | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
    | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA03.phx.gbl
    | Xref: TK2MSFTNGXA02.phx.gbl
    microsoft.public.dotnet.framework.aspnet:369938
    | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    |
    | Hi Steven,
    |
    | Thank you for the reply.
    |
    | Yes. That is kind of what's going on. If I enter debugging mode in my
    VS
    | .Net project, it doesn't see the DLL in the bin directory. If I then
    manually
    | go in and set the bin dir to read, then my web page can access the DLL.
    | However, as soon as I stop debugging and start again, the bin directory
    has
    | been reset to not-readable.
    |
    | What was happing a couple days ago, and I think it had something to do
    with
    | the server extensions, is that it wouldn't reset the bin directory to
    | not-readable each time, so, as a result, the bin directory is readable
    when I
    | step into debug mode, and I'm able to debug my winform control. I thought
    | that was pretty convenient.
    |
    | I'm still investigating. Is there a good reference on the server
    extensions
    | and that the following files control, do you know:
    | _vti_cnf
    | _vti_pvt
    | _vti_script
    | _vti_txt
    |
    | and inside the _vti_pvt folder I see the following files which I'd like
    to
    | get more info on.
    | access
    | deptodoc.btr
    | doctodep.btr
    | service
    | service.lck
    | services
    |
    | If you don't know right off the top of your head, don't worry about it,
    I'm
    | in the process of googling it now.
    |
    | thanks,
    |
    | Seg
    |
    | "Steven Cheng[MSFT]" wrote:
    |
    | > Hi Segfahlt,
    | >
    | > Welcome to ASPNET newsgroup.
    | > As for the IE hosted winform control not work in some asp.net
    application
    | > problem, based on my experience it is likely due to the IIS virtual
    | > folder's permission setting....
    | >
    | > For IE hosted winform control, their assembly will be downloaded by the
    | > clientside IE browser (just like download other page or image
    | > resources....), so the virtual folder where we put them should have at
    | > least read permission (the permission in IIS directory setting rather
    than
    | > NTFS setting....). So please check the private "bin" folder(which not
    | > work) 's directory setting in IIS manager(inetmgr) to see whether it
    has
    | > been checked on "Read" permission.... And to check this ,we can also
    put
    | > a simple html file in bin folder and try visiting it through client IE
    | > browser... If the html file can be correctly displayed, assembly(.dll
    | > file) should also be able to be downloaded by client side....
    | >
    | > Hope helps. Thanks,
    | >
    | > Steven Cheng
    | > Microsoft Online Support
    | >
    | > Get Secure! www.microsoft.com/security
    | > (This posting is provided "AS IS", with no warranties, and confers no
    | > rights.)
    | >
    | >
    | >
    | >
    | >
    | > --------------------
    | > | Thread-Topic: Problem with WinForms User Control Hosted in IE
    | > | thread-index: AcYVYrsRfT14muHRRBuaFytC8yXU4g==
    | > | X-WBNR-Posting-Host: 64.182.114.253
    | > | From: "=?Utf-8?B?U2VnZmFobHQ=?=" <>
    | > | Subject: Problem with WinForms User Control Hosted in IE
    | > | Date: Mon, 9 Jan 2006 13:22:01 -0800
    | > | Lines: 57
    | > | Message-ID: <>
    | > | MIME-Version: 1.0
    | > | Content-Type: text/plain;
    | > | charset="Utf-8"
    | > | Content-Transfer-Encoding: 7bit
    | > | X-Newsreader: Microsoft CDO for Windows 2000
    | > | Content-Class: urn:content-classes:message
    | > | Importance: normal
    | > | Priority: normal
    | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    | > | Newsgroups: microsoft.public.dotnet.framework.aspnet
    | > | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
    | > | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA03.phx.gbl
    | > | Xref: TK2MSFTNGXA02.phx.gbl
    | > microsoft.public.dotnet.framework.aspnet:369622
    | > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    | > |
    | > | I need a little help here please.
    | > |
    | > | I have 2 win forms user controls in 2 different projects that I'm
    hosting
    | > in
    | > | 2 different virtual directories. The controls have been test and
    operate
    | > okay
    | > | in both projects.
    | > |
    | > | Both controls(dlls) have been signed using SN.exe and I've set up the
    | > | appropriate .Net assembly permissions using those Strong Names
    | > | The DLL's have been copied to the /bin directory in both web virtual
    | > | directories.
    | > |
    | > | Here is the object tag for each of the web pages that are hosting the
    win
    | > | form control
    | > | <OBJECT class="object" id="mNewCC" style="WIDTH: 392px; HEIGHT:
    356px"
    | > | height="356" width="392"
    | > | classid="bin/NewCC.dll#ICCDB.NewCCCtrl" VIEWASTEXT>
    | > | </OBJECT>
    | > |
    | > |
    | > | <OBJECT class="object" id="upload1"
    | > | classid="bin/Upload.dll#Mattel.DD.RH.CopyToZeusCtrl"
    | > | VIEWASTEXT height="300" width="300">
    | > | <param NAME="RHServicesURL"
    value="http://RightHemisphere/blah/blah">
    | > | <PARAM NAME="MaxSessionUpload" VALUE="-1">
    | > | </OBJECT>
    | > |
    | > |
    | > | My problem is that the first one doesn't work, while the 2nd one
    works
    | > fine.
    | > | I've checked both file system and virtual directory permissions and
    they
    | > are
    | > | identical for each.
    | > |
    | > | If I copy the DLL to the virtual directory root and alter my classid
    | > values
    | > | to be like "classid=DLLNAME.dll#CONTROLNAME.ClassName" then they both
    | > work as
    | > | well, so I Know the IE hosting is working fine.
    | > |
    | > | When I go into the .Net 1.1 configuration under admin tools and and
    set
    | > up
    | > | the assembly permissions, I can choose the Dll with both no problem
    and
    | > | assing it.
    | > |
    | > | However, when I try to "Evaluate Assembly" from Runtime Security
    Policy
    | > | link, it doesn't work for the NewCC.dll when I check for it against
    the
    | > | http://localhost/<virtualdirectoryname>/bin/NewCC.dll
    | > |
    | > | If I try the same thing against the
    | > | http://localhost/<virtualdirectoryname>/bin/bin/Upload.dll
    | > |
    | > | it works fine.
    | > |
    | > | An excerpt of my weblog shows the following.
    | > | 21:17:03 127.0.0.1 GET /WFIEI/bin/NewCC.dll 403
    | > |
    | > | Which indicates permissions problems.
    | > |
    | > | Can somebody maybe point me to some tools I can use to troubleshoot
    the
    | > | issue?
    | > |
    | > | thanks in advance
    | > |
    | >
    | >
    |
    Steven Cheng[MSFT], Jan 11, 2006
    #4
  5. Hi Steven,

    Right. And I understand why you would want to do that for a production
    environment, however, if I could somehow figure out some way to re-create the
    ability of my project to access the bin directory upon start up, it would
    allow me to step into the code for debugging. That turned out to be pretty
    darn handy, for the couple days that it was working that way. I'd really like
    to get back to that point.

    Would this be the forum to discuss that? I think I'm pretty close to being
    able to re-create it with the original downloaded project, but I haven't been
    able to re-create it from scratch.

    Any ideas?

    Seg

    "Steven Cheng[MSFT]" wrote:

    > Thanks for your response Seg,
    >
    > Yes, the bin dir is a particular directory which is used by asp.net
    > application to store application assemblies, so by default it should not be
    > public to internet(so no read permission is granted), I'm not sure whether
    > the IDE or extension will automatically reset it to non-read... However, we
    > recommend that you put IE hosted control's assemblies in another sub
    > virtual directory in the application directory since they're not part of
    > the asp.net application's assemblies (just used by the IE hosted controls
    > which is running at clientside....)
    >
    > Thanks,
    >
    > Steven Cheng
    > Microsoft Online Support
    >
    > Get Secure! www.microsoft.com/security
    > (This posting is provided "AS IS", with no warranties, and confers no
    > rights.)
    >
    >
    >
    >
    > --------------------
    > | Thread-Topic: Problem with WinForms User Control Hosted in IE
    > | thread-index: AcYWO4w4PqVle02jRPugh9ihP89OQw==
    > | X-WBNR-Posting-Host: 64.182.114.253
    > | From: "=?Utf-8?B?U2VnZmFobHQ=?=" <>
    > | References: <>
    > <>
    > | Subject: RE: Problem with WinForms User Control Hosted in IE
    > | Date: Tue, 10 Jan 2006 15:14:03 -0800
    > | Lines: 164
    > | Message-ID: <>
    > | MIME-Version: 1.0
    > | Content-Type: text/plain;
    > | charset="Utf-8"
    > | Content-Transfer-Encoding: 7bit
    > | X-Newsreader: Microsoft CDO for Windows 2000
    > | Content-Class: urn:content-classes:message
    > | Importance: normal
    > | Priority: normal
    > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    > | Newsgroups: microsoft.public.dotnet.framework.aspnet
    > | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
    > | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA03.phx.gbl
    > | Xref: TK2MSFTNGXA02.phx.gbl
    > microsoft.public.dotnet.framework.aspnet:369938
    > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > |
    > | Hi Steven,
    > |
    > | Thank you for the reply.
    > |
    > | Yes. That is kind of what's going on. If I enter debugging mode in my
    > VS
    > | .Net project, it doesn't see the DLL in the bin directory. If I then
    > manually
    > | go in and set the bin dir to read, then my web page can access the DLL.
    > | However, as soon as I stop debugging and start again, the bin directory
    > has
    > | been reset to not-readable.
    > |
    > | What was happing a couple days ago, and I think it had something to do
    > with
    > | the server extensions, is that it wouldn't reset the bin directory to
    > | not-readable each time, so, as a result, the bin directory is readable
    > when I
    > | step into debug mode, and I'm able to debug my winform control. I thought
    > | that was pretty convenient.
    > |
    > | I'm still investigating. Is there a good reference on the server
    > extensions
    > | and that the following files control, do you know:
    > | _vti_cnf
    > | _vti_pvt
    > | _vti_script
    > | _vti_txt
    > |
    > | and inside the _vti_pvt folder I see the following files which I'd like
    > to
    > | get more info on.
    > | access
    > | deptodoc.btr
    > | doctodep.btr
    > | service
    > | service.lck
    > | services
    > |
    > | If you don't know right off the top of your head, don't worry about it,
    > I'm
    > | in the process of googling it now.
    > |
    > | thanks,
    > |
    > | Seg
    > |
    > | "Steven Cheng[MSFT]" wrote:
    > |
    > | > Hi Segfahlt,
    > | >
    > | > Welcome to ASPNET newsgroup.
    > | > As for the IE hosted winform control not work in some asp.net
    > application
    > | > problem, based on my experience it is likely due to the IIS virtual
    > | > folder's permission setting....
    > | >
    > | > For IE hosted winform control, their assembly will be downloaded by the
    > | > clientside IE browser (just like download other page or image
    > | > resources....), so the virtual folder where we put them should have at
    > | > least read permission (the permission in IIS directory setting rather
    > than
    > | > NTFS setting....). So please check the private "bin" folder(which not
    > | > work) 's directory setting in IIS manager(inetmgr) to see whether it
    > has
    > | > been checked on "Read" permission.... And to check this ,we can also
    > put
    > | > a simple html file in bin folder and try visiting it through client IE
    > | > browser... If the html file can be correctly displayed, assembly(.dll
    > | > file) should also be able to be downloaded by client side....
    > | >
    > | > Hope helps. Thanks,
    > | >
    > | > Steven Cheng
    > | > Microsoft Online Support
    > | >
    > | > Get Secure! www.microsoft.com/security
    > | > (This posting is provided "AS IS", with no warranties, and confers no
    > | > rights.)
    > | >
    > | >
    > | >
    > | >
    > | >
    > | > --------------------
    > | > | Thread-Topic: Problem with WinForms User Control Hosted in IE
    > | > | thread-index: AcYVYrsRfT14muHRRBuaFytC8yXU4g==
    > | > | X-WBNR-Posting-Host: 64.182.114.253
    > | > | From: "=?Utf-8?B?U2VnZmFobHQ=?=" <>
    > | > | Subject: Problem with WinForms User Control Hosted in IE
    > | > | Date: Mon, 9 Jan 2006 13:22:01 -0800
    > | > | Lines: 57
    > | > | Message-ID: <>
    > | > | MIME-Version: 1.0
    > | > | Content-Type: text/plain;
    > | > | charset="Utf-8"
    > | > | Content-Transfer-Encoding: 7bit
    > | > | X-Newsreader: Microsoft CDO for Windows 2000
    > | > | Content-Class: urn:content-classes:message
    > | > | Importance: normal
    > | > | Priority: normal
    > | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    > | > | Newsgroups: microsoft.public.dotnet.framework.aspnet
    > | > | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
    > | > | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA03.phx.gbl
    > | > | Xref: TK2MSFTNGXA02.phx.gbl
    > | > microsoft.public.dotnet.framework.aspnet:369622
    > | > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    > | > |
    > | > | I need a little help here please.
    > | > |
    > | > | I have 2 win forms user controls in 2 different projects that I'm
    > hosting
    > | > in
    > | > | 2 different virtual directories. The controls have been test and
    > operate
    > | > okay
    > | > | in both projects.
    > | > |
    > | > | Both controls(dlls) have been signed using SN.exe and I've set up the
    > | > | appropriate .Net assembly permissions using those Strong Names
    > | > | The DLL's have been copied to the /bin directory in both web virtual
    > | > | directories.
    > | > |
    > | > | Here is the object tag for each of the web pages that are hosting the
    > win
    > | > | form control
    > | > | <OBJECT class="object" id="mNewCC" style="WIDTH: 392px; HEIGHT:
    > 356px"
    > | > | height="356" width="392"
    > | > | classid="bin/NewCC.dll#ICCDB.NewCCCtrl" VIEWASTEXT>
    > | > | </OBJECT>
    > | > |
    > | > |
    > | > | <OBJECT class="object" id="upload1"
    > | > | classid="bin/Upload.dll#Mattel.DD.RH.CopyToZeusCtrl"
    > | > | VIEWASTEXT height="300" width="300">
    > | > | <param NAME="RHServicesURL"
    > value="http://RightHemisphere/blah/blah">
    > | > | <PARAM NAME="MaxSessionUpload" VALUE="-1">
    > | > | </OBJECT>
    > | > |
    > | > |
    > | > | My problem is that the first one doesn't work, while the 2nd one
    > works
    > | > fine.
    > | > | I've checked both file system and virtual directory permissions and
    > they
    > | > are
    > | > | identical for each.
    > | > |
    > | > | If I copy the DLL to the virtual directory root and alter my classid
    > | > values
    > | > | to be like "classid=DLLNAME.dll#CONTROLNAME.ClassName" then they both
    > | > work as
    > | > | well, so I Know the IE hosting is working fine.
    > | > |
    > | > | When I go into the .Net 1.1 configuration under admin tools and and
    > set
    > | > up
    > | > | the assembly permissions, I can choose the Dll with both no problem
    > and
    > | > | assing it.
    > | > |
    > | > | However, when I try to "Evaluate Assembly" from Runtime Security
    > Policy
    > | > | link, it doesn't work for the NewCC.dll when I check for it against
    > the
    > | > | http://localhost/<virtualdirectoryname>/bin/NewCC.dll
    > | > |
    > | > | If I try the same thing against the
    > | > | http://localhost/<virtualdirectoryname>/bin/bin/Upload.dll
    > | > |
    > | > | it works fine.
    > | > |
    > | > | An excerpt of my weblog shows the following.
    > | > | 21:17:03 127.0.0.1 GET /WFIEI/bin/NewCC.dll 403
    > | > |
    > | > | Which indicates permissions problems.
    > | > |
    > | > | Can somebody maybe point me to some tools I can use to troubleshoot
    > the
    > | > | issue?
    > | > |
    > | > | thanks in advance
    > | > |
    > | >
    > | >
    > |
    >
    >
    =?Utf-8?B?U2VnZmFobHQ=?=, Jan 12, 2006
    #5
  6. Thanks for your response Seg,

    For IE hosted control's debugging, we'll need to attache the IE process, so
    in bin dir won't help on debugging IE host control's code... Anyway, I'm
    not sure whether this is a machine specific behavior since I haven't found
    that VS IDE will change the IIS virtual dir permission on the "bin" dir...
    As long as I configure it to readable, it will always remains this until
    we explicitly change it....

    Regards,

    Steven Cheng
    Microsoft Online Support

    Get Secure! www.microsoft.com/security
    (This posting is provided "AS IS", with no warranties, and confers no
    rights.)


    --------------------
    | Thread-Topic: Problem with WinForms User Control Hosted in IE
    | thread-index: AcYXmwl6W3xTZ8pDSvubpdCoUzLsJg==
    | X-WBNR-Posting-Host: 63.100.125.21
    | From: "=?Utf-8?B?U2VnZmFobHQ=?=" <>
    | References: <>
    <>
    <>
    <>
    | Subject: RE: Problem with WinForms User Control Hosted in IE
    | Date: Thu, 12 Jan 2006 09:10:07 -0800
    | Lines: 260
    | Message-ID: <>
    | MIME-Version: 1.0
    | Content-Type: text/plain;
    | charset="Utf-8"
    | Content-Transfer-Encoding: 7bit
    | X-Newsreader: Microsoft CDO for Windows 2000
    | Content-Class: urn:content-classes:message
    | Importance: normal
    | Priority: normal
    | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    | Newsgroups: microsoft.public.dotnet.framework.aspnet
    | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
    | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGXA03.phx.gbl
    | Xref: TK2MSFTNGXA02.phx.gbl
    microsoft.public.dotnet.framework.aspnet:370384
    | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    |
    | Hi Steven,
    |
    | Right. And I understand why you would want to do that for a production
    | environment, however, if I could somehow figure out some way to re-create
    the
    | ability of my project to access the bin directory upon start up, it would
    | allow me to step into the code for debugging. That turned out to be
    pretty
    | darn handy, for the couple days that it was working that way. I'd really
    like
    | to get back to that point.
    |
    | Would this be the forum to discuss that? I think I'm pretty close to
    being
    | able to re-create it with the original downloaded project, but I haven't
    been
    | able to re-create it from scratch.
    |
    | Any ideas?
    |
    | Seg
    |
    | "Steven Cheng[MSFT]" wrote:
    |
    | > Thanks for your response Seg,
    | >
    | > Yes, the bin dir is a particular directory which is used by asp.net
    | > application to store application assemblies, so by default it should
    not be
    | > public to internet(so no read permission is granted), I'm not sure
    whether
    | > the IDE or extension will automatically reset it to non-read...
    However, we
    | > recommend that you put IE hosted control's assemblies in another sub
    | > virtual directory in the application directory since they're not part
    of
    | > the asp.net application's assemblies (just used by the IE hosted
    controls
    | > which is running at clientside....)
    | >
    | > Thanks,
    | >
    | > Steven Cheng
    | > Microsoft Online Support
    | >
    | > Get Secure! www.microsoft.com/security
    | > (This posting is provided "AS IS", with no warranties, and confers no
    | > rights.)
    | >
    | >
    | >
    | >
    | > --------------------
    | > | Thread-Topic: Problem with WinForms User Control Hosted in IE
    | > | thread-index: AcYWO4w4PqVle02jRPugh9ihP89OQw==
    | > | X-WBNR-Posting-Host: 64.182.114.253
    | > | From: "=?Utf-8?B?U2VnZmFobHQ=?=" <>
    | > | References: <>
    | > <>
    | > | Subject: RE: Problem with WinForms User Control Hosted in IE
    | > | Date: Tue, 10 Jan 2006 15:14:03 -0800
    | > | Lines: 164
    | > | Message-ID: <>
    | > | MIME-Version: 1.0
    | > | Content-Type: text/plain;
    | > | charset="Utf-8"
    | > | Content-Transfer-Encoding: 7bit
    | > | X-Newsreader: Microsoft CDO for Windows 2000
    | > | Content-Class: urn:content-classes:message
    | > | Importance: normal
    | > | Priority: normal
    | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    | > | Newsgroups: microsoft.public.dotnet.framework.aspnet
    | > | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
    | > | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA03.phx.gbl
    | > | Xref: TK2MSFTNGXA02.phx.gbl
    | > microsoft.public.dotnet.framework.aspnet:369938
    | > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    | > |
    | > | Hi Steven,
    | > |
    | > | Thank you for the reply.
    | > |
    | > | Yes. That is kind of what's going on. If I enter debugging mode in
    my
    | > VS
    | > | .Net project, it doesn't see the DLL in the bin directory. If I then
    | > manually
    | > | go in and set the bin dir to read, then my web page can access the
    DLL.
    | > | However, as soon as I stop debugging and start again, the bin
    directory
    | > has
    | > | been reset to not-readable.
    | > |
    | > | What was happing a couple days ago, and I think it had something to
    do
    | > with
    | > | the server extensions, is that it wouldn't reset the bin directory to
    | > | not-readable each time, so, as a result, the bin directory is
    readable
    | > when I
    | > | step into debug mode, and I'm able to debug my winform control. I
    thought
    | > | that was pretty convenient.
    | > |
    | > | I'm still investigating. Is there a good reference on the server
    | > extensions
    | > | and that the following files control, do you know:
    | > | _vti_cnf
    | > | _vti_pvt
    | > | _vti_script
    | > | _vti_txt
    | > |
    | > | and inside the _vti_pvt folder I see the following files which I'd
    like
    | > to
    | > | get more info on.
    | > | access
    | > | deptodoc.btr
    | > | doctodep.btr
    | > | service
    | > | service.lck
    | > | services
    | > |
    | > | If you don't know right off the top of your head, don't worry about
    it,
    | > I'm
    | > | in the process of googling it now.
    | > |
    | > | thanks,
    | > |
    | > | Seg
    | > |
    | > | "Steven Cheng[MSFT]" wrote:
    | > |
    | > | > Hi Segfahlt,
    | > | >
    | > | > Welcome to ASPNET newsgroup.
    | > | > As for the IE hosted winform control not work in some asp.net
    | > application
    | > | > problem, based on my experience it is likely due to the IIS virtual
    | > | > folder's permission setting....
    | > | >
    | > | > For IE hosted winform control, their assembly will be downloaded by
    the
    | > | > clientside IE browser (just like download other page or image
    | > | > resources....), so the virtual folder where we put them should have
    at
    | > | > least read permission (the permission in IIS directory setting
    rather
    | > than
    | > | > NTFS setting....). So please check the private "bin" folder(which
    not
    | > | > work) 's directory setting in IIS manager(inetmgr) to see whether
    it
    | > has
    | > | > been checked on "Read" permission.... And to check this ,we can
    also
    | > put
    | > | > a simple html file in bin folder and try visiting it through client
    IE
    | > | > browser... If the html file can be correctly displayed,
    assembly(.dll
    | > | > file) should also be able to be downloaded by client side....
    | > | >
    | > | > Hope helps. Thanks,
    | > | >
    | > | > Steven Cheng
    | > | > Microsoft Online Support
    | > | >
    | > | > Get Secure! www.microsoft.com/security
    | > | > (This posting is provided "AS IS", with no warranties, and confers
    no
    | > | > rights.)
    | > | >
    | > | >
    | > | >
    | > | >
    | > | >
    | > | > --------------------
    | > | > | Thread-Topic: Problem with WinForms User Control Hosted in IE
    | > | > | thread-index: AcYVYrsRfT14muHRRBuaFytC8yXU4g==
    | > | > | X-WBNR-Posting-Host: 64.182.114.253
    | > | > | From: "=?Utf-8?B?U2VnZmFobHQ=?=" <>
    | > | > | Subject: Problem with WinForms User Control Hosted in IE
    | > | > | Date: Mon, 9 Jan 2006 13:22:01 -0800
    | > | > | Lines: 57
    | > | > | Message-ID: <>
    | > | > | MIME-Version: 1.0
    | > | > | Content-Type: text/plain;
    | > | > | charset="Utf-8"
    | > | > | Content-Transfer-Encoding: 7bit
    | > | > | X-Newsreader: Microsoft CDO for Windows 2000
    | > | > | Content-Class: urn:content-classes:message
    | > | > | Importance: normal
    | > | > | Priority: normal
    | > | > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
    | > | > | Newsgroups: microsoft.public.dotnet.framework.aspnet
    | > | > | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
    | > | > | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGXA03.phx.gbl
    | > | > | Xref: TK2MSFTNGXA02.phx.gbl
    | > | > microsoft.public.dotnet.framework.aspnet:369622
    | > | > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
    | > | > |
    | > | > | I need a little help here please.
    | > | > |
    | > | > | I have 2 win forms user controls in 2 different projects that I'm
    | > hosting
    | > | > in
    | > | > | 2 different virtual directories. The controls have been test and
    | > operate
    | > | > okay
    | > | > | in both projects.
    | > | > |
    | > | > | Both controls(dlls) have been signed using SN.exe and I've set up
    the
    | > | > | appropriate .Net assembly permissions using those Strong Names
    | > | > | The DLL's have been copied to the /bin directory in both web
    virtual
    | > | > | directories.
    | > | > |
    | > | > | Here is the object tag for each of the web pages that are hosting
    the
    | > win
    | > | > | form control
    | > | > | <OBJECT class="object" id="mNewCC" style="WIDTH: 392px; HEIGHT:
    | > 356px"
    | > | > | height="356" width="392"
    | > | > | classid="bin/NewCC.dll#ICCDB.NewCCCtrl" VIEWASTEXT>
    | > | > | </OBJECT>
    | > | > |
    | > | > |
    | > | > | <OBJECT class="object" id="upload1"
    | > | > | classid="bin/Upload.dll#Mattel.DD.RH.CopyToZeusCtrl"
    | > | > | VIEWASTEXT height="300" width="300">
    | > | > | <param NAME="RHServicesURL"
    | > value="http://RightHemisphere/blah/blah">
    | > | > | <PARAM NAME="MaxSessionUpload" VALUE="-1">
    | > | > | </OBJECT>
    | > | > |
    | > | > |
    | > | > | My problem is that the first one doesn't work, while the 2nd one
    | > works
    | > | > fine.
    | > | > | I've checked both file system and virtual directory permissions
    and
    | > they
    | > | > are
    | > | > | identical for each.
    | > | > |
    | > | > | If I copy the DLL to the virtual directory root and alter my
    classid
    | > | > values
    | > | > | to be like "classid=DLLNAME.dll#CONTROLNAME.ClassName" then they
    both
    | > | > work as
    | > | > | well, so I Know the IE hosting is working fine.
    | > | > |
    | > | > | When I go into the .Net 1.1 configuration under admin tools and
    and
    | > set
    | > | > up
    | > | > | the assembly permissions, I can choose the Dll with both no
    problem
    | > and
    | > | > | assing it.
    | > | > |
    | > | > | However, when I try to "Evaluate Assembly" from Runtime Security
    | > Policy
    | > | > | link, it doesn't work for the NewCC.dll when I check for it
    against
    | > the
    | > | > | http://localhost/<virtualdirectoryname>/bin/NewCC.dll
    | > | > |
    | > | > | If I try the same thing against the
    | > | > | http://localhost/<virtualdirectoryname>/bin/bin/Upload.dll
    | > | > |
    | > | > | it works fine.
    | > | > |
    | > | > | An excerpt of my weblog shows the following.
    | > | > | 21:17:03 127.0.0.1 GET /WFIEI/bin/NewCC.dll 403
    | > | > |
    | > | > | Which indicates permissions problems.
    | > | > |
    | > | > | Can somebody maybe point me to some tools I can use to
    troubleshoot
    | > the
    | > | > | issue?
    | > | > |
    | > | > | thanks in advance
    | > | > |
    | > | >
    | > | >
    | > |
    | >
    | >
    |
    Steven Cheng[MSFT], Jan 13, 2006
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Joe
    Replies:
    1
    Views:
    483
  2. Joe
    Replies:
    0
    Views:
    351
  3. Joe
    Replies:
    1
    Views:
    381
  4. Joe
    Replies:
    2
    Views:
    236
  5. Mike
    Replies:
    0
    Views:
    741
Loading...

Share This Page