Server object, ASP 0177 (0x800401F3)

Discussion in 'ASP General' started by gregfocker@earthlink.net, Oct 26, 2005.

  1. Guest

    OK, the ProgID is correct. The .dll is registered. This is a
    permission issue. I can create objects when I disable anonymous access
    on the Web site in IIS (Win XP Pro). And I've given IUSR_<MachineName>
    pemissions all over the place (registry, files, folders, etc.)! Still
    can't create the objects with anonymous access enabled.

    It's not a problem on another XP Pro machine, but I can figure out the
    difference. Someone said to use dcomcnfg.exe, but the steps I was
    given don't seem to apply to my OS (likely they were for Win2K).

    Any help is greatly appreciated.
     
    , Oct 26, 2005
    #1
    1. Advertising

  2. Guest

    Anyone? Man, this is driving nuts (and killing valueable development
    time)! Thanks.
     
    , Oct 27, 2005
    #2
    1. Advertising

  3. Patrice Guest

    What do you do ? What is the exact message ? How do you have given this
    account all those rights ?

    You could try perhaps try with the "component manager" that allows to run
    just the DLL under a particular identity...

    --
    Patrice

    <> a écrit dans le message de
    news:...
    > OK, the ProgID is correct. The .dll is registered. This is a
    > permission issue. I can create objects when I disable anonymous access
    > on the Web site in IIS (Win XP Pro). And I've given IUSR_<MachineName>
    > pemissions all over the place (registry, files, folders, etc.)! Still
    > can't create the objects with anonymous access enabled.
    >
    > It's not a problem on another XP Pro machine, but I can figure out the
    > difference. Someone said to use dcomcnfg.exe, but the steps I was
    > given don't seem to apply to my OS (likely they were for Win2K).
    >
    > Any help is greatly appreciated.
    >
     
    Patrice, Oct 27, 2005
    #3
  4. Guest

    Patrice wrote:
    > What do you do ? What is the exact message ? How do you have given this
    > account all those rights ?
    >
    > You could try perhaps try with the "component manager" that allows to run
    > just the DLL under a particular identity...
    >
    > --
    > Patrice
    >


    Thanks for the reply. All I'm doing is:

    Set obj = Server.CreateObject("object.progid")

    and I get the error. It used to work until I had to rebuild the .dll.
    I also get Server.CreateObject errors when trying to instantiate other
    ActiveX objects/3rd party COM components w/anonymous access enabled. I
    don't have this problem on another machine, so there appears to be some
    type of permission issue, specifically with ISR_<machinename>.

    Are you talking about DCOMCNFG.EXE? I'm using Windows XP Pro. Can you
    or anyone else step me through this to enable whatever I need to for
    the ISR_<machinename> account?
     
    , Oct 27, 2005
    #4
  5. Patrice Guest

    Have you tried to register again the DLL ? (regsvr32).

    The easisest way to test a permission issue whould be liekly to add the IUSR
    account to the local admin group.

    Of course remove it then. If this is really a permission issue you could use
    "Component services" that is in the "admin tools". Here you can create a new
    "COM+ Application". The identity tab allows to run all components under a
    particular identity. Then you can register the DLL below this COM+
    application.

    As a result the DLL will run under the specified identity.

    As it works on another machine wihtout doing this, I would rather thought of
    some kind of registration problem (or a missing dependencty ?)...

    --
    Patrice

    <> a écrit dans le message de
    news:...
    > Patrice wrote:
    > > What do you do ? What is the exact message ? How do you have given this
    > > account all those rights ?
    > >
    > > You could try perhaps try with the "component manager" that allows to

    run
    > > just the DLL under a particular identity...
    > >
    > > --
    > > Patrice
    > >

    >
    > Thanks for the reply. All I'm doing is:
    >
    > Set obj = Server.CreateObject("object.progid")
    >
    > and I get the error. It used to work until I had to rebuild the .dll.
    > I also get Server.CreateObject errors when trying to instantiate other
    > ActiveX objects/3rd party COM components w/anonymous access enabled. I
    > don't have this problem on another machine, so there appears to be some
    > type of permission issue, specifically with ISR_<machinename>.
    >
    > Are you talking about DCOMCNFG.EXE? I'm using Windows XP Pro. Can you
    > or anyone else step me through this to enable whatever I need to for
    > the ISR_<machinename> account?
    >
     
    Patrice, Oct 28, 2005
    #5
  6. Guest

    I added the IUSR_<machinename> account to the admin group, but still
    doesn't work. It did work when I used anonymous access with an admin
    account instead of IUSR_<machinename>. This is not a problem on
    another machine, and it wasn't a problem on this machine until
    recently, so something happened.
     
    , Nov 4, 2005
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Austin

    Server object, ASP 0177 (0x800401F3)

    Austin, Sep 25, 2003, in forum: ASP General
    Replies:
    1
    Views:
    159
    Ray at
    Sep 25, 2003
  2. Nikhil Kumar Desai

    Error: Server object, ASP 0177 (0x800401F3) ..:: SOS ::..

    Nikhil Kumar Desai, Dec 20, 2003, in forum: ASP General
    Replies:
    7
    Views:
    216
    Ray at
    Dec 22, 2003
  3. rags

    Server object, ASP 0177 (0x800401F3)

    rags, Dec 9, 2004, in forum: ASP General
    Replies:
    0
    Views:
    130
  4. top

    ASP 0177 (0x800401F3) error

    top, Jan 11, 2006, in forum: ASP General
    Replies:
    1
    Views:
    124
    Bob Barrows [MVP]
    Jan 11, 2006
  5. Replies:
    4
    Views:
    496
Loading...

Share This Page