Setting up a Web Application on IIS 5.1

Discussion in 'ASP .Net' started by CES, Oct 9, 2003.

  1. CES

    CES Guest

    All,

    Could someone please point me to a step by step resource on setting up a
    ..net Web Application on IIS.

    I'm having a problem setting up IIS to except a new Web Application. I'm
    deploying the default Asp.net Web Application as is setup by VStudio with no
    code changed, other then adding "Hello World to the <title> tag. I've been
    able to narrow down the problem to IIS by compiling the Application and
    deploying it to my production site, that is maintained by my ISP,(everything
    works fine, with no errors).

    The IIS Service\Default Web Site\Application Settings under the Home
    Directory Tab
    Has these default values:

    Application Name : Default Application
    Starting point: <Default Web Site>
    Execute Permissions: Scripts Only
    Application Protection: Medium (Pooled)

    I'm running IIS Version: 5.1 under Windows XP Pro build
    2600.xpsp2.030422-1633(SP1).

    I've checked the security privileges on the WebApplication1 and the
    "aspnet_wp account" and the "Internet Guest Account" have "Full Control"
    access. Additionally the "aspnet_wp account" has full privileges on
    Windows\Microsoft.NET\Framework\v1.1.4322 and
    WINDOWS\Microsoft.NET\Framework\v1.0.3705 directories.

    From an earlier post it was suggested that I try running
    aspnet_regiis.exe -c, which created a aspnet_client directory in my root
    folder but I'm still having the same Error: Parser Error Message: Could not
    load type 'WebApplication1.Global'.

    Below is my original post to the vb.net newsgroup when I thought the error
    was in the code.

    Any help would be appreciated.

    CES


    I've created a base ASP.net web application and used the default name
    WebApplication1. Without doing !!anything!! to the WebForm1.aspx I build the
    project by going to File Menu Build\Build Solution (Ctr+Shift+B) :

    In the Output window I get:

    ------ Build started: Project: WebApplication1, Configuration: Debug
    ..NET ------
    Preparing resources...
    Updating references...
    Performing main compilation...
    Building satellite assemblies...
    ---------------------- Done ----------------------
    Build: 1 succeeded, 0 failed, 0 skipped


    I then when I hit F5 to run the project, and IE displays this Parser Error
    message:

    Parser Error Message: Could not load type 'WebApplication1.Global'.

    Source Error:

    Line 1: <%@ Application Codebehind="Global.asax.vb"
    Inherits="WebApplication1.Global" %>

    Source File: \\server\\_temp\WebApplication1\global.asax Line: 1

    I've checked the security privileges on the WebApplication1 and the
    "aspnet_wp account" and the "Internet Guest Account" have "Full Control"
    access. Additionally the "aspnet_wp account" has full privileges on
    Windows\Microsoft.NET\Framework\v1.1.4322 and
    WINDOWS\Microsoft.NET\Framework\v1.0.3705 directories.

    The only way I can get the page WebForm1.aspx to load and not throw an error
    is by removing both of the Inherits properties from these files:

    WebForm1.aspx:
    <%@ Page Language="vb" AutoEventWireup="false"
    Inherits="WebApplication1.WebForm1"%>

    Global.asax:
    <%@ Application Codebehind="Global.asax.vb"
    Inherits="WebApplication1.Global" %>

    But that doesn't seem to make any sense, if the page won't work as is why
    are the Inherits="WebApplication1.WebForm1 and
    Inherits="WebApplication1.Global" setup by default???

    Is it me or am I doing something wrong???
     
    CES, Oct 9, 2003
    #1
    1. Advertising

  2. CES

    CES Guest

    All,

    I still haven't solved this problem but I've narrowed it down a little
    further. Not sure why I didn't try this earlier but I moved the Web
    Application to my Fat32 drive and the problem went away. so it is a security
    problem!!!



    I've added permissions for both the "aspnet_wp account" and "Internet Guest
    Account" (granting full access to both accounts to the following
    directories:



    D:\Inetpub\wwwroot

    D:\Inetpub\wwwroot\WebApplication1

    D:\WINDOWS\Microsoft.NET\Framework\v1.0.3705

    D:\WINDOWS\Microsoft.NET\Framework\v1.1.4322



    Can anyone think of another place where permissions needs to be
    changed/added???

    "CES"


    <> wrote in message
    news:...
    > All,
    >
    > Could someone please point me to a step by step resource on setting up a
    > .net Web Application on IIS.
    >
    > I'm having a problem setting up IIS to except a new Web Application. I'm
    > deploying the default Asp.net Web Application as is setup by VStudio with

    no
    > code changed, other then adding "Hello World to the <title> tag. I've been
    > able to narrow down the problem to IIS by compiling the Application and
    > deploying it to my production site, that is maintained by my

    ISP,(everything
    > works fine, with no errors).
    >
    > The IIS Service\Default Web Site\Application Settings under the Home
    > Directory Tab
    > Has these default values:
    >
    > Application Name : Default Application
    > Starting point: <Default Web Site>
    > Execute Permissions: Scripts Only
    > Application Protection: Medium (Pooled)
    >
    > I'm running IIS Version: 5.1 under Windows XP Pro build
    > 2600.xpsp2.030422-1633(SP1).
    >
    > I've checked the security privileges on the WebApplication1 and the
    > "aspnet_wp account" and the "Internet Guest Account" have "Full Control"
    > access. Additionally the "aspnet_wp account" has full privileges on
    > Windows\Microsoft.NET\Framework\v1.1.4322 and
    > WINDOWS\Microsoft.NET\Framework\v1.0.3705 directories.
    >
    > From an earlier post it was suggested that I try running
    > aspnet_regiis.exe -c, which created a aspnet_client directory in my root
    > folder but I'm still having the same Error: Parser Error Message: Could

    not
    > load type 'WebApplication1.Global'.
    >
    > Below is my original post to the vb.net newsgroup when I thought the error
    > was in the code.
    >
    > Any help would be appreciated.
    >
    > CES
    >
    >
    > I've created a base ASP.net web application and used the default name
    > WebApplication1. Without doing !!anything!! to the WebForm1.aspx I build

    the
    > project by going to File Menu Build\Build Solution (Ctr+Shift+B) :
    >
    > In the Output window I get:
    >
    > ------ Build started: Project: WebApplication1, Configuration: Debug
    > .NET ------
    > Preparing resources...
    > Updating references...
    > Performing main compilation...
    > Building satellite assemblies...
    > ---------------------- Done ----------------------
    > Build: 1 succeeded, 0 failed, 0 skipped
    >
    >
    > I then when I hit F5 to run the project, and IE displays this Parser Error
    > message:
    >
    > Parser Error Message: Could not load type 'WebApplication1.Global'.
    >
    > Source Error:
    >
    > Line 1: <%@ Application Codebehind="Global.asax.vb"
    > Inherits="WebApplication1.Global" %>
    >
    > Source File: \\server\\_temp\WebApplication1\global.asax Line: 1
    >
    > I've checked the security privileges on the WebApplication1 and the
    > "aspnet_wp account" and the "Internet Guest Account" have "Full Control"
    > access. Additionally the "aspnet_wp account" has full privileges on
    > Windows\Microsoft.NET\Framework\v1.1.4322 and
    > WINDOWS\Microsoft.NET\Framework\v1.0.3705 directories.
    >
    > The only way I can get the page WebForm1.aspx to load and not throw an

    error
    > is by removing both of the Inherits properties from these files:
    >
    > WebForm1.aspx:
    > <%@ Page Language="vb" AutoEventWireup="false"
    > Inherits="WebApplication1.WebForm1"%>
    >
    > Global.asax:
    > <%@ Application Codebehind="Global.asax.vb"
    > Inherits="WebApplication1.Global" %>
    >
    > But that doesn't seem to make any sense, if the page won't work as is why
    > are the Inherits="WebApplication1.WebForm1 and
    > Inherits="WebApplication1.Global" setup by default???
    >
    > Is it me or am I doing something wrong???
    >
    >
     
    CES, Oct 10, 2003
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Matthew Louden
    Replies:
    3
    Views:
    5,967
    Sherif ElMetainy
    Nov 7, 2003
  2. mo
    Replies:
    2
    Views:
    361
    Mo hariri
    Nov 6, 2004
  3. Patrice
    Replies:
    3
    Views:
    369
  4. Benny Ng
    Replies:
    3
    Views:
    593
    Benny Ng
    Dec 1, 2006
  5. Jan Obrestad
    Replies:
    0
    Views:
    465
    Jan Obrestad
    Dec 5, 2007
Loading...

Share This Page