This source file has changed. It no longer matches...

Discussion in 'ASP .Net' started by Randy, Jun 1, 2007.

  1. Randy

    Randy Guest

    I'm using VS 2003. I have a c# ASP project. Lately, when I've been running
    the project in the IDE, I get a dialog which says...

    "This source file has changed. It no longer matches the version of the file
    used to build the application being debugged"

    I've gone into the Tools/Options and went to the Debugging/Edit and Continue
    and tried turning it off (I originally turned it on), shut down the project
    and restarted...but I'm still getting the message intermittently.

    Is there a way to stop this from happening?



    Thanks

    Randy
    Randy, Jun 1, 2007
    #1
    1. Advertising

  2. There are a couple of times when this happens. The first is if you are using
    ..NET test files (Team Tester or Team Suite). In these cases, rebuild works
    fine.

    The other is if one of the libraries was compiled in release but still has a
    PDB file that matches an old version. If so, kill the PDB files before you
    run again.

    It is also theoretically possible that you have the temporary ASP.NET files
    out of sync. If this is the case, shut down Visual Studio. Delete the
    temporary ASP.NET files (%windir%\Microsoft
    ..NET\{FrameworkVersion}\Temporary ASP.NET files).

    Are you on Vista by any chance? If so, all bets are off. Visual Studio sucks
    hogs on Vista. :)

    --
    Gregory A. Beamer
    MVP; MCP: +I, SE, SD, DBA
    http://gregorybeamer.spaces.live.com
    Co-author: Microsoft Expression Web Bible (upcoming)

    ************************************************
    Think outside the box!
    ************************************************
    "Randy" <> wrote in message
    news:...
    > I'm using VS 2003. I have a c# ASP project. Lately, when I've been running
    > the project in the IDE, I get a dialog which says...
    >
    > "This source file has changed. It no longer matches the version of the
    > file used to build the application being debugged"
    >
    > I've gone into the Tools/Options and went to the Debugging/Edit and
    > Continue and tried turning it off (I originally turned it on), shut down
    > the project and restarted...but I'm still getting the message
    > intermittently.
    >
    > Is there a way to stop this from happening?
    >
    >
    >
    > Thanks
    >
    > Randy
    >
    >
    Cowboy \(Gregory A. Beamer\), Jun 1, 2007
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    1
    Views:
    672
    Rosanne
    Oct 11, 2005
  2. Rob Baxter
    Replies:
    3
    Views:
    535
    Oscar kind
    Jul 28, 2004
  3. sanborne
    Replies:
    5
    Views:
    1,991
  4. Amarpal
    Replies:
    2
    Views:
    843
    harsha
    Dec 31, 2011
  5. mxbrunet
    Replies:
    1
    Views:
    203
Loading...

Share This Page