Camping: Error when running script

Discussion in 'Ruby' started by Kristen, Mar 11, 2007.

  1. Kristen

    Kristen Guest

    Hello,

    I just installed the Camping micro-framework with the command:

    gem install camping-omnibus --source http://code.whytheluckystiff.net


    Then I created a file which contained the following:

    Camping.goes :Nuts

    and called it nuts.rb


    Then I executed the the file in the terminal, but it gives me the error:

    system:~/Documents/camping kristen$ camping nuts.rb
    /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.1/lib/active_support/dependencies.rb:477:in
    `const_missing': uninitialized constant
    Mongrel::Camping::CampingHandler::Sync (NameError)
    from
    /usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.14/lib/mongrel/camping.rb:42:in
    `initialize'
    from
    /usr/local/lib/ruby/gems/1.8/gems/camping-1.5.180/bin/camping:199:in
    `cloaker_'
    from
    /usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.14/lib/mongrel/configurator.rb:138:in
    `listener'
    from
    /usr/local/lib/ruby/gems/1.8/gems/camping-1.5.180/bin/camping:191:in
    `cloaker_'
    from
    /usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.14/lib/mongrel/configurator.rb:51:in
    `initialize'
    from
    /usr/local/lib/ruby/gems/1.8/gems/camping-1.5.180/bin/camping:190
    from /usr/local/bin/camping:18

    Im not sure what this is or how to fix it. Does anyone have any ideas?

    Kristen
     
    Kristen, Mar 11, 2007
    #1
    1. Advertisements

  2. Kristen

    eden li Guest

    Hrm.. that's strange. Have you tried upgrading mongrel? Maybe
    that'll fix it?

    $ gem install mongrel --include-dependencies
     
    eden li, Mar 11, 2007
    #2
    1. Advertisements

  3. Kristen

    Al Cholic Guest

    Thanks. That worked!

    Kristen
     
    Al Cholic, Mar 11, 2007
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.