Custom Minecraft launcher client error; I think regarding java


Joined
Sep 6, 2022
Messages
1
Reaction score
0
Hey guys, I hope everyone is doing well.

I play a lot of Minecraft specifically related to a server called Cosmic PvP. I usually don't play video games although this one I am very fond of but am having troubles running the servers custom launcher. I have tried sending in my logs with a support ticket to server staff but have yet to have any help fixing the problem :(. I am hoping here can be the place and appreciate any help or discussion!

So far I have tried the following general fixes the server has posted.

"
Fix 1
Make sure that you have downloaded regular 1.8/1.12 minecraft onto your computer, Most often this should solve the issue.

If that doesn't work try:

Fix 2
Open launcher-settings text document and locate the Line that says RamMB
Change the value from 1024 to one of the following:
1 Gigabytes is 1024 - 2 Gigabytes is 2048 - 3 Gigabytes is 3072 In most cases changing it to 2048 will fix the issue.

Still not working?:

Fix 3
Make sure that you have the correct version of Java installed which you can get from Here "(https://wiki.cosmicpvp.com/wiki/CosmicClient#Common_Issues_People_Run_Into).



This is the log error I have received, I have been told it is a simple java error, nothing looks wrong, and my launcher should work :p



detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------

-- Head --
Stacktrace:
at bx.d(bx.java:7)
at gF.<init>(gF.java:38)
at hy.b(hy.java:37)
at gZ.<init>(gZ.java:1)
at hy.<init>(hy.java:40)
at mG.<init>(mG.java:154)
at net.minecraft.client.ei.l(ei.java:476)

-- Initialization --
Details:
Stacktrace:
at net.minecraft.client.ei.h(ei.java:609)
at net.minecraft.client.main.Main.main(Main.java:80)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at net.minecraft.client.main.Main.main(Main.java:42)

-- System Details --
Details:
Minecraft Version: 1.8.9
Operating System: Windows 10 (amd64) version 10.0
CPU: <unknown>
Java Version: 1.8.0_301, Oracle Corporation
Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
Memory: 1262607712 bytes (1204 MB) / 1561329664 bytes (1489 MB) up to 3176660992 bytes (3029 MB)
JVM Flags: 6 total; -Xms1536M -Xmx3072M -XX:MaxDirectMemorySize=3072M -XX:+DisableAttachMechanism -Xshare:eek:ff -Xmn128M
IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
Launched Version: 1.8
LWJGL: 2.9.4
OpenGL: NVIDIA GeForce GTX 1060 3GB/PCIe/SSE2 GL version 4.6.0 NVIDIA 512.59, NVIDIA Corporation
GL Caps: Using GL 1.3 multitexturing.
Using GL 1.3 texture combiners.
Using framebuffer objects because OpenGL 3.0 is supported and separate blending is supported.
Shaders are available because OpenGL 2.1 is supported.
VBOs are available because OpenGL 1.5 is supported.

Using VBOs: Yes
Is Modded: Very likely; Jar signature invalidated
Type: Client (map_client.txt)
Resource Packs:
Current Language: English (US)
Profiler Position: N/A (disabled)
CPU: <unknown>
OptiFine Version: OptiFine_1.8.9_HD_U_H8
Render Distance Chunks: 28
Mipmaps: 4
Anisotropic Filtering: 1
Antialiasing: 0
Multitexture: false
Shaders: null
OpenGlVersion: 4.6.0 NVIDIA 512.59
OpenGlRenderer: NVIDIA GeForce GTX 1060 3GB/PCIe/SSE2
OpenGlVendor: NVIDIA Corporation
CpuCount: 12
#@[email protected]# Game crashed! Crash report saved to: #@[email protected]# C:\Users\Vasil Call\AppData\Roaming\.minecraft\.\crash-reports\crash-2022-09-05_22.49.28-client.txt
[22:49:29] [Client Shutdown Thread/INFO]: Stopping server
AL lib: (EE) alc_cleanup: 1 device not closed
[Cosmic] Starting update sequence
[Cosmic] OS.name: WINDOWS
[Cosmic] OS.arch: x86_64
[Cosmic] Starting update process for 1.8
[Cosmic] Checking for updates...
[Cosmic] C:\Users\Vasil Call\Documents\CosmicClient-x64\1.8\CosmicClient-1.8.9.jar
Using JRE: C:\Users\Vasil Call\Documents\CosmicClient-x64\jre_64
[Cosmic] Current version CosmicClient-1.8.9.jar is: 8a89300fa36f5b4b3280b53cd9f2cc3e
[Cosmic] Updated version http://cdn.cosmicclient.com/download/CosmicClient-1.0-SNAPSHOT.jar is: 8a89300fa36f5b4b3280b53cd9f2cc3e
[Cosmic] Up to date!
[Cosmic] Starting update process for 1.12.2
[Cosmic] Checking for updates...
[Cosmic] C:\Users\Vasil Call\Documents\CosmicClient-x64\1.12.2\SkyClient-1.0-SNAPSHOT.jar
Using JRE: C:\Users\Vasil Call\Documents\CosmicClient-x64\jre_64
[Cosmic] Current version SkyClient-1.0-SNAPSHOT.jar is: 11dfcd8ef3a9cfec22432d2a085a02de
[Cosmic] Updated version http://cdn.cosmicclient.com/download/SkyClient-1.0-SNAPSHOT.jar is: 11dfcd8ef3a9cfec22432d2a085a02de
[Cosmic] Up to date!
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads


Top