customerrors tag doesnt works

T

Tahir

Hi,

i am delevoping an ASP.NET website which worked well on my old web host and
now working on localhost but now it doesnt works on my new host. i have new
registered and ftp the files that work on previous host. now it shows the
classic runtime eror page which explains how to enable customerrors tag.
the problem is my website is configured to show my custom error page. what
is the problem? why the customerors tag doesnt work?


my Web.Config file is:

<?xml version="1.0"?>
<configuration>
<appSettings>
</appSettings>
<connectionStrings>
<add name=..../>
</connectionStrings>
<system.web>
<authentication mode="Forms">
<forms name..../>
</authentication>
<authorization>
<allow users="*"/>
</authorization>
<customErrors mode="RemoteOnly" defaultRedirect="YapimAsamasinda.htm">
<error statusCode="403" redirect="YapimAsamasinda.htm"/>
<error statusCode="404" redirect="YapimAsamasinda.htm"/>
</customErrors>
<compilation debug="true">
<assemblies>
<add assembly="System.Design, Version=2.0.0.0, Culture=neutral,
PublicKeyToken=B03F5F7F11D50A3A"/>
</assemblies>
</compilation>
</system.web>
</configuration>



the site is shown as:

Server Error in '/' Application.
Runtime Error
Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable
on remote machines, please create a <customErrors> tag within a "web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>


Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the application's
<customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>
 
G

Göran Andersson

Tahir said:
Hi,

i am delevoping an ASP.NET website which worked well on my old web host
and now working on localhost but now it doesnt works on my new host. i
have new registered and ftp the files that work on previous host. now
it shows the classic runtime eror page which explains how to enable
customerrors tag. the problem is my website is configured to show my
custom error page. what is the problem? why the customerors tag doesnt
work?


my Web.Config file is:

<?xml version="1.0"?>
<configuration>
<appSettings>
</appSettings>
<connectionStrings>
<add name=..../>
</connectionStrings>
<system.web>
<authentication mode="Forms">
<forms name..../>
</authentication>
<authorization>
<allow users="*"/>
</authorization>
<customErrors mode="RemoteOnly" defaultRedirect="YapimAsamasinda.htm">

Try with mode="Off" so that you see the actual error message. That may
help to find out what the main problem is.


Use an url relative to the root instead of an url relative to the
current folder:

~/YapimAsamasinda.htm

That way you get redirected to the same page even if the error occurs in
a page in a subfolder.
 
T

Tahir

ok, i found that the error was my site isnot configured as .NET 2.0
application :mad:
thanks for replies.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Forum statistics

Threads
473,763
Messages
2,569,560
Members
45,035
Latest member
HoTaKeDai

Latest Threads

Top