Global.asax not firing

Discussion in 'ASP .Net' started by furiousmojo, Jun 20, 2006.

  1. furiousmojo

    box464

    Joined:
    Aug 22, 2008
    Messages:
    1
    Likes Received:
    0
    Thank you for this thread. I had been trying to figure this one out for several hours now.

    Here is my scenario:

    An existing ASP.Net site has been around for awhile (since 2006). It did not use a global.asax file.

    I added a global.asax file to the site.

    It worked great on my local box.

    I moved it up to our development box. The events in global.asax were not getting fired.

    After a few hours of frustration, I hit Google and find this thread.

    I deleted PreCompiledApp.config (which had a timestamp of 2006!). But this didn't immediately solve the issue.

    I then opened Web.Config, made a space, and saved it (I call this App Slapping).

    Ta Da! Everything is working. I followed these steps on our development and staging boxes and it worked both times.

    Searching Google for "ProCompiledApp.config" got me this, which was helpful in explaining the issue to co-workers.

    http://kbalertz.com/937095/raise-events-application.aspx

    Thanks Again,

    Jeff
     
    box464, Aug 22, 2008
    #21
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.