Moved to new Plesk Server. PHP stopped working completely.


Joined
Jun 8, 2022
Messages
4
Reaction score
1
Any help appreciated. Migrated to a new server and each website page is either blank where PHP files are meant to be called in or they are showing PHP coding as if it was HTML. I can't find the cause. No files are missing from the migration. Everything looks correct. Anyone had this happen and knows what it might be? The only different setting I can find is the version of PHP being used. Snapshots of old and new server configuration attached. I've tried every variation in the dropdown menus to see if that made a difference but nothing.


oldphpsettings.png


newphpsettings.png
 
Ad

Advertisements

Ian

Administrator
Joined
Nov 13, 2005
Messages
75
Reaction score
19
You've gone from using PHP 5.3.3 (very old) to PHP 7.4 - I wonder if your code is simply not compatible with PHP7.4 but errors are being suppressed. Can you temporarily enable/install PHP 5.3 (if possible) in Plesk on the new server, to see if your code runs?
 
Ad

Advertisements

Joined
Jun 8, 2022
Messages
4
Reaction score
1
Thanks Ian. I got that suggestion from someone else just a few hours ago and have been going through my sites changing to the installed PHP5 version. Looks like everything is working now. I didn't realise so much was different such as mysql connect being completely removed. That's in practically every page of my coding. No wonder the sites wen tdown.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top