Paramiko Threading Error


M

mud

Hi All,

Does anybody know what the following error means with paramiko, and
how to fix it.

I don't know what is causing it and why. I have updated paramiko to
version 1.7.7.1 (George) but still has the same issue.

Also I can not reproduce the problem and therefore debugging is harder
for me.


Exception in thread Thread-4 (most likely raised during interpreter
shutdown):
Traceback (most recent call last):
File "/usr/lib64/python2.6/threading.py", line 532, in
__bootstrap_inner
File "/usr/lib/python2.6/site-packages/paramiko/transport.py", line
1574, in run
<type 'exceptions.AttributeError'>: 'NoneType' object has no attribute
'error'
 
Ad

Advertisements

M

mud

Il Tue, 7 Jun 2011 19:25:43 -0700 (PDT), mud ha scritto:














if I remember rightly, I got that kind of error when I tried to use a
transport without setting up the paramiko's logging subsystem.
Try to put in head of your code the line:

pk.util.log_to_file("log file name.txt")

D.

Hi David,

I have tried that already because I though that the logging might
indicate what the issue is.

What I have found is that paramiko seems to be using threading which
is not %100 thread safe in python. So it seems that when the script
exits, the interpreter is failing to close the threads running and
therefor giving the exception.

What I have tried now is to go through all the connections objects
that I have opened, close them first if they are open before the
script exists. It appears to be working so far but only time will
tell.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top