Problem installing ExtUtils::Command from CPAN

Discussion in 'Perl Misc' started by Vincent Foley, Oct 31, 2006.

  1. Hello clpm,

    I am trying to install the ExtUtils::Command module on my Ubuntu (Edgy
    Eft) machine, but I seem to fall into a practical joke of some sort,
    because I am told during the installation that CPAN.pm cannot install
    ExtUtils::Command because ExtUtils/Command.pm isn't found in my @INC.
    Could anyone help me out with this problem? The version of Perl used
    on Edgy Eft is 5.8.8. For more information, I have included the entire
    output of what happens when I try to do the installation.

    Thanks,

    Vincent.

    cpan> install ExtUtils::Command
    CPAN: Storable loaded ok
    Going to read /home/vince/.cpan/Metadata
    Database was generated on Thu, 26 Oct 2006 05:23:55 GMT
    Running install for module ExtUtils::Command
    Running make for R/RK/RKOBES/ExtUtils-Command-1.12.tar.gz
    CPAN: Digest::MD5 loaded ok
    CPAN: Compress::Zlib loaded ok
    Checksum for
    /home/vince/.cpan/sources/authors/id/R/RK/RKOBES/ExtUtils-Command-1.12.tar.gz
    ok
    Scanning cache /home/vince/.cpan/build for sizes
    ExtUtils-Command-1.12/
    ExtUtils-Command-1.12/t/
    ExtUtils-Command-1.12/t/shell_exit.t
    ExtUtils-Command-1.12/t/shell_command.t
    ExtUtils-Command-1.12/t/eu_command.t
    ExtUtils-Command-1.12/t/lib/
    ExtUtils-Command-1.12/t/lib/TieOut.pm
    ExtUtils-Command-1.12/META.yml
    ExtUtils-Command-1.12/lib/
    ExtUtils-Command-1.12/lib/ExtUtils/
    ExtUtils-Command-1.12/lib/ExtUtils/Command.pm
    ExtUtils-Command-1.12/lib/Shell/
    ExtUtils-Command-1.12/lib/Shell/Command.pm
    ExtUtils-Command-1.12/Changes
    ExtUtils-Command-1.12/MANIFEST
    ExtUtils-Command-1.12/Build.PL
    ExtUtils-Command-1.12/Makefile.PL
    ExtUtils-Command-1.12/README
    Removing previously used /home/vince/.cpan/build/ExtUtils-Command-1.12

    CPAN.pm: Going to build R/RK/RKOBES/ExtUtils-Command-1.12.tar.gz

    Argument "6.30_01" isn't numeric in numeric ge (>=) at Makefile.PL line
    22.
    Checking if your kit is complete...
    Looks good
    Writing Makefile for ExtUtils::Command
    Can't locate ExtUtils/Command.pm in @INC (@INC contains:
    /home/vince/perl /home/vince/perl/lib/perl/5.8.7
    /home/vince/perl/share/perl/5.8.7 /etc/perl /usr/local/lib/perl/5.8.8
    /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5
    /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .).
    BEGIN failed--compilation aborted.
    make: *** [blib/lib/ExtUtils/.exists] Error 2
    /usr/bin/make -- NOT OK
    Running make test
    Can't test without successful make
    Running make install
    make had returned bad status, install seems impossible
     
    Vincent Foley, Oct 31, 2006
    #1
    1. Advertisements

  2. Vincent Foley

    Sisyphus Guest

    ..
    ..
    Neat joke, indeed :)

    EU::Command is part of core perl with 5.8.7 and 5.8.8 - so definitely should
    have been part of your perl to begin with. What became of it ?

    Does the module install if you simply download ExtUtils-Command-1.12.tar.gz
    from CPAN, extract to some location, cd to that location, and run:

    perl Makefile.PL
    make test
    make install

    Are you able to install *any* perl modules at all ? (Sometimes the default
    perl installation is not fully functional - and to get a fully functional
    version of perl it is necessary to install the perl "devel" version from the
    OS installation media. But if we're dealing with a perl that you've built
    yourself then this should *not* be the case.)

    EU::Command is pure perl, so if all else fails, you might be able to get
    things working by copying Command.pm to the ExtUtils directory under one of
    the @INC directories. But if you're missing the "devel" installation then
    that probably won't be sufficient in itself.

    Cheers,
    Rob
     
    Sisyphus, Oct 31, 2006
    #2
    1. Advertisements

  3. I just tried installing WWW::Mechanize and IO::prompt and both failed
    because of the absence of ExtUtils/Command.pm in my @INC.

    I have downloaded libperl-dev from apt-get, but this hasn't fixed the
    problem. When I went to ~/.cpan/build/ExtUtils-Command-1.12/ and tried
    the perl Makefile.PL; make test, I got the same error as before.

    Now, I just tried something that I think worked, but I'm not sure: I
    copied ExtUtils/Command.pm into my @INC so that I could perform the
    manual installation of the module and this worked. If I run into more
    problems, I'll let you know.

    Also, I would be interested to know if you guys think I should compile
    Perl5 from scratch instead of using the Ubuntu-provided packages; I
    know the Ruby guys strongly recommend against using the Debian package
    of Ruby because it lacks all sorts of modules that are normally
    installed by default.

    Vincent
     
    Vincent Foley, Oct 31, 2006
    #3
  4. Vincent Foley

    Sisyphus Guest

    ..
    ..
    On my Mandrake box I leave the perl that comes with the OS (in /usr/bin)
    alone - since the OS actually needs it, and I don't want to inadvertently
    jigger something up.

    Instead the perl that *I* use on that box (which I built myself from source)
    is in /usr/local/bin.

    I think it's good general advice to do it that way. It might not be
    *necessary* to do that .... but it's a fairly safe way of going about
    things.

    Cheers,
    Rob
     
    Sisyphus, Oct 31, 2006
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.