Siimple solution to "Access denied" problem with WinXP-apache-perl-cgi

Discussion in 'Perl Misc' started by Binod Pant, Aug 25, 2006.

  1. Binod Pant

    Binod Pant Guest

    I haave setup a webserver using the Netserver application. It is a bundle of
    Apache, MySQL, PHP,Perl all in one.

    I tried to run a CGI script such as this :

    #!D:\Applications\NetServer\bin\stable\perl\
    print "Content-type: text/html\n\n";
    print "<h2>Hello, World!</h2>\n";
    print "<table border=1><tr><td>Hello, World!</td></tr></table></h2>\n";

    I kept getting "Access denied Could not spawn child process" error in Apache
    log.
    I solved this by simply changing the path to perl and replacing it with the
    full path to the perl executable
    i.e.,
    #!D:\Applications\NetServer\bin\stable\perl\bin\perl.exe

    That was it! hope this will help someone who has a similar problem
     
    Binod Pant, Aug 25, 2006
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.