uninitialized constant ActiveSupport::Dependencies::Mutex(NameError)

R

Rajesh B.

Hi all

i have installed rails 2.3.8 in my machine. after the installation when
i create a new project it gives the error "uninitialized constant
ActiveSupport::Dependencies::Mutex (NameError)".

can any one please help i am new to apple mac os x.
my os version is mac 10.6.3


This is the error :

rajeshs-macbook:Desktop rajesh$ ruby --version
ruby 1.8.7 (2009-06-08 patchlevel 173) [universal-darwin10.0]

rajeshs-macbook:Desktop rajesh$ rails --version
Rails 2.3.8

rajeshs-macbook:Desktop rajesh$ rails demo

/Library/Ruby/Gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:55:
uninitialized constant ActiveSupport::Dependencies::Mutex (NameError)
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:49:in
`gem_original_require'
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:49:in `require'
from
/Library/Ruby/Gems/1.8/gems/activesupport-2.3.8/lib/active_support.rb:57
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:49:in
`gem_original_require'
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:49:in `require'
from /Library/Ruby/Gems/1.8/gems/rails-2.3.8/lib/rails_generator.rb:31
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:49:in
`gem_original_require'
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:49:in `require'
from /Library/Ruby/Gems/1.8/gems/rails-2.3.8/bin/rails:15
from /usr/bin/rails:19:in `load'
from /usr/bin/rails:19




Thanks all
Rajesh
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Forum statistics

Threads
473,787
Messages
2,569,630
Members
45,335
Latest member
Tommiesal

Latest Threads

Top