Ruby 1.8.7 from 1.8.6

A

Awijeet Mr.

I have been given a project to understand the ruby and rails so every
time when I try to execute the server via script/server i get following
message.
script/server
=> Booting Mongrel
=> Rails 2.3.8 application starting on http://0.0.0.0:3000
/usr/lib/ruby/gems/1.8/gems/mail-2.2.6.1/lib/mail.rb:19: You need to
install tlsmail if you are using ruby <= 1.8.6 (RuntimeError)
from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in
`require'
from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:521:in
`new_constants_in'
from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:156:in
`require'
from
/usr/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/rails/gem_dependency.rb:215:in
`load'
from /usr/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/initializer.rb:307:in
`load_gems'
from /usr/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/initializer.rb:307:in
`each'
... 10 levels...
from /usr/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/commands/server.rb:84
from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
from script/server:3


if i execute rake gems:install



I get this

rake gems:install
(in /home/Awijeet/Downloads/loc)
DEPRECATION WARNING: Rake tasks in vendor/plugins/delayed_job/tasks,
vendor/plugins/fetcher/tasks, and vendor/plugins/thinking-sphinx/tasks
are deprecated. Use lib/tasks instead. (called from
/usr/lib/ruby/gems/1.8/gems/rails-2.3.8/lib/tasks/rails.rb:10)

Sphinx cannot be found on your system. You may need to configure the
following
settings in your config/sphinx.yml file:
* bin_path
* searchd_binary_name
* indexer_binary_name

For more information, read the documentation:
http://freelancing-god.github.com/ts/en/advanced_config.html
gem install mms2r
ERROR: Error installing mms2r:
ERROR: Failed to build gem native extension.

/usr/bin/ruby extconf.rb
checking for #include <libxml/parser.h>
... no
-----
libxml2 is missing. please visit
http://nokogiri.org/tutorials/installing_nokogiri.html for help with
installing dependencies.
-----
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

Provided configuration options:
--with-opt-dir
--without-opt-dir
--with-opt-include
--without-opt-include=${opt-dir}/include
--with-opt-lib
--without-opt-lib=${opt-dir}/lib
--with-make-prog
--without-make-prog
--srcdir=.
--curdir
--ruby=/usr/bin/ruby
--with-zlib-dir
--without-zlib-dir
--with-zlib-include
--without-zlib-include=${zlib-dir}/include
--with-zlib-lib
--without-zlib-lib=${zlib-dir}/lib
--with-iconv-dir
--without-iconv-dir
--with-iconv-include
--without-iconv-include=${iconv-dir}/include
--with-iconv-lib
--without-iconv-lib=${iconv-dir}/lib
--with-xml2-dir
--without-xml2-dir
--with-xml2-include
--without-xml2-include=${xml2-dir}/include
--with-xml2-lib
--without-xml2-lib=${xml2-dir}/lib
--with-xslt-dir
--without-xslt-dir
--with-xslt-include
--without-xslt-include=${xslt-dir}/include
--with-xslt-lib
--without-xslt-lib=${xslt-dir}/lib


Gem files will remain installed in
/usr/lib/ruby/gems/1.8/gems/nokogiri-1.4.3.1 for inspection.
Results logged to
/usr/lib/ruby/gems/1.8/gems/nokogiri-1.4.3.1/ext/nokogiri/gem_make.out
Building native extensions. This could take a while...
gem install paperclip
ERROR: Error installing paperclip:
activesupport requires Ruby version >= 1.8.7

please help.

Thanks
 
B

Brian Candler

Awijeet said:
please help.

The most appropriate place for questions about or problems with Rails
would be a Rails forum. This mailing list is for discussion of Ruby, the
programming language.
 
M

Marcel Faas

Awijeet Mr. said:
I have been given a project to understand the ruby and rails so every
time when I try to execute the server via script/server i get following
message.
script/server


I would advise you to try the Bitnami Rubystack.
Once installed you have the complete bunch of Ruby, Rubygem and Rails,
including Apache, MySQL and more.

Greetings,

Marcel
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Forum statistics

Threads
473,795
Messages
2,569,644
Members
45,358
Latest member
TreyTritt8

Latest Threads

Top