WCF v4.0.21006 and IIS on Windows7

Discussion in 'ASP .Net Web Services' started by YYZRic, Jan 29, 2010.

  1. YYZRic

    YYZRic Guest

    I didn't have IIS installed on my Windows7 when I installed Visual Studio 2010.
    Then I decided to install IIS, but I'm not able to host a WCF Service.

    I've tried to register WCF:

    1. Start command prompt (cmd) as Administrator.
    2. CD C:\Windows\Microsoft.NET\Framwork\v4.0.21006
    3. serviceModelReg -ia (to install all components)

    and I'm getting:
    [Warning] The HTTP namespace reservation already exists.

    I've also tried:
    netsh http show urlacl
    netsh http delete urlacl url=<url to delete goes here> (i tried a few)

    Any help is greatly appreciated.
     
    YYZRic, Jan 29, 2010
    #1
    1. Advertisements

  2. YYZRic

    YYZRic Guest

    I found a way to install the Framework 4 on IIS.

    1. Open command prompt as Administrator
    2. At the command prompt, type the following, and then press ENTER:
    "%windir%\Microsoft.NET\Framework\v4.0.21006\aspnet_regiis.exe" -i
     
    YYZRic, Jan 29, 2010
    #2
    1. Advertisements

  3. On Jan 30, 7:30 am, YYZRic <> wrote:
    > I found a way to install the Framework 4 on IIS.
    >
    > 1. Open command prompt as Administrator
    > 2. At the command prompt, type the following, and then press ENTER:
    > "%windir%\Microsoft.NET\Framework\v4.0.21006\aspnet_regiis.exe" -i


    Great! It solved.
     
    balarrock (Mon Gyi), Mar 17, 2010
    #3
    1. Advertisements

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
  1. Simon
    Replies:
    0
    Views:
    1,359
    Simon
    Oct 13, 2009
  2. shavirak
    Replies:
    1
    Views:
    936
    Alexey Smirnov
    Nov 12, 2009
  3. Cindy Lee
    Replies:
    1
    Views:
    3,531
    Mr. Arnold
    Mar 19, 2010
  4. News123
    Replies:
    2
    Views:
    3,601
    Tim Golden
    May 6, 2010
  5. Mr. X.

    Security issue on Windows7

    Mr. X., Oct 25, 2010, in forum: ASP .Net
    Replies:
    1
    Views:
    839
    Mr. X.
    Oct 26, 2010
  6. Mahesh Varma
    Replies:
    0
    Views:
    584
    Mahesh Varma
    Feb 11, 2011
  7. Mike Endys
    Replies:
    2
    Views:
    791
    Steven Cheng
    Nov 7, 2008
  8. hisan
    Replies:
    5
    Views:
    674
    gwang
    Mar 3, 2012
Loading...