application pool problem

Discussion in 'ASP .Net' started by =?Utf-8?B?R2xlbg==?=, Apr 21, 2005.

  1. I have a web service project that was fine untill I created a new application
    pool and moved my service to the new pool. Now I can not even open the
    project in VS. Error message says "file path c:\Inetpub\wwwroot\myproject
    does not correspond to the url http://localhost/myproject. The two need to
    map to the same server location. HTTP error 503 service not available."

    Can somebody please explain what the problem is?

    Thanks
     
    =?Utf-8?B?R2xlbg==?=, Apr 21, 2005
    #1
    1. Advertising

  2. You seemed to have broken the virtual directory mappings. Your webservice
    should map to the the directory on your hard disk. it doesn't have anything
    to do with application pools. Using internet manager to reset the path and
    then make sure the application is configured as a virtual directory

    --
    Regards,
    Alvin Bruney - ASP.NET MVP

    [Shameless Author Plug]
    The Microsoft Office Web Components Black Book with .NET
    Now available @ www.lulu.com/owc
    "Glen" <> wrote in message
    news:...
    >I have a web service project that was fine untill I created a new
    >application
    > pool and moved my service to the new pool. Now I can not even open the
    > project in VS. Error message says "file path c:\Inetpub\wwwroot\myproject
    > does not correspond to the url http://localhost/myproject. The two need
    > to
    > map to the same server location. HTTP error 503 service not available."
    >
    > Can somebody please explain what the problem is?
    >
    > Thanks
     
    Alvin Bruney [MVP - ASP.NET], Apr 22, 2005
    #2
    1. Advertising

  3. Hi Glen,

    When you created your web application, VS generated virtual directory and
    mapping of physical path. Since you move project files to other location, the
    mapping doesn’t work any more. You can manually create new virtual directory
    and map physical path to your new pool location.

    HTH

    Elton Wang




    "Glen" wrote:

    > I have a web service project that was fine untill I created a new application
    > pool and moved my service to the new pool. Now I can not even open the
    > project in VS. Error message says "file path c:\Inetpub\wwwroot\myproject
    > does not correspond to the url http://localhost/myproject. The two need to
    > map to the same server location. HTTP error 503 service not available."
    >
    > Can somebody please explain what the problem is?
    >
    > Thanks
     
    =?Utf-8?B?RWx0b24gVw==?=, Apr 22, 2005
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    4
    Views:
    7,343
  2. Replies:
    2
    Views:
    14,315
    dguisinger
    Jul 6, 2006
  3. Aamir Mahmood
    Replies:
    1
    Views:
    1,470
    Peter Bromberg [C# MVP]
    May 28, 2008
  4. cowznofsky
    Replies:
    4
    Views:
    3,504
    cowznofsky
    Feb 23, 2009
  5. Rick Lawson
    Replies:
    8
    Views:
    810
    Graham Dumpleton
    Jul 17, 2009
Loading...

Share This Page