ASP.net validation controls don't are not validated(fired) on the client side.

Discussion in 'ASP .Net' started by mallik, Jul 6, 2005.

  1. mallik

    mallik Guest

    Seems like we have a strange problem.

    Development environment is win 2000 prof, IIS5.0,
    QA environment is Windows 2003 server, IIS 6.0.

    Everything works as expected on Dev. machine, but when deployed on to the QA server...
    The Asp.Net validation controls are not fired/validated on the client side(browser). They're validated only on the serverside (when posted back).

    Is there any known issue with IIS5.0 and IIS6.0 environments?
    Is there any behavioral difference for .NetFramework 1.1 on windows 2000 and Windows 2003 ?

    Seems like few other people had this issue, but I couldn't get any resoultion here.
    http://www.pcreview.co.uk/forums/thread-1272113.php

    http://www.pcreview.co.uk/forums/thread-1269345.php

    Any pointers/help is greatly appreciated.
     
    mallik, Jul 6, 2005
    #1
    1. Advertising

  2. RE: ASP.net validation controls don't are not validated(fired) on the

    Did you copy over the aspnet_client folder with all of the client side
    scripts? You will need to put it into your web servers inetpub/wwwroot
    directory.

    --
    Staff Consultant II
    Enterprise Web Services
    Cardinal Solutions Group

    Future Business Model
    Loan Origination Services
    National City Mortgage


    "mallik" wrote:

    >
    > Seems like we have a strange problem.
    >
    > Development environment is win 2000 prof, IIS5.0,
    > QA environment is Windows 2003 server, IIS 6.0.
    >
    > Everything works as expected on Dev. machine, but when deployed on to the QA server...
    > The Asp.Net validation controls are not fired/validated on the client side(browser). They're validated only on the serverside (when posted back).
    >
    > Is there any known issue with IIS5.0 and IIS6.0 environments?
    > Is there any behavioral difference for .NetFramework 1.1 on windows 2000 and Windows 2003 ?
    >
    > Seems like few other people had this issue, but I couldn't get any resoultion here.
    > http://www.pcreview.co.uk/forums/thread-1272113.php
    >
    > http://www.pcreview.co.uk/forums/thread-1269345.php
    >
    > Any pointers/help is greatly appreciated
     
    =?Utf-8?B?TWljaGFlbCBCYWx0aWM=?=, Jul 6, 2005
    #2
    1. Advertising

  3. mallik

    mallik Guest

    Re: ASP.net validation controls don't are not validated(fired) on the

    Yes, The folder structure "/aspnet_client/*" and files are already present on the QA server. So I didn't need to copy them.

    "Michael Baltic" <> wrote in message news:...
    > Did you copy over the aspnet_client folder with all of the client side
    > scripts? You will need to put it into your web servers inetpub/wwwroot
    > directory.
    >
    > --
    > Staff Consultant II
    > Enterprise Web Services
    > Cardinal Solutions Group
    >
    > Future Business Model
    > Loan Origination Services
    > National City Mortgage
    >
    >
    > "mallik" wrote:
    >
    > >
    > > Seems like we have a strange problem.
    > >
    > > Development environment is win 2000 prof, IIS5.0,
    > > QA environment is Windows 2003 server, IIS 6.0.
    > >
    > > Everything works as expected on Dev. machine, but when deployed on to the QA server...
    > > The Asp.Net validation controls are not fired/validated on the client side(browser). They're validated only on the serverside (when posted back).
    > >
    > > Is there any known issue with IIS5.0 and IIS6.0 environments?
    > > Is there any behavioral difference for .NetFramework 1.1 on windows 2000 and Windows 2003 ?
    > >
    > > Seems like few other people had this issue, but I couldn't get any resoultion here.
    > > http://www.pcreview.co.uk/forums/thread-1272113.php
    > >
    > > http://www.pcreview.co.uk/forums/thread-1269345.php
    > >
    > > Any pointers/help is greatly appreciated
     
    mallik, Jul 6, 2005
    #3
  4. Re: ASP.net validation controls don't are not validated(fired) on

    Hi Malik, I think what Micheal is getting at is, if your application is not
    the default website in iis you either need to copy the aspnet_client folder
    to the root of your application or set up a virtual directory in your
    application that points to the aspnet_client folder. HTH jd

    "mallik" wrote:

    >
    > Yes, The folder structure "/aspnet_client/*" and files are already present on the QA server. So I didn't need to copy them.
    >
    > "Michael Baltic" <> wrote in message news:...
    > > Did you copy over the aspnet_client folder with all of the client side
    > > scripts? You will need to put it into your web servers inetpub/wwwroot
    > > directory.
    > >
    > > --
    > > Staff Consultant II
    > > Enterprise Web Services
    > > Cardinal Solutions Group
    > >
    > > Future Business Model
    > > Loan Origination Services
    > > National City Mortgage
    > >
    > >
    > > "mallik" wrote:
    > >
    > > >
    > > > Seems like we have a strange problem.
    > > >
    > > > Development environment is win 2000 prof, IIS5.0,
    > > > QA environment is Windows 2003 server, IIS 6.0.
    > > >
    > > > Everything works as expected on Dev. machine, but when deployed on to the QA server...
    > > > The Asp.Net validation controls are not fired/validated on the client side(browser). They're validated only on the serverside (when posted back).
    > > >
    > > > Is there any known issue with IIS5.0 and IIS6.0 environments?
    > > > Is there any behavioral difference for .NetFramework 1.1 on windows 2000 and Windows 2003 ?
    > > >
    > > > Seems like few other people had this issue, but I couldn't get any resoultion here.
    > > > http://www.pcreview.co.uk/forums/thread-1272113.php
    > > >
    > > > http://www.pcreview.co.uk/forums/thread-1269345.php
    > > >
    > > > Any pointers/help is greatly appreciated
     
    =?Utf-8?B?bG9uZG9uIGNhbGxpbmc=?=, Jul 7, 2005
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Matt
    Replies:
    14
    Views:
    4,110
    Chad Z. Hower aka Kudzu
    Jan 30, 2004
  2. =?Utf-8?B?dmlkeWE=?=
    Replies:
    1
    Views:
    756
    Kevin Spencer
    Jun 2, 2005
  3. =?Utf-8?B?UGFuYXlvdGlzIEtvdXZhcmFraXM=?=

    2-digit year dates not validated properly during client validation

    =?Utf-8?B?UGFuYXlvdGlzIEtvdXZhcmFraXM=?=, Dec 2, 2005, in forum: ASP .Net
    Replies:
    0
    Views:
    555
    =?Utf-8?B?UGFuYXlvdGlzIEtvdXZhcmFraXM=?=
    Dec 2, 2005
  4. Stuart Whiteford
    Replies:
    2
    Views:
    746
    Stuart Whiteford
    Apr 25, 2006
  5. Boss302
    Replies:
    0
    Views:
    1,056
    Boss302
    Nov 21, 2006
Loading...

Share This Page