copyright symbol in web.config

Discussion in 'ASP .Net' started by =?Utf-8?B?bW9XaGl0ZQ==?=, Mar 7, 2006.

  1. How can I add a copyright symbol to a web.config file? I cannot use the © or
    char(169) statements, I need to pass the string onto another application.

    The following works on Window XP Professional, IIS 5.1, but fails on Windows
    Server 2003, IIS 6.0:

    <?xml version="1.0" encoding="utf-8" ?>
    <configuration>
    <appSettings>
    <add key="CopyrightGDT"
    value="© 2006 Tele Atlas, Rel. 07/2005."></add>
    …

    I suspect the utf-8 encoding is causing the problem, but have not been able
    to change to utf-16 or us-ascii with any success.

    Thanks, Richard
     
    =?Utf-8?B?bW9XaGl0ZQ==?=, Mar 7, 2006
    #1
    1. Advertising

  2. =?Utf-8?B?bW9XaGl0ZQ==?=

    Scott M. Guest

    How about: &copy;



    "moWhite" <> wrote in message
    news:...
    > How can I add a copyright symbol to a web.config file? I cannot use the ©
    > or
    > char(169) statements, I need to pass the string onto another application.
    >
    > The following works on Window XP Professional, IIS 5.1, but fails on
    > Windows
    > Server 2003, IIS 6.0:
    >
    > <?xml version="1.0" encoding="utf-8" ?>
    > <configuration>
    > <appSettings>
    > <add key="CopyrightGDT"
    > value="© 2006 Tele Atlas, Rel. 07/2005."></add>
    > .
    >
    > I suspect the utf-8 encoding is causing the problem, but have not been
    > able
    > to change to utf-16 or us-ascii with any success.
    >
    > Thanks, Richard
    >
     
    Scott M., Mar 7, 2006
    #2
    1. Advertising

  3. Nope. I should have included © in my list with © and char(169). (c) doesn't
    work for my marketing folk either.

    Any "extended" character would probably suffer the same problem; not just
    the copyright symbol.

    Richard

    "Scott M." wrote:

    > How about: ©
    >
    >
    >
    > "moWhite" <> wrote in message
    > news:...
    > > How can I add a copyright symbol to a web.config file? I cannot use the ©
    > > or
    > > char(169) statements, I need to pass the string onto another application.
    > >
    > > The following works on Window XP Professional, IIS 5.1, but fails on
    > > Windows
    > > Server 2003, IIS 6.0:
    > >
    > > <?xml version="1.0" encoding="utf-8" ?>
    > > <configuration>
    > > <appSettings>
    > > <add key="CopyrightGDT"
    > > value="© 2006 Tele Atlas, Rel. 07/2005."></add>
    > > .
    > >
    > > I suspect the utf-8 encoding is causing the problem, but have not been
    > > able
    > > to change to utf-16 or us-ascii with any success.
    > >
    > > Thanks, Richard
    > >

    >
    >
    >
     
    =?Utf-8?B?bW9XaGl0ZQ==?=, Mar 7, 2006
    #3
  4. =?Utf-8?B?bW9XaGl0ZQ==?=

    Stephen Ahn Guest

    How about

    value="© 2006 Tele Atlas, Rel. 07/2005."

    OR

    value="© 2006 Tele Atlas, Rel. 07/2005."

    HTH,
    Stephen


    "moWhite" <> wrote in message
    news:...
    > How can I add a copyright symbol to a web.config file? I cannot use the ©
    > or
    > char(169) statements, I need to pass the string onto another application.
    >
    > The following works on Window XP Professional, IIS 5.1, but fails on
    > Windows
    > Server 2003, IIS 6.0:
    >
    > <?xml version="1.0" encoding="utf-8" ?>
    > <configuration>
    > <appSettings>
    > <add key="CopyrightGDT"
    > value="© 2006 Tele Atlas, Rel. 07/2005."></add>
    > .
    >
    > I suspect the utf-8 encoding is causing the problem, but have not been
    > able
    > to change to utf-16 or us-ascii with any success.
    >
    > Thanks, Richard
    >
     
    Stephen Ahn, Mar 8, 2006
    #4
  5. =?Utf-8?B?bW9XaGl0ZQ==?=

    Joerg Jooss Guest

    Thus wrote moWhite,

    > How can I add a copyright symbol to a web.config file? I cannot use
    > the © or char(169) statements, I need to pass the string onto another
    > application.
    >
    > The following works on Window XP Professional, IIS 5.1, but fails on
    > Windows Server 2003, IIS 6.0:
    >
    > <?xml version="1.0" encoding="utf-8" ?>
    > <configuration>
    > <appSettings>
    > <add key="CopyrightGDT"
    > value="© 2006 Tele Atlas, Rel. 07/2005."></add>
    > …
    > I suspect the utf-8 encoding is causing the problem, but have not been
    > able to change to utf-16 or us-ascii with any success.


    © is a Unicode character, so UTF-8 cannot be the problem. Do you really save
    the web.config as UTF-8?

    Cheers,
    --
    Joerg Jooss
     
    Joerg Jooss, Mar 8, 2006
    #5
  6. Thanks for the response. I tried © © and get the same web config error. I'm
    assuming that à©© would give the same result.

    Has anyone been able to get any special character in a web.config with
    encoding set to utf-8?

    Richard

    "Stephen Ahn" wrote:

    > How about
    >
    > value="© 2006 Tele Atlas, Rel. 07/2005."
    >
    > OR
    >
    > value="© 2006 Tele Atlas, Rel. 07/2005."
    >
    > HTH,
    > Stephen
    >
    >
    > "moWhite" <> wrote in message
    > news:...
    > > How can I add a copyright symbol to a web.config file? I cannot use the ©
    > > or
    > > char(169) statements, I need to pass the string onto another application.
    > >
    > > The following works on Window XP Professional, IIS 5.1, but fails on
    > > Windows
    > > Server 2003, IIS 6.0:
    > >
    > > <?xml version="1.0" encoding="utf-8" ?>
    > > <configuration>
    > > <appSettings>
    > > <add key="CopyrightGDT"
    > > value="© 2006 Tele Atlas, Rel. 07/2005."></add>
    > > .
    > >
    > > I suspect the utf-8 encoding is causing the problem, but have not been
    > > able
    > > to change to utf-16 or us-ascii with any success.
    > >
    > > Thanks, Richard
    > >

    >
    >
    >
     
    =?Utf-8?B?bW9XaGl0ZQ==?=, Mar 8, 2006
    #6
  7. I'm not sure what you mean by "save the web.config as UTF-8". I'm setting
    the encoding attribute to utf-8 in the xml declaration, but I use either
    notepad or VS 2003 IDE to edit and save the actual file. I would assume that
    its a dos or windows text file. The copyright symbol © shows up fine in the
    actual file.

    Richard

    "Joerg Jooss" wrote:

    > Thus wrote moWhite,
    >
    > > How can I add a copyright symbol to a web.config file? I cannot use
    > > the © or char(169) statements, I need to pass the string onto another
    > > application.
    > >
    > > The following works on Window XP Professional, IIS 5.1, but fails on
    > > Windows Server 2003, IIS 6.0:
    > >
    > > <?xml version="1.0" encoding="utf-8" ?>
    > > <configuration>
    > > <appSettings>
    > > <add key="CopyrightGDT"
    > > value="© 2006 Tele Atlas, Rel. 07/2005."></add>
    > > …
    > > I suspect the utf-8 encoding is causing the problem, but have not been
    > > able to change to utf-16 or us-ascii with any success.

    >
    > © is a Unicode character, so UTF-8 cannot be the problem. Do you really save
    > the web.config as UTF-8?
    >
    > Cheers,
    > --
    > Joerg Jooss
    >
    >
    >
    >
     
    =?Utf-8?B?bW9XaGl0ZQ==?=, Mar 8, 2006
    #7
  8. =?Utf-8?B?bW9XaGl0ZQ==?=

    Joerg Jooss Guest

    Thus wrote moWhite,

    > I'm not sure what you mean by "save the web.config as UTF-8". I'm
    > setting the encoding attribute to utf-8 in the xml declaration, but I
    > use either notepad or VS 2003 IDE to edit and save the actual file. I
    > would assume that its a dos or windows text file. The copyright
    > symbol © shows up fine in the actual file.


    Simply setting an XML declaration with encoding attribute doesn't mean the
    file actual uses that encoding. In Notepad, you can select the encoding in
    the Save As dialog. In VS2005, you can select the encoding under File->Advanced
    Save Options.

    Cheers,
    --
    Joerg Jooss
     
    Joerg Jooss, Mar 8, 2006
    #8
  9. You are exactly correct. I use a file compare program to compare my web
    config files on various servers and keep them in sync. It changes the
    encoding to ANSI. I've made the correction and am no longer failing on the
    copyright symbol. This has been a problem for months with zero solution.

    Thanks, Richard


    "Joerg Jooss" wrote:

    > Thus wrote moWhite,
    >
    > > I'm not sure what you mean by "save the web.config as UTF-8". I'm
    > > setting the encoding attribute to utf-8 in the xml declaration, but I
    > > use either notepad or VS 2003 IDE to edit and save the actual file. I
    > > would assume that its a dos or windows text file. The copyright
    > > symbol © shows up fine in the actual file.

    >
    > Simply setting an XML declaration with encoding attribute doesn't mean the
    > file actual uses that encoding. In Notepad, you can select the encoding in
    > the Save As dialog. In VS2005, you can select the encoding under File->Advanced
    > Save Options.
    >
    > Cheers,
    > --
    > Joerg Jooss
    >
    >
    >
    >
     
    =?Utf-8?B?bW9XaGl0ZQ==?=, Mar 8, 2006
    #9
  10. =?Utf-8?B?bW9XaGl0ZQ==?=

    Blue Streak Guest

    Would using (c) as opposed to © be an option?

    ....Just a thought.
     
    Blue Streak, Mar 8, 2006
    #10
  11. =?Utf-8?B?bW9XaGl0ZQ==?=

    ankyeez

    Joined:
    Aug 22, 2012
    Messages:
    1
    Solved my woes by changing the encoding to <?xml version="1.0" encoding="iso-8859-1"?> to get the character to display correctly.
     
    ankyeez, Aug 22, 2012
    #11
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. baumann@pan
    Replies:
    1
    Views:
    746
    Richard Bos
    Apr 15, 2005
  2. CSharpner
    Replies:
    0
    Views:
    1,044
    CSharpner
    Apr 9, 2007
  3. Robert Dailey

    Character encoding & the copyright symbol

    Robert Dailey, Aug 6, 2009, in forum: Python
    Replies:
    11
    Views:
    1,690
    Dave Angel
    Aug 6, 2009
  4. Song Ma
    Replies:
    2
    Views:
    233
    Charles Oliver Nutter
    Jul 20, 2008
  5. Replies:
    6
    Views:
    1,798
Loading...

Share This Page