Default runtime error page regardless of customerrors setting

Discussion in 'ASP .Net' started by kristan.mcdonald@googlemail.com, Jun 9, 2006.

  1. Guest

    Probably a simple one, but I've found nothing in groups or google so
    here goes;
    trying to deploy a simple .net asp app to our web server, which has
    been hardended as it's public facing. It's only ever run classic asp
    apps before. I've tried to upload a basic app with nothing but an empty
    web form, and I get the default "Runtime error, The custom error
    settings prevent you blah"

    I've tried setting customErrors but I get the same page, I've tried
    aspnet_regiis -i to reinstall, I've tried doing a -ua then an -i to
    remove and install. I'm guessing it's something to do with whatever
    security settings were applied to the box, but I've even tried giving
    everyone full control to the folder and still nothing!

    Please has anyone got any ideas?

    ta
     
    , Jun 9, 2006
    #1
    1. Advertising

  2. If this is IIS 6.0, have you "Allowed" the webservice extension for ASP.NET?
    They all come locked down by default, except for plain old HTML.
    Peter

    --
    Co-founder, Eggheadcafe.com developer portal:
    http://www.eggheadcafe.com
    UnBlog:
    http://petesbloggerama.blogspot.com




    "" wrote:

    > Probably a simple one, but I've found nothing in groups or google so
    > here goes;
    > trying to deploy a simple .net asp app to our web server, which has
    > been hardended as it's public facing. It's only ever run classic asp
    > apps before. I've tried to upload a basic app with nothing but an empty
    > web form, and I get the default "Runtime error, The custom error
    > settings prevent you blah"
    >
    > I've tried setting customErrors but I get the same page, I've tried
    > aspnet_regiis -i to reinstall, I've tried doing a -ua then an -i to
    > remove and install. I'm guessing it's something to do with whatever
    > security settings were applied to the box, but I've even tried giving
    > everyone full control to the folder and still nothing!
    >
    > Please has anyone got any ideas?
    >
    > ta
    >
    >
     
    =?Utf-8?B?UGV0ZXIgQnJvbWJlcmcgW0MjIE1WUF0=?=, Jun 9, 2006
    #2
    1. Advertising

  3. Guest

    Yeah, but thanks for reminding me to check though - "ASP.NET v1.1.4322
    Allowed". Any other ideas?

    Peter wrote:
    > If this is IIS 6.0, have you "Allowed" the webservice extension for ASP.NET?
    > They all come locked down by default, except for plain old HTML.
    > Peter
    >
    > --
    > Co-founder, Eggheadcafe.com developer portal:
    > http://www.eggheadcafe.com
    > UnBlog:
    > http://petesbloggerama.blogspot.com
    >
    >
    >
    >
    > "" wrote:
    >
    > > Probably a simple one, but I've found nothing in groups or google so
    > > here goes;
    > > trying to deploy a simple .net asp app to our web server, which has
    > > been hardended as it's public facing. It's only ever run classic asp
    > > apps before. I've tried to upload a basic app with nothing but an empty
    > > web form, and I get the default "Runtime error, The custom error
    > > settings prevent you blah"
    > >
    > > I've tried setting customErrors but I get the same page, I've tried
    > > aspnet_regiis -i to reinstall, I've tried doing a -ua then an -i to
    > > remove and install. I'm guessing it's something to do with whatever
    > > security settings were applied to the box, but I've even tried giving
    > > everyone full control to the folder and still nothing!
    > >
    > > Please has anyone got any ideas?
    > >
    > > ta
    > >
    > >
     
    , Jun 9, 2006
    #3
  4. Guest

    Just to thicken the plot slightly, if I just copy a default app up I
    get told
    "Server cannot access application directory 'E:\site\atest\'. The
    directory does not exist or is not accessible because of security
    settings. "

    This is true, and interestingly I get the footer giving me the
    information about the framework and asp.net versions. If I grant
    permissions to the relevant accounts, I get the default runtime error
    page, but without the footer. It's like it can't find some part of
    asp.net and it giving up.

    wrote:
    > Yeah, but thanks for reminding me to check though - "ASP.NET v1.1.4322
    > Allowed". Any other ideas?
    >
    > Peter wrote:
    > > If this is IIS 6.0, have you "Allowed" the webservice extension for ASP.NET?
    > > They all come locked down by default, except for plain old HTML.
    > > Peter
    > >
    > > --
    > > Co-founder, Eggheadcafe.com developer portal:
    > > http://www.eggheadcafe.com
    > > UnBlog:
    > > http://petesbloggerama.blogspot.com
    > >
    > >
    > >
    > >
    > > "" wrote:
    > >
    > > > Probably a simple one, but I've found nothing in groups or google so
    > > > here goes;
    > > > trying to deploy a simple .net asp app to our web server, which has
    > > > been hardended as it's public facing. It's only ever run classic asp
    > > > apps before. I've tried to upload a basic app with nothing but an empty
    > > > web form, and I get the default "Runtime error, The custom error
    > > > settings prevent you blah"
    > > >
    > > > I've tried setting customErrors but I get the same page, I've tried
    > > > aspnet_regiis -i to reinstall, I've tried doing a -ua then an -i to
    > > > remove and install. I'm guessing it's something to do with whatever
    > > > security settings were applied to the box, but I've even tried giving
    > > > everyone full control to the folder and still nothing!
    > > >
    > > > Please has anyone got any ideas?
    > > >
    > > > ta
    > > >
    > > >
     
    , Jun 9, 2006
    #4
  5. Guest

    horrah, got it working!

    In case anyone else has problems with this, I edited the machine.config
    to set customerrors to off, go the actual error (which was due to me
    being stupid, as I didn't grant asp.net permissions to the folder of
    the website, only the app folder which was underneath) and now it
    works. Only taken me 5 hours!!

    wrote:
    > Just to thicken the plot slightly, if I just copy a default app up I
    > get told
    > "Server cannot access application directory 'E:\site\atest\'. The
    > directory does not exist or is not accessible because of security
    > settings. "
    >
    > This is true, and interestingly I get the footer giving me the
    > information about the framework and asp.net versions. If I grant
    > permissions to the relevant accounts, I get the default runtime error
    > page, but without the footer. It's like it can't find some part of
    > asp.net and it giving up.
    >
    > wrote:
    > > Yeah, but thanks for reminding me to check though - "ASP.NET v1.1.4322
    > > Allowed". Any other ideas?
    > >
    > > Peter wrote:
    > > > If this is IIS 6.0, have you "Allowed" the webservice extension for ASP.NET?
    > > > They all come locked down by default, except for plain old HTML.
    > > > Peter
    > > >
    > > > --
    > > > Co-founder, Eggheadcafe.com developer portal:
    > > > http://www.eggheadcafe.com
    > > > UnBlog:
    > > > http://petesbloggerama.blogspot.com
    > > >
    > > >
    > > >
    > > >
    > > > "" wrote:
    > > >
    > > > > Probably a simple one, but I've found nothing in groups or google so
    > > > > here goes;
    > > > > trying to deploy a simple .net asp app to our web server, which has
    > > > > been hardended as it's public facing. It's only ever run classic asp
    > > > > apps before. I've tried to upload a basic app with nothing but an empty
    > > > > web form, and I get the default "Runtime error, The custom error
    > > > > settings prevent you blah"
    > > > >
    > > > > I've tried setting customErrors but I get the same page, I've tried
    > > > > aspnet_regiis -i to reinstall, I've tried doing a -ua then an -i to
    > > > > remove and install. I'm guessing it's something to do with whatever
    > > > > security settings were applied to the box, but I've even tried giving
    > > > > everyone full control to the folder and still nothing!
    > > > >
    > > > > Please has anyone got any ideas?
    > > > >
    > > > > ta
    > > > >
    > > > >
     
    , Jun 9, 2006
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Les Caudle
    Replies:
    0
    Views:
    509
    Les Caudle
    Oct 31, 2006
  2. Justin Dutoit

    Runtime error when customErrors are Off

    Justin Dutoit, Jun 11, 2007, in forum: ASP .Net
    Replies:
    0
    Views:
    444
    Justin Dutoit
    Jun 11, 2007
  3. Bob Johnson

    URL Unchanged Regardless of Page Viewed

    Bob Johnson, Jun 26, 2007, in forum: ASP .Net
    Replies:
    1
    Views:
    567
    Cowboy \(Gregory A. Beamer\)
    Jun 26, 2007
  4. CSINVA
    Replies:
    1
    Views:
    334
    Lloyd Sheen
    Nov 8, 2007
  5. Timur Tabi
    Replies:
    1
    Views:
    129
    Timur Tabi
    May 14, 2004
Loading...

Share This Page