Extremely Slow Performance

Discussion in 'ASP .Net' started by Rabbit, Feb 6, 2006.

  1. Rabbit

    Rabbit Guest

    Dear All,

    I am development my web application on my PC, while its testing under the
    local area network environment (http://192.168.0.2/webapp/default.aspx), the
    speed and response are all very fast.

    The slow performance issue happens while i access it via WAN method
    (http://rabbit.dyndns.org/webapp/default.aspx), does anyone got any idea why
    will this happen?

    I did ask my friend to access my web application over the internet, and the
    speed testing results are all very fast, so I wonder why this scenario only
    happening when I use same PC to access my web application thru WAN?

    Thanks in advance
    Rabbit
    Rabbit, Feb 6, 2006
    #1
    1. Advertising

  2. you need to figure out what the connection speed is from that point before
    doing anything else. See if you can isolate the problem to eliminate or
    blame the network as the source of the issue.

    --
    Regards,
    Alvin Bruney [MVP ASP.NET]

    [Shameless Author plug]
    The Microsoft Office Web Components Black Book with .NET
    Now Available @ www.lulu.com/owc
    Forth-coming VSTO.NET - Wrox/Wiley 2006
    -------------------------------------------------------



    "Rabbit" <> wrote in message
    news:...
    > Dear All,
    >
    > I am development my web application on my PC, while its testing under the
    > local area network environment (http://192.168.0.2/webapp/default.aspx),

    the
    > speed and response are all very fast.
    >
    > The slow performance issue happens while i access it via WAN method
    > (http://rabbit.dyndns.org/webapp/default.aspx), does anyone got any idea

    why
    > will this happen?
    >
    > I did ask my friend to access my web application over the internet, and

    the
    > speed testing results are all very fast, so I wonder why this scenario

    only
    > happening when I use same PC to access my web application thru WAN?
    >
    > Thanks in advance
    > Rabbit
    >
    >
    Alvin Bruney - ASP.NET MVP, Feb 6, 2006
    #2
    1. Advertising

  3. shot in the dark..
    do you have two databases one for testing and one for production. could your
    production site be trying to access the wrong db?

    like i said a shot ing the dark, but it happened to me once.
    --
    thanks (as always)
    some day i''m gona pay this forum back for all the help i''m getting
    kes


    "Rabbit" wrote:

    > Dear All,
    >
    > I am development my web application on my PC, while its testing under the
    > local area network environment (http://192.168.0.2/webapp/default.aspx), the
    > speed and response are all very fast.
    >
    > The slow performance issue happens while i access it via WAN method
    > (http://rabbit.dyndns.org/webapp/default.aspx), does anyone got any idea why
    > will this happen?
    >
    > I did ask my friend to access my web application over the internet, and the
    > speed testing results are all very fast, so I wonder why this scenario only
    > happening when I use same PC to access my web application thru WAN?
    >
    > Thanks in advance
    > Rabbit
    >
    >
    >
    =?Utf-8?B?V2ViQnVpbGRlcjQ1MQ==?=, Feb 6, 2006
    #3
  4. Rabbit

    Rabbit Guest

    Thanks for your advice.

    Problem fixed, it was due to my router, if i bypass it to connect my PC to
    the broadband modem directly, the speed turns out as normal as I expected.

    It is strange to me that the router(Netgear Wireless Router 802.11b - model
    MR814) can perform all functions except the speed, probably its old enough
    to replace another one ^.^


    "Alvin Bruney - ASP.NET MVP" <www.lulu.com/owc> wrote in message
    news:...
    > you need to figure out what the connection speed is from that point before
    > doing anything else. See if you can isolate the problem to eliminate or
    > blame the network as the source of the issue.
    >
    > --
    > Regards,
    > Alvin Bruney [MVP ASP.NET]
    >
    > [Shameless Author plug]
    > The Microsoft Office Web Components Black Book with .NET
    > Now Available @ www.lulu.com/owc
    > Forth-coming VSTO.NET - Wrox/Wiley 2006
    > -------------------------------------------------------
    >
    >
    >
    > "Rabbit" <> wrote in message
    > news:...
    >> Dear All,
    >>
    >> I am development my web application on my PC, while its testing under the
    >> local area network environment (http://192.168.0.2/webapp/default.aspx),

    > the
    >> speed and response are all very fast.
    >>
    >> The slow performance issue happens while i access it via WAN method
    >> (http://rabbit.dyndns.org/webapp/default.aspx), does anyone got any idea

    > why
    >> will this happen?
    >>
    >> I did ask my friend to access my web application over the internet, and

    > the
    >> speed testing results are all very fast, so I wonder why this scenario

    > only
    >> happening when I use same PC to access my web application thru WAN?
    >>
    >> Thanks in advance
    >> Rabbit
    >>
    >>

    >
    >
    Rabbit, Feb 7, 2006
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. B Dunwoodie

    ASP.NET/IIS on XP Pro Extremely SLOW

    B Dunwoodie, Apr 26, 2004, in forum: ASP .Net
    Replies:
    0
    Views:
    478
    B Dunwoodie
    Apr 26, 2004
  2. Natan

    Extremely slow ASP.NET

    Natan, Dec 11, 2004, in forum: ASP .Net
    Replies:
    1
    Views:
    1,275
    =?ISO-8859-1?Q?Marcelo_Hern=E1n_Ruiz?=
    Dec 11, 2004
  3. =?Utf-8?B?RENDLTcwMA==?=

    IDE/Debugger Extremely Slow

    =?Utf-8?B?RENDLTcwMA==?=, Mar 23, 2006, in forum: ASP .Net
    Replies:
    6
    Views:
    1,247
    DCC700
    Apr 17, 2006
  4. Timo Nentwig

    linux: eclipse extremely slow

    Timo Nentwig, Jul 24, 2003, in forum: Java
    Replies:
    0
    Views:
    655
    Timo Nentwig
    Jul 24, 2003
  5. Jim Garrison

    pickle.load() extremely slow performance

    Jim Garrison, Mar 20, 2009, in forum: Python
    Replies:
    11
    Views:
    2,231
    Jim Garrison
    Mar 23, 2009
Loading...

Share This Page