Idle no longer works

Discussion in 'Python' started by Opap-OJ, Aug 12, 2012.

  1. Opap-OJ

    Opap-OJ Guest

    I can no longer open the Idle IDE for Python on Windows 7.

    For 3-5 years I used Idle for all my python work. But in January this happens:

    When I right click on a python file and choose "open with Idle" nothing happens.

    If I double-click on the file itself, it briefly opens an MS-DOS looking window, then closes it immediately.

    I tried installing Eclipse with PyDev. It opens the file, but will not run it in Python.

    Any idea why?
    Opap-OJ, Aug 12, 2012
    #1
    1. Advertising

  2. On Sat, Aug 11, 2012 at 4:09 PM, Opap-OJ <> wrote:
    > I can no longer open the Idle IDE for Python on Windows 7.
    >
    > For 3-5 years I used Idle for all my python work. But in January this happens:
    >
    > When I right click on a python file and choose "open with Idle" nothing happens.
    >
    > If I double-click on the file itself, it briefly opens an MS-DOS looking window, then closes it immediately.
    >
    > I tried installing Eclipse with PyDev. It opens the file, but will not run it in Python.
    >
    > Any idea why?
    > --


    Have you tried launching Python from the Command Prompt? Open up
    command prompt and run C:\Python32\python.exe or whatever corresponds
    to your version of Python.
    Benjamin Kaplan, Aug 12, 2012
    #2
    1. Advertising

  3. Opap-OJ

    Terry Reedy Guest

    On 8/11/2012 7:09 PM, Opap-OJ wrote:
    > I can no longer open the Idle IDE for Python on Windows 7.
    >
    > For 3-5 years I used Idle for all my python work. But in January
    > this happens:
    >
    > When I right click on a python file and choose "open with Idle"
    > nothing happens.
    >
    > If I double-click on the file itself, it briefly opens an MS-DOS
    > looking window, then closes it immediately.


    That should run the file and discard the output. Above is typical

    > Any idea why?


    *Something* very specific to your system changed. Either registry
    associations for .py are screwed, or your Python installation is
    damaged. Easiest fix is to uninstall and re-install Python. But download
    a more recent version first. Uninstall might not be needed, but makes
    process more like to work.

    In the regular interactive command prompt interpreter

    import idlelib.idle

    should start idle.


    --
    Terry Jan Reedy
    Terry Reedy, Aug 12, 2012
    #3
  4. Opap-OJ

    Guest

    On Saturday, August 11, 2012 4:09:16 PM UTC-7, Opap-OJ wrote:

    > I can no longer open the Idle IDE for Python on Windows 7.
    > ..
    > Any idea why?


    It looks like your registry has changed.

    To fix this just use the Windows Explorer, click on a Python file
    and use the 'Open with, Choose default program' menu and then
    select the Idle IDE as the default program.
    , Aug 13, 2012
    #4
  5. On Mon, 13 Aug 2012 00:11:06 -0700 (PDT), declaimed
    the following in gmane.comp.python.general:

    > On Saturday, August 11, 2012 4:09:16 PM UTC-7, Opap-OJ wrote:
    >
    > > I can no longer open the Idle IDE for Python on Windows 7.
    > > ..
    > > Any idea why?

    >
    > It looks like your registry has changed.
    >
    > To fix this just use the Windows Explorer, click on a Python file
    > and use the 'Open with, Choose default program' menu and then
    > select the Idle IDE as the default program.


    That is probably the worst choice to make -- since what you've
    defined means double clicking on ANY .py file will NOT RUN IT -- but
    rather attempt to open it with the editor (IDLE)... But since IDLE
    itself is a .py file, it may fail to start at all.

    If double-clicking an IDLE.py file does not start it, then the
    registry has lost the association of .py to python.exe, not to IDLE. OR
    -- .py IS associated to python.exe but the association (the "run
    command" is not passing the .py file name to the python executable).

    On WinXP (with ActiveState 2.5.x version) my associations are as:

    E:\UserData\Wulfraed\My Documents>assoc .py
    ..py=py_auto_file

    E:\UserData\Wulfraed\My Documents>ftype py_auto_file
    py_auto_file="E:\Python25\python.exe" "%1" %*

    E:\UserData\Wulfraed\My Documents>

    (with similar entries for .pyw to hook into pythonw.exe)
    {Just booted the Win7 laptop with Python 2.7.x: The only real difference
    is that it uses Python.File where the above has py_auto_file}



    --
    Wulfraed Dennis Lee Bieber AF6VN
    HTTP://wlfraed.home.netcom.com/
    Dennis Lee Bieber, Aug 13, 2012
    #5
  6. Opap-OJ

    Terry Reedy Guest

    On 8/13/2012 1:43 PM, Dennis Lee Bieber wrote:
    > On Mon, 13 Aug 2012 00:11:06 -0700 (PDT), declaimed
    > the following in gmane.comp.python.general:
    >
    >> On Saturday, August 11, 2012 4:09:16 PM UTC-7, Opap-OJ wrote:
    >>
    >>> I can no longer open the Idle IDE for Python on Windows 7.
    >>> ..
    >>> Any idea why?

    >>
    >> It looks like your registry has changed.


    Most likely, or the Python installation has be damaged.

    >> To fix this just use the Windows Explorer, click on a Python file
    >> and use the 'Open with, Choose default program' menu and then
    >> select the Idle IDE as the default program.

    >
    > That is probably the worst choice to make -- since what you've
    > defined means double clicking on ANY .py file will NOT RUN IT -- but
    > rather attempt to open it with the editor (IDLE)... But since IDLE
    > itself is a .py file, it may fail to start at all.
    >
    > If double-clicking an IDLE.py file does not start it, then the
    > registry has lost the association of .py to python.exe, not to IDLE. OR
    > -- .py IS associated to python.exe but the association (the "run
    > command" is not passing the .py file name to the python executable).
    >
    > On WinXP (with ActiveState 2.5.x version) my associations are as:
    >
    > E:\UserData\Wulfraed\My Documents>assoc .py
    > .py=py_auto_file
    >
    > E:\UserData\Wulfraed\My Documents>ftype py_auto_file
    > py_auto_file="E:\Python25\python.exe" "%1" %*
    >
    > E:\UserData\Wulfraed\My Documents>
    >
    > (with similar entries for .pyw to hook into pythonw.exe)
    > {Just booted the Win7 laptop with Python 2.7.x: The only real difference
    > is that it uses Python.File where the above has py_auto_file}


    Re-installing, as I suggested in the first response, is much easier,
    especially for someone not familiar with the above.

    --
    Terry Jan Reedy
    Terry Reedy, Aug 13, 2012
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Cory Nelson
    Replies:
    2
    Views:
    397
    Cory Nelson
    Apr 15, 2004
  2. =?Utf-8?B?QnJ5YW4gWk0=?=
    Replies:
    1
    Views:
    1,144
    =?Utf-8?B?QnJ5YW4gWk0=?=
    May 26, 2005
  3. bb
    Replies:
    2
    Views:
    373
  4. Mark
    Replies:
    6
    Views:
    557
    Andrew Thompson
    Nov 15, 2005
  5. Matt Whiteley

    Import no longer works in Python 2.3.x

    Matt Whiteley, Feb 11, 2004, in forum: Python
    Replies:
    4
    Views:
    294
    Matt Whiteley
    Feb 13, 2004
Loading...

Share This Page