Index was outside the bounds of the array

Discussion in 'ASP .Net Web Services' started by Cammie Watson, Nov 25, 2005.

  1. Hi there,

    We have a web application written in asp.net (1.1). I'm not going to go
    into too much detail but we use a DLL to communicate with the database and
    also a couple of webservices. When we deployed version 1, everything
    deployed OK on our webserver. We deployed the application and 1 webservice
    under default web site, the other webservice (3rd party supplied) is on
    another server and services many other application in our organisation
    sucessfully.

    Recently we have tried to deploy version 2, but this time we have assigned
    another IP address to the web server and tried to install the application
    under a new website. Everything looked OK the application installed OK and
    most of the functionallity works just fine but 1 or 2 of the webservice calls
    fails with the error:
    "Index was outside the bounds of the array"
    I get this error on both webservices, on specific webmethods, but it DOES
    work OK on default website....

    Any help on this would be appreciated

    Cammie
     
    Cammie Watson, Nov 25, 2005
    #1
    1. Advertising

  2. Cammie Watson

    DC Guest

    what you describe is a very generic error and is not specific to
    webservices.
    you're going to have to narrow it down a bit more.
    for one thing, which array is it?

    -D

    "Cammie Watson" <.(donotspam)> wrote in message
    news:...
    > Hi there,
    >
    > We have a web application written in asp.net (1.1). I'm not going to go
    > into too much detail but we use a DLL to communicate with the database and
    > also a couple of webservices. When we deployed version 1, everything
    > deployed OK on our webserver. We deployed the application and 1
    > webservice
    > under default web site, the other webservice (3rd party supplied) is on
    > another server and services many other application in our organisation
    > sucessfully.
    >
    > Recently we have tried to deploy version 2, but this time we have assigned
    > another IP address to the web server and tried to install the application
    > under a new website. Everything looked OK the application installed OK
    > and
    > most of the functionallity works just fine but 1 or 2 of the webservice
    > calls
    > fails with the error:
    > "Index was outside the bounds of the array"
    > I get this error on both webservices, on specific webmethods, but it DOES
    > work OK on default website....
    >
    > Any help on this would be appreciated
    >
    > Cammie
     
    DC, Dec 1, 2005
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    0
    Views:
    3,173
  2. =?Utf-8?B?Q2FtbWllIFdhdHNvbg==?=

    Index was outside the bounds of the array

    =?Utf-8?B?Q2FtbWllIFdhdHNvbg==?=, Nov 28, 2005, in forum: ASP .Net
    Replies:
    3
    Views:
    9,740
    Patrice
    Nov 28, 2005
  3. Replies:
    10
    Views:
    547
    Mark McIntyre
    Apr 12, 2006
  4. Seb
    Replies:
    0
    Views:
    1,892
  5. ton
    Replies:
    4
    Views:
    1,031
Loading...

Share This Page