Install from source on CentOS question

Discussion in 'Ruby' started by Cameron Smith, May 3, 2010.

  1. I am attempting to install 1.9.1 from source on CentOS 5.4 and am
    running into an issue.

    after unpacking the archive and cd-ing into the ruby-1.9.1-p376 I run:
    /configure --with-openssl-dir=/usr/lib/openssl

    but the last line of the output shows:
    config.status: creating Makefile
    configure: WARNING: unrecognized options: --with-openssl-dir

    What do I need to do to get the creation of the makefile to not throw
    that warning?
    --
    Posted via http://www.ruby-forum.com/.
     
    Cameron Smith, May 3, 2010
    #1
    1. Advertising

  2. Cameron Smith

    v4 forums Guest

    [Note: parts of this message were removed to make it a legal post.]

    Hi Cameron,

    I am new to Ruby and I came across this same problem when I was installing
    ruby for the first time on my Ubuntu box. But after spending some time on
    it, I found the following steps works without much of a problem for
    installing ruby with openssl.

    Ignore the --with-openssl-dir: I think the problem is to say with using
    [dash][dash]with-openssl-dir instead of [dash][dash]
    [dash][dash]with-openssl-dir. Google for the same and you will find the
    reason

    Instead, try this approach:

    1. Install ruby with ./configure --prefix = /installation_path
    2. Download openssl source and run ./config --perfix= /installation_path
    Note: OpenSSL 1.0.X version doesn't seems to be working with ruby.
    OpenSSL-0.9.8n worked for me. Also use the same $installation_path for both
    'prefix' declarations. e.g., --prefix=/usr/local
    3. Complete OpenSSL installation.
    4. Go back to the ruby-1.8.6-pxxx/ext/openssl folder and run - ruby
    extconf.rb, make, make install respectively.

    Now I am sure, all the required packages for openssl can be identified by
    ruby whenever required.

    Hope this helps. I have also blogged about the same in the following
    location. Feel free to check this out too.
    http://theflashesofinsight.wordpress.com/2010/04/29/ubuntu-rails-fix-starting-webrick-openssl-issue/

    With be glad to hear from the group if there are any better solutions.

    Thanks

    On Mon, May 3, 2010 at 5:43 AM, Cameron Smith <> wrote:

    > I am attempting to install 1.9.1 from source on CentOS 5.4 and am
    > running into an issue.
    >
    > after unpacking the archive and cd-ing into the ruby-1.9.1-p376 I run:
    > ./configure --with-openssl-dir=/usr/lib/openssl
    >
    > but the last line of the output shows:
    > config.status: creating Makefile
    > configure: WARNING: unrecognized options: --with-openssl-dir
    >
    > What do I need to do to get the creation of the makefile to not throw
    > that warning?
    > --
    > Posted via http://www.ruby-forum.com/.
    >
    >
     
    v4 forums, May 3, 2010
    #2
    1. Advertising

  3. v4 forums wrote:
    > With be glad to hear from the group if there are any better solutions.


    There's no need to install openssl from source. Just install the
    openssl-devel package before building ruby (yum install openssl-devel)
    --
    Posted via http://www.ruby-forum.com/.
     
    Brian Candler, May 3, 2010
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. nat
    Replies:
    0
    Views:
    506
  2. Xeno Campanoli
    Replies:
    2
    Views:
    213
    Xeno Campanoli
    Sep 13, 2007
  3. Xeno Campanoli
    Replies:
    13
    Views:
    303
    Xeno Campanoli
    Jan 6, 2008
  4. Xeno Campanoli
    Replies:
    2
    Views:
    276
    Xeno Campanoli
    Mar 26, 2008
  5. Xeno Campanoli
    Replies:
    4
    Views:
    146
    Kyle Schmitt
    Apr 10, 2008
Loading...

Share This Page