"Load Report Failed." error... cryptic and evasive...

Discussion in 'ASP .Net' started by Roy, May 5, 2005.

  1. Roy

    Roy Guest

    Hey all,

    I have a VB App which uses the bundled version of Crystal Reports for
    VS.NET 2003. It works fine in when I run it using VS *but* when I
    deploy it anywhere
    (including the development PC itself) it won't load a report and
    displays the cryptic "Load Report Failed" error. It's frustrating. Why
    would it work great on my machine using the VS "Start" option, but fail
    to work when I try to run it as an executable?

    I've loaded the 4 merge modules specified on crystal reports support
    site into the deployment project...what am I missing?

    Thanks!
     
    Roy, May 5, 2005
    #1
    1. Advertising

  2. Roy

    Roy Guest

    Ok. I've added
    1.) the default 4 crystal report merge modules needed
    2.) atl.msm
    3.) every single dll in the "program files\common files\crystal
    reports\" folder to my deployment project.
    4.) all 5 groups (primary output, localized resources, debug symbols,
    content files, source files) in the "Add Project Output Group" to my
    deployment project's application folder.
    5.) and I've reinstalled .net framework 1.1 sdk and vj# 1.1
    redistributable on the machines.

    I'm banging my head against the wall here. Anyone have any ideas at
    all? Again, I can run the app (and view the reports) just fine within
    V.S., but after creating an msi and installing it doesn't display
    reports (even on the same development machine)...

    Clearly something must be getting left out in the process of moving
    from a raw vs.net project to a live .msi file but i'll be darned if I
    can figure out what it is?
     
    Roy, May 5, 2005
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Meheraj shaik via .NET 247

    Crysatl report load report failed

    Meheraj shaik via .NET 247, May 28, 2005, in forum: ASP .Net
    Replies:
    1
    Views:
    3,251
    saapr
    Jun 7, 2005
  2. Simon
    Replies:
    0
    Views:
    9,869
    Simon
    Jun 7, 2005
  3. Generic Usenet Account
    Replies:
    1
    Views:
    601
    Victor Bazarov
    Mar 21, 2005
  4. none

    Cryptic error

    none, May 5, 2010, in forum: C++
    Replies:
    11
    Views:
    645
    Ian Collins
    May 5, 2010
  5. andrey the giant

    cryptic error in cgi script

    andrey the giant, Oct 13, 2010, in forum: Perl Misc
    Replies:
    2
    Views:
    197
    Uri Guttman
    Oct 13, 2010
Loading...

Share This Page