Migration to Windows 2003, Error Messages not shown in Browser

Discussion in 'ASP General' started by Michael G. Schneider, Nov 26, 2003.

  1. I recently upgraded my servers to 2003. Since then the error-information
    shown in the browser has changed.

    For example, if under Windows 2000 I executed an SQL statement from within
    an ASP, and the SQL statement was syntactically incorrect, the error thrown
    by ADO would finally show up in the client browser.

    If I do the same with an Windows 2003 Server, only a "HTTP 500, internal
    server error" is sent to to client browser. The IIS LogFiles still show the
    actual error, but looking there is not that comfortable.

    Is this some configuration that can be done on the Windows 2003 server?

    Michael G. Schneider
     
    Michael G. Schneider, Nov 26, 2003
    #1
    1. Advertising

  2. Michael G. Schneider

    middletree Guest

    Is the browser in question on the same machine as it was before? If not, go
    to Tools, Internet Options, Advanced, and make sure that the Show Friendly
    messages box is unchecked.



    "Michael G. Schneider" <> wrote in message
    news:OpfU#...
    > I recently upgraded my servers to 2003. Since then the error-information
    > shown in the browser has changed.
    >
    > For example, if under Windows 2000 I executed an SQL statement from within
    > an ASP, and the SQL statement was syntactically incorrect, the error

    thrown
    > by ADO would finally show up in the client browser.
    >
    > If I do the same with an Windows 2003 Server, only a "HTTP 500, internal
    > server error" is sent to to client browser. The IIS LogFiles still show

    the
    > actual error, but looking there is not that comfortable.
    >
    > Is this some configuration that can be done on the Windows 2003 server?
    >
    > Michael G. Schneider
    >
    >
     
    middletree, Nov 26, 2003
    #2
    1. Advertising

  3. "middletree" <> schrieb im Newsbeitrag
    news:...

    > Is the browser in question on the same machine as it was before? If not,

    go
    > to Tools, Internet Options, Advanced, and make sure that the Show Friendly
    > messages box is unchecked.


    It is the same workstation, same browser. If this browser is used with a
    Windows 2000 Server ASP application, the full message is shown. So I suspect
    that it is a server-side question.

    Michael G. Schneider
     
    Michael G. Schneider, Nov 26, 2003
    #3
  4. "middletree" <> schrieb im Newsbeitrag
    news:...
    > Is the browser in question on the same machine as it was before? If not,

    go
    > to Tools, Internet Options, Advanced, and make sure that the Show Friendly
    > messages box is unchecked.


    Sorry, my last post, a couple of minutes ago, was wrong.

    It was indeed a setting in Internet Explorer. Translated from German the
    setting reads "Short HTTP-Error Messages". When unchecked, the error
    messages are shown correctly.

    Thank's a lot for your help.

    Michael G. Schneider
     
    Michael G. Schneider, Nov 26, 2003
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Johann Blake
    Replies:
    4
    Views:
    1,538
    earbullet
    Dec 9, 2004
  2. Chris
    Replies:
    0
    Views:
    391
    Chris
    Mar 24, 2010
  3. Mete Akalýn
    Replies:
    1
    Views:
    438
    Mete Akalýn
    Jul 25, 2003
  4. Don Miller

    ASP 3.0 - Migration to Windows 2003 Question

    Don Miller, Aug 22, 2006, in forum: ASP General
    Replies:
    2
    Views:
    133
    Bob Barrows [MVP]
    Aug 22, 2006
  5. Boni Satani
    Replies:
    0
    Views:
    194
    Boni Satani
    Jan 9, 2014
Loading...

Share This Page