mysql problem after upgrade to 5.0

Discussion in 'Ruby' started by Kem Mason, Jan 24, 2007.

  1. Kem Mason

    Kem Mason Guest

    I'm posting this as an FYI -- for other people who might encounter the
    same problem -- I couldn't find any clear instructions on how to resolve
    it.

    I upgraded from mysql 4.1 to 5.0, at which point 2 different errors
    occured:

    error while trying to create table customers; Could not load driver
    (libmysqlclient.so.14: cannot open shared object file: No such file or
    directory - /usr/lib64/site_ruby/1.8/x86_64-linux/mysql.so)

    and:
    Errno::ENOENT in SearchController#search

    No such file or directory - /tmp/mysql.sock

    the solution was to install the latest ruby code -- in my case (fedora)

    yum upgrade ruby*

    did the trick.

    --
    Posted via http://www.ruby-forum.com/.
     
    Kem Mason, Jan 24, 2007
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Robert Ginsburg
    Replies:
    0
    Views:
    533
    Robert Ginsburg
    Jan 2, 2006
  2. Jason Blair

    Problem with ASP after upgrade to IIS 6

    Jason Blair, Jan 27, 2005, in forum: ASP General
    Replies:
    6
    Views:
    275
    Tom Kaminski [MVP]
    Jan 27, 2005
  3. Jason Wold

    problem after rails upgrade

    Jason Wold, Nov 18, 2005, in forum: Ruby
    Replies:
    1
    Views:
    130
    Jason Wold
    Nov 18, 2005
  4. Russ Amer

    problem running after upgrade

    Russ Amer, Mar 25, 2011, in forum: Ruby
    Replies:
    0
    Views:
    140
    Russ Amer
    Mar 25, 2011
  5. Replies:
    5
    Views:
    308
    Dr.Ruud
    Jul 5, 2006
Loading...

Share This Page