Page not found when running ASP.Net web application

Discussion in 'ASP .Net' started by HvLa, May 22, 2008.

  1. HvLa

    HvLa Guest

    I've just installed Visual Web developer 2008 and tried to run my first
    ASP.net web site. When I run it on my Vista Business PC I got an error
    "Page can not be displayed". What should I check to get an ASP.Net
    application running. I'm familiar with classic ASP programming not with
    ASP.Net. Classic ASP applications are running fine on the same PC.

    --
    Kind regards,
    Hans
     
    HvLa, May 22, 2008
    #1
    1. Advertising

  2. First thing to check for is whether the account ASP.NET
    is running as has ACL permissions to the application directory.

    In Vista, ASP.NET on IIS runs, by default, as the Network Authority account.

    Make sure that account has at least read permissions to the app dir.

    If you need to write to the directory, or update an Access database,
    add write permissions to the appropiate directories, too.

    If you're using VWD's Development Server,
    it will run as the MachineName\Administrator account.

    Make sure *that* account has access permissions.




    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "HvLa" <> wrote in message news:...
    > I've just installed Visual Web developer 2008 and tried to run my first
    > ASP.net web site. When I run it on my Vista Business PC I got an error
    > "Page can not be displayed". What should I check to get an ASP.Net
    > application running. I'm familiar with classic ASP programming not with
    > ASP.Net. Classic ASP applications are running fine on the same PC.
    >
    > --
    > Kind regards,
    > Hans
     
    Juan T. Llibre, May 22, 2008
    #2
    1. Advertising

  3. HvLa

    HvLa Guest

    I don't seem to have a ASPNET account! Any ideas how this is possible
    and how to correct this.

    --
    Kind regards,
    Hans van de Laar

    www.datascore.nl
     
    HvLa, May 22, 2008
    #3
  4. re:
    !>I don't seem to have a ASPNET account!

    Of course you don't. You are running Vista.
    ASPNET was the default account in IIS 5.1, in Windows XP.

    In Vista, which runs IIS 7.0, the default IIS account is Network Service.
    If you are using IIS, that's the account which needs permissions.

    Since apparently you're not running IIS, but VWD's Development Server,
    ASP.NET will run as the MachineName\Administrator account.

    Make sure *that* account has access permissions.

    re:
    !>Any ideas how this is possible and how to correct this.

    There's nothing to correct.
    Just give the right account the permissions outlined in my previous post.




    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "HvLa" <> wrote in message news:...
    >I don't seem to have a ASPNET account! Any ideas how this is possible
    > and how to correct this.
    >
    > --
    > Kind regards,
    > Hans van de Laar
    >
    > www.datascore.nl
    >
    >
     
    Juan T. Llibre, May 22, 2008
    #4
  5. HvLa

    HvLa Guest

    How do you give the Network Service the right permissions?

    I also noticed that the asp.net websites aren't listed in the IIS
    management console, whereas the classic asp web apps do. Shouldn't
    these asp.net apps show up also?

    --
    Kind regards,
    Hans van de Laar

    www.datascore.nl


    Juan T. Llibre wrote:

    > re:
    > !>I don't seem to have a ASPNET account!
    >
    > Of course you don't. You are running Vista.
    > ASPNET was the default account in IIS 5.1, in Windows XP.
    >
    > In Vista, which runs IIS 7.0, the default IIS account is Network
    > Service. If you are using IIS, that's the account which needs
    > permissions.
    >
    > Since apparently you're not running IIS, but VWD's Development Server,
    > ASP.NET will run as the MachineName\Administrator account.
    >
    > Make sure that account has access permissions.
    >
    > re:
    > !>Any ideas how this is possible and how to correct this.
    >
    > There's nothing to correct.
    > Just give the right account the permissions outlined in my previous
    > post.
    >
    >
    >
    >
    > Juan T. Llibre, asp.net MVP
    > asp.net faq : http://asp.net.do/faq/
    > foros de asp.net, en espaqol : http://asp.net.do/foros/
    > ======================================
    > "HvLa" <> wrote in message
    > news:...
    > > I don't seem to have a ASPNET account! Any ideas how this is
    > > possible and how to correct this.
    > >
    > > -- Kind regards,
    > > Hans van de Laar
    > >
    > > www.datascore.nl
    > >
    > >
     
    HvLa, May 22, 2008
    #5
  6. re:
    !> How do you give the Network Service the right permissions?

    You need to open the "Advanced Security Settings" dialog for the directory.
    Search Vista's help for "Advanced Security Settings".

    There's a good rundown, background info and images here :
    http://technet.microsoft.com/en-us/magazine/cc138011.aspx

    re:
    !> I also noticed that the asp.net websites aren't listed in the IIS
    !> management console, whereas the classic asp web apps do

    Did you install ASP.NET ?

    http://msdn.microsoft.com/en-us/library/aa964620(VS.80).aspx

    Did you *enable* ASP.NET ?

    http://intersoftpt.wordpress.com/2006/11/25/enabling-aspnet-20-in-vista-rtm/

    Scott Guthrie has a very good rundown here :

    http://weblogs.asp.net/scottgu/arch...k_3A00_-Using-IIS7-on-Vista-with-VS-2005.aspx



    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "HvLa" <> wrote in message news:%...
    > How do you give the Network Service the right permissions?
    >
    > I also noticed that the asp.net websites aren't listed in the IIS
    > management console, whereas the classic asp web apps do. Shouldn't
    > these asp.net apps show up also?
    >
    > --
    > Kind regards,
    > Hans van de Laar
    >
    > www.datascore.nl
    >
    >
    > Juan T. Llibre wrote:
    >
    >> re:
    >> !>I don't seem to have a ASPNET account!
    >>
    >> Of course you don't. You are running Vista.
    >> ASPNET was the default account in IIS 5.1, in Windows XP.
    >>
    >> In Vista, which runs IIS 7.0, the default IIS account is Network
    >> Service. If you are using IIS, that's the account which needs
    >> permissions.
    >>
    >> Since apparently you're not running IIS, but VWD's Development Server,
    >> ASP.NET will run as the MachineName\Administrator account.
    >>
    >> Make sure that account has access permissions.
    >>
    >> re:
    >> !>Any ideas how this is possible and how to correct this.
    >>
    >> There's nothing to correct.
    >> Just give the right account the permissions outlined in my previous
    >> post.
    >>
    >>
    >>
    >>
    >> Juan T. Llibre, asp.net MVP
    >> asp.net faq : http://asp.net.do/faq/
    >> foros de asp.net, en espaqol : http://asp.net.do/foros/
    >> ======================================
    >> "HvLa" <> wrote in message
    >> news:...
    >> > I don't seem to have a ASPNET account! Any ideas how this is
    >> > possible and how to correct this.
    >> >
    >> > -- Kind regards,
    >> > Hans van de Laar
    >> >
    >> > www.datascore.nl
    >> >
    >> >
     
    Juan T. Llibre, May 22, 2008
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Hellp
    Replies:
    0
    Views:
    370
    Hellp
    Sep 9, 2004
  2. =?Utf-8?B?Vk1J?=
    Replies:
    0
    Views:
    327
    =?Utf-8?B?Vk1J?=
    Oct 19, 2006
  3. Greg
    Replies:
    0
    Views:
    804
  4. Amit Save
    Replies:
    0
    Views:
    109
    Amit Save
    Jun 14, 2005
  5. Divya
    Replies:
    2
    Views:
    193
    Bullschmidt
    May 11, 2004
Loading...

Share This Page