Problem getting IHttpHandler recognized globally on IIS 5.0

Discussion in 'ASP .Net' started by =?Utf-8?B?am9obg==?=, May 24, 2004.

  1. I have an http handler that I’d like to be recognized for every site on a server. The http handler is similar to what the trace.axd handler, in that there is no actual file that exists on the hard drive to process. When the hander gets called, it generates the html and dumps the html to the context.Response object, which then gets rendered to the client.

    I have the handler in the GAC, all my web sites have the appropriate web.config section. And I’ve added the file extension ‘.mgr’ to IIS. Here is the problem. If I register the file extension to a specific web site under the Default Web Site in IIS, then everything works fine. But if I register the file extension just for the Default Web Site on IIS (the one that all the other web sites that run on port 80 reside under), then it doesn’t work. If I have 25 sites running under the Default Web Site, do I have to register my handler individually for each site? Or shouldn’t the settings for the Default Web site trickle down to the sub sites

    I'm using IIS 5.0 on an XP machine
    =?Utf-8?B?am9obg==?=, May 24, 2004
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Chris Hughes

    IHttpHandler - configuring IIS security

    Chris Hughes, Dec 12, 2003, in forum: ASP .Net
    Replies:
    0
    Views:
    331
    Chris Hughes
    Dec 12, 2003
  2. rss
    Replies:
    3
    Views:
    678
  3. Shaike
    Replies:
    0
    Views:
    438
    Shaike
    Dec 1, 2004
  4. Tim_Mac
    Replies:
    2
    Views:
    1,452
    Tim_Mac
    Mar 4, 2006
  5. Alphapage

    WCF in IIS : get IHttpHandler to process request

    Alphapage, May 24, 2008, in forum: ASP .Net Web Services
    Replies:
    0
    Views:
    297
    Alphapage
    May 24, 2008
Loading...

Share This Page