IIS 7.0 Scripting.FileSystemObject

Discussion in 'ASP General' started by Andrew, Mar 1, 2010.

  1. Andrew

    Andrew Guest

    I created a simple test script below:

    Dim s
    Dim a
    Set s = CreateObject(“Scripting.FileSystemObjectâ€)
    Set a = s.getFile(Server.MapPath(“test.txtâ€))

    Error: File NOT found. I am tying to read a file located under "wwwroot"

    I installed classic ASP support. Added the site to the "classic asp"
    application Pool (unmanaged, enabled parent paths). I added IUSR and
    IUSR_Users to the permissions. I even tried to add "everyone" full access to
    the file.

    YES. The file Exist. I did a Response.Write on the Path and copied and
    paste the result in the address bar. The path is hard coded.

    I have NO idea what is causing the problem. "File Not found" is not the
    reason. The file exist. It must be a permission issue (I think).

    any ideas what I can change or fix?
     
    Andrew, Mar 1, 2010
    #1
    1. Advertisements

  2. Andrew

    Andrew Guest

    Using Windows 2008 with all the updates installed.
     
    Andrew, Mar 1, 2010
    #2
    1. Advertisements

  3. Andrew

    Andrew Guest

    fixed it. forgot to set read/write permissions on the classic asp handler.
     
    Andrew, Mar 1, 2010
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.