IIS Security w/ASP.NET 2.0


S

Scott M.

I have changed the "My Project" setting in VS 2005 from "Use VS Dev. Server" to "Use IIS Web Server" and I've clicked the "Create Virtual Directory" button. When I attempt to run (with debugging), I get a generic error messagebox (doesn't even get to the browser) that says to ensure the server is operating correctly and that there are no errors in my code. When I try to start without debugging, I get a standard error page in my browser saying:
HTTP 403.1 Forbidden: Execute Access Forbidden
Internet Information Services
When I check the permissions of the VD, it looks ok, execute permissions are set to "scripts only" and the directory security is set to use the IUSER account.

What am I missing here?

Thanks,

Scott
 
Ad

Advertisements

N

Norman Yuan

You must make the virtual directiory an application. Have you done that?

I have changed the "My Project" setting in VS 2005 from "Use VS Dev. Server"
to "Use IIS Web Server" and I've clicked the "Create Virtual Directory"
button. When I attempt to run (with debugging), I get a generic error
messagebox (doesn't even get to the browser) that says to ensure the server
is operating correctly and that there are no errors in my code. When I try
to start without debugging, I get a standard error page in my browser
saying:
HTTP 403.1 Forbidden: Execute Access Forbidden
Internet Information Services
When I check the permissions of the VD, it looks ok, execute permissions are
set to "scripts only" and the directory security is set to use the IUSER
account.

What am I missing here?

Thanks,

Scott
 
S

Scott M.

When you hit the "Create Virtual Directory" button in VS's "My Project -
Web" tab, it not only creates the virtual directory, but makes it an
application as well - I have confirmed that within the MMC for IIS.
 
S

Scott M.

Curiosly, if I change the permissions on the application root folder to
"Scripts and Executables" (which I know I don't want to do in real life), I
get past the "Forbidden Access" error and now get a 404 error, yet the page
I'm trying to bring up does exist in the location that the browser its
trying to get it from (virtual directory wise, that is).
 
S

Scott M.

Well, I think I've solved part of the mystery.

After looking through the IIS application settings, I noticed that in the Documents tab, "default.aspx" was not listed as a default document. I added it and now my page comes up.

I still think there are other issues here, but I'll add more when I know more.

Interesting why "default.aspx" wasn't automatically added to the list (ASPNET_REGIIS -i has been run on IIS).

I have changed the "My Project" setting in VS 2005 from "Use VS Dev. Server" to "Use IIS Web Server" and I've clicked the "Create Virtual Directory" button. When I attempt to run (with debugging), I get a generic error messagebox (doesn't even get to the browser) that says to ensure the server is operating correctly and that there are no errors in my code. When I try to start without debugging, I get a standard error page in my browser saying:
HTTP 403.1 Forbidden: Execute Access Forbidden
Internet Information Services
When I check the permissions of the VD, it looks ok, execute permissions are set to "scripts only" and the directory security is set to use the IUSER account.

What am I missing here?

Thanks,

Scott
 
Ad

Advertisements

S

sloan

That must have been the missing piece .... I think most do the "Set Start Up Page", and somehow yours didn't get set.

The other issue I run into is

"Windows Integrated Security" on the IIS Security Tab.

...

And the last "Make sure" .. is the last tab of IIS property window, which sets the 1.1 or 2.0 version.
(Rare, but sometimes it'll get out of whack)


I have changed the "My Project" setting in VS 2005 from "Use VS Dev. Server" to "Use IIS Web Server" and I've clicked the "Create Virtual Directory" button. When I attempt to run (with debugging), I get a generic error messagebox (doesn't even get to the browser) that says to ensure the server is operating correctly and that there are no errors in my code. When I try to start without debugging, I get a standard error page in my browser saying:
HTTP 403.1 Forbidden: Execute Access Forbidden
Internet Information Services
When I check the permissions of the VD, it looks ok, execute permissions are set to "scripts only" and the directory security is set to use the IUSER account.

What am I missing here?

Thanks,

Scott
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads


Top