Latest .Net 1.1 patch causes aspnet_wp.exe not to work


J

John Blair

Hi,

I updated the latest .Net patch on my system this moring and now my SQL Web
Data Administrator application is not working. I get the following error:

Server Application Unavailable
The web application you are attempting to access on this web server is
currently unavailable. Please hit the "Refresh" button in your web browser
to retry your request.

Administrator Note: An error message detailing the cause of this specific
request failure can be found in the application event log of the web server.
Please review this log entry to discover what caused this error to occur.



I checked my event log and there is the error there:

Event Id: 1084 - ASP.Net stopped working.


aspnet_wp.exe could not be started. The error code for the failure is
800700CB. This error can be caused when the worker process account has
insufficient rights to read the .NET Framework files. Please ensure that the
..NET Framework is correctly installed and that the ACLs on the installation
directory allow access to the configured account.

Everything was fine before i applied the microsoft path - i tried to restore
my system to before the path was applied but i still get the same problem -
any ideas how to fix this problem?



Thanks.
 
Ad

Advertisements

T

Tampa.NET Koder

try re-registring asp.net with aspnet_regiis -i at the vs.net command prompt
 
W

William F. Robertson, Jr.

Try deleting the aspnet account from Users/Group management.

Then run the "aspnet_regiis /i "again, it should restore the privileges for
the machine.

Have you altered the processModel of the machine.config file?

bill
 
J

John Blair

Hi, i found the solution as described below.
Note: I also re-installed my Vb.net - this got rid of the attached problem
but then i still had a login problem and the following fixed it. Thanks
again.
 
Ad

Advertisements

J

John Blair

Thanks a lot - i got it working in the end - i basically re-installed my
Vb.net (to get the .net reinstalled); and re-installed my web data
administrator application and applied the following patch to fix a
problem with this application and the .net 1.1 patch. Thanks.
 
A

Anonieko

I got the same strange problem today after I rebooted my Windows XP Pro
machine. Running ASPNET 1.1

After researching a little I tried the following and fixed it.

1. Edit machine.config in the directory
C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\CONFIG Locate the
<processModel> tag. If the userName is "machine", change it to
"system"
(IF THIS IS NOT YOUR CASE, then you may have a different PROBLEM!!!)

This is the sample portion of machine.config.


<processModel enable="true" timeout="Infinite"
idleTimeout="Infinite" shutdownTimeout="0:00:05"
requestLimit="Infinite" requestQueueLimit="5000" restartQueueLimit="10"
memoryLimit="60" webGarden="false" cpuMask="0xffffffff"
userName="system" password="AutoGenerate" logLevel="Errors"
clientConnectedCheck="0:00:05" comAuthenticationLevel="Connect"
comImpersonationLevel="Impersonate" responseDeadlockInterval="00:03:00"
maxWorkerThreads="20" maxIoThreads="20"/>


2. Try to reinstall aspnet

C:>aspnet_regiis -i

3. Restart IIS via admin console or command console


Try and good luck!!!!
 
Ad

Advertisements

G

Guest

I have the same problem as described. I tryied the suggested solution from
Anonieko in various versions but nothing works. Does anybody else have some
ideas how to solve this problem? Any help greatly appreciated. I don't want
to rebuild the machine if I don't have to
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top