Login Control Problem

L

Lars

Hi

When I upload my site to my ISP I get error message given below. I do not
get the error if I publish the page to my own ISS server. I can access the
page form my machine on the Internet. But not at my ISPs site. Any ideas.



Line 118: public login_aspx() {
Line 119: string[] dependencies;
Line 120: ((Login)(this)).AppRelativeVirtualPath =
"~/Login.aspx";
Line 121: if ((global::ASP.login_aspx.@__initialized == false)) {
Line 122: dependencies = new string[2];


Here's my system.web file. Note that I'm using an Access database for the
user logins. IT has been working OK before. The changes I did was to att
code to the myLoginView.LoggenIn event and Load_Page event for the
Login.aspx file.

<?xml version="1.0"?>
<configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">
<connectionStrings>
<add name="LocalAccessDatabase" connectionString="~/App_Data/ASPNetDB.mdb"
providerName="System.Data.OleDb"/>
</connectionStrings>
<system.web>
<membership defaultProvider="AccessMembershipProvider">
<providers>
<clear/>
<add name="AccessMembershipProvider"
type="Samples.AccessProviders.AccessMembershipProvider"
connectionStringName="LocalAccessDatabase" enablePasswordRetrieval="false"
enablePasswordReset="false" requiresUniqueEmail="true"
requiresQuestionAndAnswer="true" minRequiredPasswordLength="1"
minRequiredNonalphanumericCharacters="0" applicationName="SampleSite"
hashAlgorithmType="SHA1" passwordFormat="Hashed"/>
</providers>
</membership>
<roleManager enabled="true" defaultProvider="AccessRoleProvider"
cacheRolesInCookie="true" cookieName=".ASPXROLES" cookieTimeout="30"
cookiePath="/" cookieRequireSSL="false" cookieSlidingExpiration="true"
cookieProtection="All">
<providers>
<add name="AccessRoleProvider"
type="Samples.AccessProviders.AccessRoleProvider"
connectionStringName="LocalAccessDatabase" applicationName="SampleSite"/>
</providers>
</roleManager>
<authentication mode="Forms">
<forms loginUrl="~/Login.aspx" />
</authentication>
<authorization>
<allow users="*" />
</authorization>
<customErrors mode="Off"/>
<compilation debug="true"/>
</system.web>

</configuration>
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Forum statistics

Threads
473,756
Messages
2,569,531
Members
45,004
Latest member
KetoBoostGummies

Latest Threads

Top