Problem adding AJAX Control Toolkit to VWD 2008

Discussion in 'ASP .Net' started by rudi2218, Feb 28, 2008.

  1. rudi2218

    rudi2218 Guest

    Hi Everyone,

    I followed the instructions on the site to add the
    AjaxControlToolkit (AjaxControlToolkit.dll) to the VWD 2008 toolbar:
    http://www.asp.net/AJAX/AjaxControlToolkit/Samples/Walkthrough/Setup.aspx

    However, when I selected the AjaxControlToolkit.dll and clicked OK
    (as the instructions say to do), I get the following error:

    ' There was an error loading types from assembly
    "C:\Project\.....\AjaxControlToolkit\Bin\AjaxControlToolkit.dll"
    Could Not load file or assembly "System.Web.Extensions",
    version 1.0.61025,0....'

    Do I need to place the Ajax Control Toolkit or any files in any
    particular directory?

    Also, another weird thing is that when I select "New Project" I see
    under my template 3 icons that say Ajax Web Site.

    I even tried to unistall VWD 2008 and install it again. Regular
    controls
    and .Net 3.5 work fine. The Ajax Control Toolkit are the ones that I
    can't add to the Toolbar.

    Can someone please help?

    Thanks,

    Rudi
     
    rudi2218, Feb 28, 2008
    #1
    1. Advertisements

  2. Hello ,

    You can put that dll to any folder or to GAC and then add reference to that
    dll in your VS project.
    It should work fine.



    ---
    WBR,
    Michael Nemtsev [.NET/C# MVP] :: blog: http://spaces.live.com/laflour

    "The greatest danger for most of us is not that our aim is too high and we
    miss it, but that it is too low and we reach it" (c) Michelangelo
     
    Michael Nemtsev [MVP], Feb 28, 2008
    #2
    1. Advertisements

  3. rudi2218

    rudi2218 Guest

    Hi Michael,

    Thanks for the reply and recommendation. I'll try it and will let
    you know.


     
    rudi2218, Feb 28, 2008
    #3
  4. rudi2218

    rudi2218 Guest

    Hi Michael,

    I tried placing the dll in other directories (right in the .Net
    directory). Then I added
    it to the project again (right clicked on Solution Explorer and added
    it to the Project).

    Then I need to add it to the Toolbox to have the controls available.
    I created a new
    section called Ajax Control Toolkit. I then right clicked inside that
    section and selected
    Choose Items. I browsed to that directory and selected the
    AjaxControlToolkit.dll.
    Then it still gives me an error "Can't load assembly
    "System.Web.Extensions"..."

    I'm still unable to place the Ajax Controls in the Toolbox.

    Any ideas on what else can I do to get that working?

    Have a nice day and thanks in advance.

    Regards,

    Rudi
     
    rudi2218, Feb 28, 2008
    #4
  5. rudi2218

    dblake

    Joined:
    Mar 25, 2008
    Messages:
    1
    Likes Received:
    0
    Add AJAX Contol Toolkit

    I had a simular issue. Try this. Add a new tab to the toolbox. Within the new tab, select Choose Items and select the AjaxControlToolkit.dll file to add the controls to the toolbar.
     
    dblake, Mar 25, 2008
    #5
  6. rudi2218

    Tanu

    Joined:
    May 25, 2012
    Messages:
    1
    Likes Received:
    0
    Just need to swich to Design mode of page and then add

    Hi,
    I also face similar issue. However I realise that only code file was open i.e .cs file and I was tring to add ajaxtoolkit. then I open the same page in design mode then I wen to tool box and added ajaxtoolkit . that resolve the issue and I am able to add it.

    Hope that will help you.
     
    Tanu, May 25, 2012
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.