Still can't debug. ARGH!

D

darrel

Quick background:

Our department reveived new PCs a few weeks ago. Alas, due to new security
policies, we weren't immediately set up as admins of our own machines, so
most of us developers had issues getting SQL Server and IIS running
properly.

They apparently fixed all permissions (granting us admin rights) and we
thought we were good to go.

HOWEVER, I still maintain a few ASP.net 1.1 apps via VS 2003. I can no
longer debug any of my projects in VS 2003. I tried uninstalling and
reinstalling IIS, but still have these issues.

Here's the error(s) and all the remedies I've found/tried. I'm at my wits
end here. Does anyone have any other theories/suggestions as to why I can't
debug any applications?

I reinstalled IIS and tried to run/debug by asp.net 1.1 application from VS
2003. I got this error:

---------------------------
Microsoft Development Environment
---------------------------
Error while trying to run project: Unable to start debugging on the web
server. Debugging failed because integrated Windows authentication is not
enabled. Click Help for more information.
---------------------------
OK Help
---------------------------

So, I went in and enabled it.

Then, I get this error:

---------------------------
Microsoft Development Environment
---------------------------
Error while trying to run project: Unable to start debugging on the web
server. You do not have permissions to debug the server.

Verify that you are a member of the 'Debugger Users' group on the server.
---------------------------
OK Help
---------------------------

Some suggestions for this bug:

"Make sure you are a part of debugger group."

Well, this is probably an issue of what, exactly, does 'you' mean?

Under the 'Debugger Users' group on my local machine, the following accounts
are listed:

- administrator
- aspnet
- [my personal active directory account]

Same error.

"Make sure you have execute permissions on your virtual folder"

I set that to execute Scripts and Executables.

Still, same error.

"Make sure that HTTP Keep Alives are enabled."

I double check and, yep, that's enabled. Same error.

"add http://localhost to the trusted sites in Internet Explorer"

I do that and, still, same error.

"Go to your project > Properties > Configuration Properties > Debugging
Check at the bottom that ASP.NET debugging is still enabled."

Yep, that's enabled.

"Also, make sure that the DEBUG verb is still recognized on the server."

Hmm...not really sure what that refers too. Can anyone explain that one?

-Darrel
 
J

John Saunders

"Also, make sure that the DEBUG verb is still recognized on the server."

Hmm...not really sure what that refers too. Can anyone explain that one?

By "verb", it probably means "HTTP method". You can test this by sending a
DEBUG request to the server.

You can manually sent a request to the server by issuing the following
command from a command prompt:

TELNET servername 80

Then, on the next line, carefully type what you want to send. Type it
carefully because you will not see what you are typing. So, type:

DEBUG /<ENTER>
<ENTER>

Where "<ENTER>" means to press the Enter key on your keyboard.

Then, note any error message that comes back. It will likely be in HTML.
 
D

darrel

By "verb", it probably means "HTTP method". You can test this by sending a
DEBUG request to the server.

You can manually sent a request to the server by issuing the following
command from a command prompt:

TELNET servername 80

Then, on the next line, carefully type what you want to send. Type it
carefully because you will not see what you are typing. So, type:

DEBUG /<ENTER>
<ENTER>

Where "<ENTER>" means to press the Enter key on your keyboard.

Then, note any error message that comes back. It will likely be in HTML.

Wow...that's something I never would have figured out.

OK, so that does return an error!:

HTTP/0.9 501 Not Implemented

Connection to host lost.

Oddly, that doesn't show up on Google much.

However, what I can find does appear to be a permissions issue with my
system and/or IIS on my system.

Thanks for that lead, John!

Off to the IIS newsgroups... ;o)

-Darrel
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Forum statistics

Threads
473,754
Messages
2,569,516
Members
44,983
Latest member
BuyX10BoostKeto

Latest Threads

Top