web.config custom error settings


Joined
Sep 30, 2006
Messages
4
Reaction score
0
Hi everyone,

I've just uploaded my ASP.NET application on a new web host. But now whenever I load any .aspx page, I get this error:

Server Error in '/' Application.
Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>


Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>



It was running perfectly on the previous web host as well as my localhost. My web.config includes:

<configuration>
<system.web>
...
<customErrors mode="RemoteOnly" defaultRedirect="~/Error.aspx" />
<compilation debug="true" defaultLanguage="c#">
...
</compilation>
...
</system.web>
</configuration>

I have already tried:

1. Changing customErrors tag to: <customErrors mode="On" />
2. Changing customErrors tag to: <customErrors mode="Off" />
3. Changing compilation tag to: <compilation debug="false" defaultLanguage="c#">
4. Asking my web hosting company to ensure that my ASP.NET version is 2.0.xxx.
5. Asking my web host to ensure that the folder containing my .aspx files is a separate Virtual
Directory under IIS.

All of them do not solve the problem. I don't have any access to the web server's admin settings (not even a Plesk panel). I have to email the web hosting company for every change I want to make.

WHat else can I do? Thanks for the help.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top