aspnet_setreg fails

Discussion in 'ASP .Net Security' started by Kevin Brown, Aug 13, 2003.

  1. Kevin Brown

    Kevin Brown Guest

    Getting a consistent failure on machines when attempting
    to run the aspnet_setreg utility. The command line has
    worked on one or two machines. Here is the command line
    being used:
    aspnet_setreg.exe -
    k:SOFTWARE\CORPORATEAPPS\AppName\identity -
    u:"domain\account" -p:"password"

    The error is: ERROR: Argument 1 Invalid:

    I've tried creating the key manually ahead of time and
    checking rights. Cannot find anything wrong. Windows
    2000, SP4, Framework 1.1 (only).

    Anybody else get this or know what the issue might be?
     
    Kevin Brown, Aug 13, 2003
    #1
    1. Advertising

  2. Kevin Brown

    Kevin Brown Guest

    Well anything is always worth a try but no that isn't the
    problem. Same failure. The original command line worked
    on my XP machine but fails on the Windows 2000 boxes at my
    client.
    It would be nice if we had the source. There isn't much
    to this program so re-producing the encrypt functionality
    isn't difficult (just seems ashame to have to do that when
    a tool is provided).

    >-----Original Message-----
    >Well, the help specifies a single subkey argument, and

    you are providing two
    >levels. Perhaps this is the issue? It shouldn't matter, I

    know, but it
    >might. Try using only SOFTARE\AppName\identity ....
    >
    >--
    >Chris Jackson
    >Software Engineer
    >Microsoft MVP - Windows XP
    >Windows XP Associate Expert
    >--
    >"Kevin Brown" <> wrote

    in message
    >news:001c01c361b5$be935f90$...
    >> Getting a consistent failure on machines when attempting
    >> to run the aspnet_setreg utility. The command line has
    >> worked on one or two machines. Here is the command line
    >> being used:
    >> aspnet_setreg.exe -
    >> k:SOFTWARE\CORPORATEAPPS\AppName\identity -
    >> u:"domain\account" -p:"password"
    >>
    >> The error is: ERROR: Argument 1 Invalid:
    >>
    >> I've tried creating the key manually ahead of time and
    >> checking rights. Cannot find anything wrong. Windows
    >> 2000, SP4, Framework 1.1 (only).
    >>
    >> Anybody else get this or know what the issue might be?
    >>
    >>

    >
    >
    >.
    >
     
    Kevin Brown, Aug 13, 2003
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Andy

    aspnet_setreg error with v1.1

    Andy, Nov 20, 2003, in forum: ASP .Net
    Replies:
    1
    Views:
    1,023
  2. Kevin Burton

    aspnet_setreg?

    Kevin Burton, Jan 9, 2004, in forum: ASP .Net
    Replies:
    1
    Views:
    649
    ShikariShambu
    Jan 9, 2004
  3. Kevin Burton
    Replies:
    1
    Views:
    1,813
    Craig Deelsnyder
    Feb 7, 2004
  4. microsoft.public.dotnet.framework.aspnet.webcontro

    ASPNET_SETREG runs on XP, not 2000

    microsoft.public.dotnet.framework.aspnet.webcontro, May 5, 2004, in forum: ASP .Net
    Replies:
    0
    Views:
    356
    microsoft.public.dotnet.framework.aspnet.webcontro
    May 5, 2004
  5. D Barry
    Replies:
    1
    Views:
    2,947
    aedna
    Dec 17, 2008
Loading...

Share This Page