aspx pages dont work on win2003-server - newbie needs help

Discussion in 'ASP .Net' started by ASPNET@lesje.nl, Dec 14, 2004.

  1. Guest

    Hi,

    After spending several hours reading through help pages I try to turn
    to you guys for help.

    I have a co-located server (ie my own) with IIS 6.0 and MS Win 2003
    installed.

    ASP works on that server, as most things do, but now I am trying to
    learn APS.NET. So, I am a newbie, on both IIS, win2003 and APS.NET.

    The problem I am having: .aspx pages are not working.

    Error: HTTP Error 404 - File or directory not found

    Trying to solve this I have:

    - installed MS Framework SDK 1.1

    - tried to find out if .NET is installed properly. However, Win2003
    seems to have IIS6.0 and the .NET framework intergrated. So I can't
    find a definitve answer there.

    - Several pages suggested that the aspx extension needs to be binded
    (?). So here is what I did:

    in IIS manager, right click on websitefolder/properties/documents
    enabled default content page "default.aspx".

    in IIS manager/web extensions/ added aspx, in required files :
    C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspnet_isapi.dll is set
    to allowed.

    There is another option there: "All unknown ISAPI Extensions" is set
    to prohibited. I think that is right.

    A second problem, which might stop me from solving this: Many help
    pages speak of a "manage your server"-page. However, that page never
    comes up at the places those pages say that page should come up. SO
    where can I find that? (ie physically on the harddrive).

    Any help is much appreciated, and again, I am completely new at this
    so forgive me any stupidities :))

    Alexander
     
    , Dec 14, 2004
    #1
    1. Advertising

  2. In IIS Manager/Web Service Extensions/


    is there an entry for "ASP.NET v1.1.4322" ?

    If so, set it to "Allowed".
    ( Highlight it and click the "Allow" button. )

    If that's where you made the aspx entry,
    you can delete it. It's unneeded.



    Juan T. Llibre
    ===========
    <> wrote in message
    news:...
    > Hi,
    >
    > After spending several hours reading through help pages I try to turn
    > to you guys for help.
    >
    > I have a co-located server (ie my own) with IIS 6.0 and MS Win 2003
    > installed.
    >
    > ASP works on that server, as most things do, but now I am trying to
    > learn APS.NET. So, I am a newbie, on both IIS, win2003 and APS.NET.
    >
    > The problem I am having: .aspx pages are not working.
    >
    > Error: HTTP Error 404 - File or directory not found
    >
    > Trying to solve this I have:
    >
    > - installed MS Framework SDK 1.1
    >
    > - tried to find out if .NET is installed properly. However, Win2003
    > seems to have IIS6.0 and the .NET framework intergrated. So I can't
    > find a definitve answer there.
    >
    > - Several pages suggested that the aspx extension needs to be binded
    > (?). So here is what I did:
    >
    > in IIS manager, right click on websitefolder/properties/documents
    > enabled default content page "default.aspx".
    >
    > in IIS manager/web extensions/ added aspx, in required files :
    > C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspnet_isapi.dll is set
    > to allowed.
    >
    > There is another option there: "All unknown ISAPI Extensions" is set
    > to prohibited. I think that is right.
    >
    > A second problem, which might stop me from solving this: Many help
    > pages speak of a "manage your server"-page. However, that page never
    > comes up at the places those pages say that page should come up. SO
    > where can I find that? (ie physically on the harddrive).
    >
    > Any help is much appreciated, and again, I am completely new at this
    > so forgive me any stupidities :))
    >
    > Alexander
     
    Juan T. Llibre, Dec 14, 2004
    #2
    1. Advertising

  3. Guest

    Re: aspx pages dont work on win2003-server - newbie needs help - webext.jpg (0/1)

    On Tue, 14 Dec 2004 09:37:33 -0400, "Juan T. Llibre"
    <> wrote:

    >In IIS Manager/Web Service Extensions/
    >
    >
    >is there an entry for "ASP.NET v1.1.4322" ?
    >
    >If so, set it to "Allowed".
    >( Highlight it and click the "Allow" button. )
    >
    >If that's where you made the aspx entry,
    >you can delete it. It's unneeded.
    >
    >
    >
    >Juan T. Llibre
    >===========


    Dear Juan,

    Thank you for helping.

    There is no entry for "ASP.NET v1.1.4322".
    I made the entry for aspx. SO I can delete again?

    Ok, then what can I try next ?

    Alexander
     
    , Dec 14, 2004
    #3
  4. Re: aspx pages dont work on win2003-server - newbie needs help - webext.jpg (0/1)

    re:
    > Ok, then what can I try next ?


    1.
    Re-register ASP NET 1.1 by running "aspnet_regiis -i"
    from a command prompt in the Framework 1.1 directory:
    c:\windows\microsoft.net\framework\v1.1.4322\

    2.
    Check to see if the ASPNET and the IUSR_YourComputer
    accounts have permission to access your wwwroot and the
    directory tree below it.


    re:
    > There is no entry for "ASP.NET v1.1.4322".
    > I made the entry for aspx. SO I can delete again?


    What I meant is that *if* there was an entry
    for "ASP.NET v1.1.4322" *then* you could
    delete the entry you made for "aspx", since
    it would duplicate the "ASP.NET v1.1.4322" entry.

    To prevent confusion, I'd delete that entry, anyway,
    and create a new one for "ASP.NET v1.1.4322",
    mapping the entry to
    C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspnet_isapi.dll
    and checking the "Allowed" checkbox.

    But, *only* do that after you re-register ASP.NET 1.1,
    per above, and check the IIS Manager again, to see
    if re-registering ASP.NET 1.1 added the entry ( it should ).

    Make sure you close and open IIS Manager,
    or refresh the view, before cheking for the new entry.




    Juan T. Llibre
    ===========
    <> wrote in message
    news:...
    > On Tue, 14 Dec 2004 09:37:33 -0400, "Juan T. Llibre"
    > <> wrote:
    >
    >>In IIS Manager/Web Service Extensions/
    >>
    >>
    >>is there an entry for "ASP.NET v1.1.4322" ?
    >>
    >>If so, set it to "Allowed".
    >>( Highlight it and click the "Allow" button. )
    >>
    >>If that's where you made the aspx entry,
    >>you can delete it. It's unneeded.
    >>
    >>
    >>
    >>Juan T. Llibre
    >>===========

    >
    > Dear Juan,
    >
    > Thank you for helping.
    >
    > There is no entry for "ASP.NET v1.1.4322".
    > I made the entry for aspx. SO I can delete again?
    >
    > Ok, then what can I try next ?
    >
    > Alexander
     
    Juan T. Llibre, Dec 14, 2004
    #4
  5. Rozijn Guest

    Re: aspx pages dont work on win2003-server - newbie needs help - webext.jpg (0/1)

    On Tue, 14 Dec 2004 10:40:46 -0400, "Juan T. Llibre"
    <> wrote:

    >re:
    >> Ok, then what can I try next ?

    >
    >1.
    >Re-register ASP NET 1.1 by running "aspnet_regiis -i"
    >from a command prompt in the Framework 1.1 directory:
    >c:\windows\microsoft.net\framework\v1.1.4322\
    >


    ___ THANK YOU ________ !!!!!!!!!!!!!!!!

    Finally, that did the trick! the .aspx entry was deleted
    automatically.

    Thank you Juan !!

    A very happy Alexander :))

    >2.
    >Check to see if the ASPNET and the IUSR_YourComputer
    >accounts have permission to access your wwwroot and the
    >directory tree below it.
    >
    >
    >re:
    >> There is no entry for "ASP.NET v1.1.4322".
    >> I made the entry for aspx. SO I can delete again?

    >
    >What I meant is that *if* there was an entry
    >for "ASP.NET v1.1.4322" *then* you could
    >delete the entry you made for "aspx", since
    >it would duplicate the "ASP.NET v1.1.4322" entry.
    >
    >To prevent confusion, I'd delete that entry, anyway,
    >and create a new one for "ASP.NET v1.1.4322",
    >mapping the entry to
    >C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspnet_isapi.dll
    >and checking the "Allowed" checkbox.
    >
    >But, *only* do that after you re-register ASP.NET 1.1,
    >per above, and check the IIS Manager again, to see
    >if re-registering ASP.NET 1.1 added the entry ( it should ).
    >
    >Make sure you close and open IIS Manager,
    >or refresh the view, before cheking for the new entry.
    >
    >
    >
    >
    >Juan T. Llibre
    >===========
    ><> wrote in message
    >news:...
    >> On Tue, 14 Dec 2004 09:37:33 -0400, "Juan T. Llibre"
    >> <> wrote:
    >>
    >>>In IIS Manager/Web Service Extensions/
    >>>
    >>>
    >>>is there an entry for "ASP.NET v1.1.4322" ?
    >>>
    >>>If so, set it to "Allowed".
    >>>( Highlight it and click the "Allow" button. )
    >>>
    >>>If that's where you made the aspx entry,
    >>>you can delete it. It's unneeded.
    >>>
    >>>
    >>>
    >>>Juan T. Llibre
    >>>===========

    >>
    >> Dear Juan,
    >>
    >> Thank you for helping.
    >>
    >> There is no entry for "ASP.NET v1.1.4322".
    >> I made the entry for aspx. SO I can delete again?
    >>
    >> Ok, then what can I try next ?
    >>
    >> Alexander

    >
     
    Rozijn, Dec 14, 2004
    #5
  6. Re: aspx pages dont work on win2003-server - newbie needs help - webext.jpg (0/1)

    re:
    > Finally, that did the trick!


    Glad to have been of help !

    Have fun coding ASP.NET...



    Juan T. Llibre
    ===========
    "Rozijn" <> wrote in message
    news:...
    > On Tue, 14 Dec 2004 10:40:46 -0400, "Juan T. Llibre"
    > <> wrote:
    >
    >>re:
    >>> Ok, then what can I try next ?

    >>
    >>1.
    >>Re-register ASP NET 1.1 by running "aspnet_regiis -i"
    >>from a command prompt in the Framework 1.1 directory:
    >>c:\windows\microsoft.net\framework\v1.1.4322\
    >>

    >
    > ___ THANK YOU ________ !!!!!!!!!!!!!!!!
    >
    > Finally, that did the trick! the .aspx entry was deleted
    > automatically.
    >
    > Thank you Juan !!
    >
    > A very happy Alexander :))
    >
    >>2.
    >>Check to see if the ASPNET and the IUSR_YourComputer
    >>accounts have permission to access your wwwroot and the
    >>directory tree below it.
    >>
    >>
    >>re:
    >>> There is no entry for "ASP.NET v1.1.4322".
    >>> I made the entry for aspx. SO I can delete again?

    >>
    >>What I meant is that *if* there was an entry
    >>for "ASP.NET v1.1.4322" *then* you could
    >>delete the entry you made for "aspx", since
    >>it would duplicate the "ASP.NET v1.1.4322" entry.
    >>
    >>To prevent confusion, I'd delete that entry, anyway,
    >>and create a new one for "ASP.NET v1.1.4322",
    >>mapping the entry to
    >>C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspnet_isapi.dll
    >>and checking the "Allowed" checkbox.
    >>
    >>But, *only* do that after you re-register ASP.NET 1.1,
    >>per above, and check the IIS Manager again, to see
    >>if re-registering ASP.NET 1.1 added the entry ( it should ).
    >>
    >>Make sure you close and open IIS Manager,
    >>or refresh the view, before cheking for the new entry.
    >>
    >>
    >>
    >>
    >>Juan T. Llibre
    >>===========
    >><> wrote in message
    >>news:...
    >>> On Tue, 14 Dec 2004 09:37:33 -0400, "Juan T. Llibre"
    >>> <> wrote:
    >>>
    >>>>In IIS Manager/Web Service Extensions/
    >>>>
    >>>>
    >>>>is there an entry for "ASP.NET v1.1.4322" ?
    >>>>
    >>>>If so, set it to "Allowed".
    >>>>( Highlight it and click the "Allow" button. )
    >>>>
    >>>>If that's where you made the aspx entry,
    >>>>you can delete it. It's unneeded.
    >>>>
    >>>>
    >>>>
    >>>>Juan T. Llibre
    >>>>===========
    >>>
    >>> Dear Juan,
    >>>
    >>> Thank you for helping.
    >>>
    >>> There is no entry for "ASP.NET v1.1.4322".
    >>> I made the entry for aspx. SO I can delete again?
    >>>
    >>> Ok, then what can I try next ?
    >>>
    >>> Alexander

    >>

    >
     
    Juan T. Llibre [MVP], Dec 14, 2004
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Brian Watkins
    Replies:
    5
    Views:
    524
    Patrick Steele [MVP]
    Jan 6, 2004
  2. =?Utf-8?B?SmFycm9k?=

    Aspx Pages dont work on Server

    =?Utf-8?B?SmFycm9k?=, Nov 10, 2005, in forum: ASP .Net
    Replies:
    4
    Views:
    612
    =?Utf-8?B?SmFycm9k?=
    Nov 10, 2005
  3. RadioSignal

    passing variables from .aspx.cs code pages to .aspx pages

    RadioSignal, Sep 12, 2005, in forum: ASP .Net Web Controls
    Replies:
    7
    Views:
    2,243
    Mirronelli
    Oct 22, 2005
  4. Scott Gordo
    Replies:
    4
    Views:
    443
    Scott Gordo
    Mar 15, 2006
  5. AlexCZ
    Replies:
    1
    Views:
    324
    Evertjan.
    Jun 29, 2006
Loading...

Share This Page