Attribute 'ms_2d_layout' is not a valid attribute of element 'table'

Discussion in 'ASP .Net' started by CdnRebel, Jun 29, 2007.

  1. CdnRebel

    CdnRebel Guest

    Hi,

    I got the above message on the code below. The code is in an ASP.NET program
    (I think from version 1.1) and the error message shows up when I open the
    file in Visual Studio 2005. I am new to ASP.NET and Visual Studio. Is there
    another way to write that to get the same results? This is happening on
    every other program that I have opened on the website that I am updating.



    <TABLE height="737" cellSpacing="0" cellPadding="0" width="737" border="0"
    ms_2d_layout="TRUE">

    Thanks!!
     
    CdnRebel, Jun 29, 2007
    #1
    1. Advertising

  2. On Jun 29, 10:56 pm, "CdnRebel" <u35447@uwe> wrote:
    > Hi,
    >
    > I got the above message on the code below. The code is in an ASP.NET program
    > (I think from version 1.1) and the error message shows up when I open the
    > file in Visual Studio 2005. I am new to ASP.NET and Visual Studio. Is there
    > another way to write that to get the same results? This is happening on
    > every other program that I have opened on the website that I am updating.
    >
    > <TABLE height="737" cellSpacing="0" cellPadding="0" width="737" border="0"
    > ms_2d_layout="TRUE">
    >
    > Thanks!!


    It's a validation error.

    Go to Tools - Options - Text Editor - HTML - Validation
    (or View - Toolbars - HTML Source Editing)

    and change the target schema for validation

    If this attribute (ms_2d_layout) is not needed, simply remove it from
    your code
     
    Alexey Smirnov, Jun 30, 2007
    #2
    1. Advertising

  3. Alexey Smirnov wrote:
    >> Hi,
    >>

    >[quoted text clipped - 8 lines]
    >>
    >> Thanks!!

    >
    >It's a validation error.
    >
    >Go to Tools - Options - Text Editor - HTML - Validation
    >(or View - Toolbars - HTML Source Editing)
    >
    >and change the target schema for validation
    >
    >If this attribute (ms_2d_layout) is not needed, simply remove it from
    >your code


    Hi Alexey,

    Your information got me to a certain point, but I wasn't sure what to change
    the target schema to. I think that I had mentioned that I am new to ASP.NET,
    Visual Studio and C# and I may have forgotten XML. What should I be
    selecting?

    Thanks!!
    Mary

    --
    Message posted via DotNetMonster.com
    http://www.dotnetmonster.com/Uwe/Forums.aspx/asp-net/200707/1
     
    CdnRebel via DotNetMonster.com, Jul 3, 2007
    #3
  4. On Jul 3, 7:16 pm, "CdnRebel via DotNetMonster.com" <u35447@uwe>
    wrote:
    > Alexey Smirnov wrote:
    > >> Hi,

    >
    > >[quoted text clipped - 8 lines]

    >
    > >> Thanks!!

    >
    > >It's a validation error.

    >
    > >Go to Tools - Options - Text Editor - HTML - Validation
    > >(or View - Toolbars - HTML Source Editing)

    >
    > >and change the target schema for validation

    >
    > >If this attribute (ms_2d_layout) is not needed, simply remove it from
    > >your code

    >
    > Hi Alexey,
    >
    > Your information got me to a certain point, but I wasn't sure what to change
    > the target schema to. I think that I had mentioned that I am new to ASP.NET,
    > Visual Studio and C# and I may have forgotten XML. What should I be
    > selecting?
    >


    Mary,

    the target schema depends on your document. It's used for client-side
    markup validation (and intellisense + autocomplete). In your case, the
    problem is not really in the schema, but in the ms_2d_layout attribute
    which is not supported by selected target schema.

    http://msdn2.microsoft.com/en-us/library/f940516c(VS.80).aspx

    If you do not want to use validation, you can turn it off. For
    details, see

    How to: Set Validation Options for HTML Editing in Visual Web
    Developer.
    http://msdn2.microsoft.com/en-us/library/0byxkfet(VS.80).aspx

    Hope it helps
     
    Alexey Smirnov, Jul 4, 2007
    #4
  5. Alexey,

    Bo Chen on ASP.Net forums sent me the following info with regard to this
    problem, but they weren't as thorough as you about fixing the validation:


    First, you don't have to fix validation errors. They don't stop your program
    from running correctly.

    Second, ms_2d_layout is not known to be a valid attribute for table indeed.
    Likely, it is an additional attribute used somewhere in the client code. If
    it is true, just ignore the error.


    see original post at: http://www.mcse.ms/message2358272.html


    Thanks,
    Mary



    Alexey Smirnov wrote:
    >On Jul 3, 7:16 pm, "CdnRebel via DotNetMonster.com" <u35447@uwe>
    >wrote:
    >> >> Hi,

    >>

    >[quoted text clipped - 18 lines]
    >> Visual Studio and C# and I may have forgotten XML. What should I be
    >> selecting?

    >
    >Mary,
    >
    >the target schema depends on your document. It's used for client-side
    >markup validation (and intellisense + autocomplete). In your case, the
    >problem is not really in the schema, but in the ms_2d_layout attribute
    >which is not supported by selected target schema.
    >
    >http://msdn2.microsoft.com/en-us/library/f940516c(VS.80).aspx
    >
    >If you do not want to use validation, you can turn it off. For
    >details, see
    >
    >How to: Set Validation Options for HTML Editing in Visual Web
    >Developer.
    >http://msdn2.microsoft.com/en-us/library/0byxkfet(VS.80).aspx
    >
    >Hope it helps


    --
    Message posted via DotNetMonster.com
    http://www.dotnetmonster.com/Uwe/Forums.aspx/asp-net/200707/1
     
    CdnRebel via DotNetMonster.com, Jul 4, 2007
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. anonymous
    Replies:
    1
    Views:
    5,979
  2. =?Utf-8?B?TWFyaw==?=
    Replies:
    4
    Views:
    635
    =?Utf-8?B?TWFyaw==?=
    Dec 14, 2006
  3. perspolis
    Replies:
    1
    Views:
    2,591
    Mark Rae
    Jan 23, 2007
  4. Joe Kovac
    Replies:
    2
    Views:
    974
    Joe Kovac
    May 2, 2007
  5. Dan
    Replies:
    2
    Views:
    419
Loading...

Share This Page