ConfigurationSettings

Discussion in 'ASP .Net' started by Jason, Dec 3, 2004.

  1. Jason

    Jason Guest

    Hello all

    I have two web virtual directories
    http://localhost/publications
    http://localhost/main/publications
    both virtual directories point to the same location
    C:\inetpub\wwwroot\publications
    the first virtual directory works perfectly fine, as expected.
    the second does not. when the default page loads and i put a watch on the
    ConfigurationSettings class and inspect the AppSettings property, the length
    is 0. whereas the length is 3 if i debug the first virtual directory.

    any ideas why? obviosuly i need to get stuff outa AppSettings.

    Thanks
    Jason
    Jason, Dec 3, 2004
    #1
    1. Advertising

  2. Is the second virtual directory set up under its own application? That would
    account for the behaviour you have seen.

    "Jason" <> wrote in message
    news:...
    > Hello all
    >
    > I have two web virtual directories
    > http://localhost/publications
    > http://localhost/main/publications
    > both virtual directories point to the same location
    > C:\inetpub\wwwroot\publications
    > the first virtual directory works perfectly fine, as expected.
    > the second does not. when the default page loads and i put a watch on the
    > ConfigurationSettings class and inspect the AppSettings property, the
    > length
    > is 0. whereas the length is 3 if i debug the first virtual directory.
    >
    > any ideas why? obviosuly i need to get stuff outa AppSettings.
    >
    > Thanks
    > Jason
    >
    >
    Fredrik Elestedt, Dec 3, 2004
    #2
    1. Advertising

  3. Jason

    Jason Guest

    yes, you mean if i am in the virtual directory properties and click
    "Create"?

    the virtual directory is in it's own application then.

    Thanks
    Jason

    "Fredrik Elestedt" <> wrote in message
    news:...
    > Is the second virtual directory set up under its own application? That

    would
    > account for the behaviour you have seen.
    >
    > "Jason" <> wrote in message
    > news:...
    > > Hello all
    > >
    > > I have two web virtual directories
    > > http://localhost/publications
    > > http://localhost/main/publications
    > > both virtual directories point to the same location
    > > C:\inetpub\wwwroot\publications
    > > the first virtual directory works perfectly fine, as expected.
    > > the second does not. when the default page loads and i put a watch on

    the
    > > ConfigurationSettings class and inspect the AppSettings property, the
    > > length
    > > is 0. whereas the length is 3 if i debug the first virtual directory.
    > >
    > > any ideas why? obviosuly i need to get stuff outa AppSettings.
    > >
    > > Thanks
    > > Jason
    > >
    > >

    >
    >
    Jason, Dec 3, 2004
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Bassel Tabbara [MSFT]

    RE: ConfigurationSettings.AppSettings Error

    Bassel Tabbara [MSFT], Jul 2, 2003, in forum: ASP .Net
    Replies:
    1
    Views:
    686
    Bassel Tabbara [MSFT]
    Jul 7, 2003
  2. Rob Mayo
    Replies:
    6
    Views:
    424
    TJoker .NET [MVP]
    Sep 22, 2003
  3. Guest
    Replies:
    3
    Views:
    3,703
    =?Utf-8?B?TG9yaSBNY0RvbmFsZA==?=
    Feb 23, 2004
  4. [myfirstname]

    ConfigurationSettings vs Application State

    [myfirstname], Feb 19, 2004, in forum: ASP .Net
    Replies:
    1
    Views:
    654
    Teemu Keiski
    Feb 19, 2004
  5. =?Utf-8?B?Sk1E?=
    Replies:
    4
    Views:
    2,403
    Scott Allen
    Jun 30, 2004
Loading...

Share This Page